Try ERPNext Buy Support Partners Foundation

Need your help to solve the issue during Installation

Hello Team ,

I am getting following error , while doing the installation on ubuntu 18 .04 when I execute the command
erpnext@ERPNEXT:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.4 LTS
Release: 18.04
Codename: bionic

------------------------------------------------ERROR---------------------
erpnext@ERPNEXT:~$ bench --version
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:10: warning: constant Gem::ConfigMap is deprecated
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:10: warning: constant Gem::ConfigMap is deprecated
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:29: warning: constant Gem::ConfigMap is deprecated
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:30: warning: constant Gem::ConfigMap is deprecated
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb:10: warning: constant Gem::ConfigMap is deprecated
Traceback (most recent call last):
8: from /usr/bin/bench:6:in <main>' 7: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:143:in setup’
6: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:194:in definition' 5: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:81:in configure’
4: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:639:in configure_gem_home_and_path' 3: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:658:in configure_gem_home’
2: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:95:in bundle_path' 1: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:277:in root’
/var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:281:in `rescue in root’: Could not locate Gemfile or .bundle/ directory (Bundler::GemfileNotFound)
erpnext@ERPNEXT:~$

Can anyone help me.

Thanks
Debanjan Chakraborty
cell-+91-7276098372

Hello Team , Pl. help , need your advice to solve the issue

Hello Now I am getting following error

bench --version
Traceback (most recent call last):
8: from /usr/bin/bench:6:in <main>' 7: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:143:in setup’
6: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:194:in definition' 5: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:81:in configure’
4: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:639:in configure_gem_home_and_path' 3: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:658:in configure_gem_home’
2: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:95:in bundle_path' 1: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:277:in root’
/var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:281:in `rescue in root’: Could not locate Gemfile or .bundle/ directory (Bundler::GemfileNotFound)

Kindly help

Normally no need for ruby. You happened on say this prompt sudo apt install ruby-active-model-serializers

That’s an install misstep on your part, so best repeat your install.

To learn more check here Manual bench install error - what's this no Ruby required?

Shall I follow this steps

Debian / Ubuntu

Install git , python , and redis

sudo apt install git python-dev redis-server

Install MariaDB

sudo apt-get install software-properties-common
sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8
sudo add-apt-repository 'deb [arch=amd64,i386,ppc64el] http://ftp.ubuntu-tw.org/mirror/mariadb/repo/10.3/ubuntu xenial main'
sudo apt-get update
sudo apt-get install mariadb-server-10.3

During this installation you’ll be prompted to set the MySQL root password. If you are not prompted, you’ll have to initialize the MySQL server setup yourself. You can do that by running the command:

mysql_secure_installation

Remember: only run it if you’re not prompted the password during setup.

It is really important that you remember this password, since it’ll be useful later on. You’ll also need the MySQL database development files.

sudo apt-get install libmysqlclient-dev

Now, edit the MariaDB configuration file.

sudo nano /etc/mysql/my.cnf

And add this configuration

[mysqld]
character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci

[mysql]
default-character-set = utf8mb4

Now, just restart the mysql service and you are good to go.

sudo service mysql restart

Install Node

We recommend installing node using nvm

curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.33.11/install.sh | bash

After nvm is installed, you may have to close your terminal and open another one. Now run the following command to install node.

nvm install 8

Verify the installation, by running:

node -v
# output
v8.11.3

Finally, install yarn using npm

npm install -g yarn

Install wkhtmltopdf

sudo apt-get install xvfb libfontconfig wkhtmltopdf

Install Bench

Install bench as a non-root user

git clone https://github.com/frappe/bench bench-repo
pip install --user -e bench-repo

Confirm the bench installation by checking version

bench --version

# output
4.1.0

Create your first bench folder.

cd ~
bench init frappe-bench

After the frappe-bench folder is created, change your directory to it and run this command

bench start

As the posts here will attest, unfortunately installs can be a challenging exercise and learning experience.

Let this forum be your guide…

1 Like

Yes , Thank you for the help I have started . Here is the screen shot
bench@ERPNEXT:~/erpnext$ bench restart
$ sudo supervisorctl restart erpnext-workers: erpnext-web:
erpnext-workers:erpnext-frappe-schedule: stopped
erpnext-workers:erpnext-frappe-default-worker-0: stopped
erpnext-workers:erpnext-frappe-long-worker-0: stopped
erpnext-workers:erpnext-frappe-short-worker-0: stopped
erpnext-web:erpnext-node-socketio: stopped
erpnext-web:erpnext-frappe-web: stopped
erpnext-workers:erpnext-frappe-schedule: started
erpnext-workers:erpnext-frappe-default-worker-0: started
erpnext-workers:erpnext-frappe-long-worker-0: started
erpnext-workers:erpnext-frappe-short-worker-0: started
erpnext-web:erpnext-node-socketio: started
erpnext-web:erpnext-frappe-web: started

bench@ERPNEXT:~/erpnext$ sudo supervisorctl status all
erpnext-redis:erpnext-redis-cache RUNNING pid 12806, uptime 0:12:36
erpnext-redis:erpnext-redis-queue RUNNING pid 12805, uptime 0:12:36
erpnext-redis:erpnext-redis-socketio RUNNING pid 12810, uptime 0:12:36
erpnext-web:erpnext-frappe-web RUNNING pid 13739, uptime 0:02:18
erpnext-web:erpnext-node-socketio RUNNING pid 13738, uptime 0:02:19
erpnext-workers:erpnext-frappe-default-worker-0 RUNNING pid 13727, uptime 0:02:20
erpnext-workers:erpnext-frappe-long-worker-0 RUNNING pid 13728, uptime 0:02:20
erpnext-workers:erpnext-frappe-schedule RUNNING pid 13726, uptime 0:02:20
erpnext-workers:erpnext-frappe-short-worker-0 RUNNING pid 13729, uptime 0:02:20

Now need to understand , how I will get the UI screen in opera/internet explorer

Pl. help

Thanks

Debanjan Chakraborty

I am trying to get the UI by giving the IP address

http://192.168.0.106:8080/. Attached is the screen shot ,

Also wanted to understand what will be default userrid & password.
Need your help pl.

From you message it shows you have converted to production mode, so you are accessing on wrong port. The port is no longer 8000 or 8080 unless you did set it up in nginx. Its usually default port 80. You can open /etc/nginx/conf.d/frappe-bench.conf to check you settings.

Default Login is Administrator. If you forgot admin password try:

bench --site [site] set-admin-password [new password]

1 Like

I am trying to connect with the http://192.xxx.xx.xx:80 , I am getting following screen . Need your help to resolve.

Here is attached document for your reference .

Installation of ERPNext in Ubuntu 18.04 is very simple. Just use Easy Install. For me, I highly discourage using the manual steps because Easy Install does it all.

1 Like

use the easy install.

It is very straight forward.

All the manual installation is done without any errors. but after installing bench, when i check for the bench installation with $bench --version i am getting an error - “command ‘bench’ not found, but can be installed with: sudo apt install ruby-active-model-serializers”.
So it seems like we have to run the command to install ruby. But even if we run the command “sudo apt install ruby-active-model-serializers”, we still get the error :
Traceback (most recent call last):
8: from /usr/bin/bench:6:in <main>' 7: from /var/lib/gems/2.5.0/gems/bundler-2.1.4/lib/bundler.rb:143:in setup’

Please Do provide me with a correct installation document or a video if there is any. It will be really useful.

emailID: vkj5555@gmail.com

you need to cd into the bench directory for the bench command. This error shows when you execute the bench command at the wrong directory. (I don’t know what user or bench directory you used for the manual installation so I cannot give a command sequence).

1 Like

Everything went well. Got bench also installed. I did cd to frappe-bench folder ( $cd frappe-bench/ ).
And when i run $ bench start, i am getting this error:
Traceback (most recent call last):
File “/home/vinod/.local/bin/bench”, line 11, in
load_entry_point(‘frappe-bench’, ‘console_scripts’, ‘bench’)()
File “/home/vinod/bench-repo/bench/cli.py”, line 45, in cli
if sys.argv[1] in get_frappe_commands() + ["–site", “–verbose”, “–force”, “–profile”]:
TypeError: unsupported operand type(s) for +: ‘NoneType’ and ‘list’

Help me out please…

Everything went well. Got bench also installed. I did cd to frappe-bench folder ( $cd frappe-bench/ ).
And when i run $ bench start, i am getting this error:
Traceback (most recent call last):
File “/home/vinod/.local/bin/bench”, line 11, in
load_entry_point(‘frappe-bench’, ‘console_scripts’, ‘bench’)()
File “/home/vinod/bench-repo/bench/cli.py”, line 45, in cli
if sys.argv[1] in get_frappe_commands() + ["–site", “–verbose”, “–force”, “–profile”]:
TypeError: unsupported operand type(s) for +: ‘NoneType’ and ‘list’

Help me out please…

Easy Install is not easy …
they need to put some best practice checking into the easy install script

  • the script should know which version of OS it support and make sure it’s been install on one of those.
  • the script should know which packages works with which version of the OS, and which version of ERPNext to install.

it is not !!!

thanks for the reply. I got it how. we just have to close and restart the system and open a new terminal and try for the bench version. And you will get it. Make sure you cd to the frappe-bench/ folder and try.

Hello,
Everything went well. Got bench also installed. I did cd to frappe-bench folder ( $cd frappe-bench/ ).
And when i run $ bench start, i am getting this error:
Traceback (most recent call last):
File “/home/vinod/.local/bin/bench”, line 11, in
load_entry_point(‘frappe-bench’, ‘console_scripts’, ‘bench’)()
File “/home/vinod/bench-repo/bench/cli.py”, line 45, in cli
if sys.argv[1] in get_frappe_commands() + ["–site", “–verbose”, “–force”, “–profile”]:
TypeError: unsupported operand type(s) for +: ‘NoneType’ and ‘list’

Help me out please…