Try ERPNext Buy Support Partners Foundation

Need your help to solve the issue during Installation

hello,
I went through all of your errors. I did follow the steps mentioned above. But when i am trying to start the bench i am getting an error.

Please help.
Email: vkj5555@gmail.com

Hello,
Everything went well. Got bench also installed. I did cd to frappe-bench folder ( $cd frappe-bench/ ).
And when i run $ bench start, i am getting this error:
Traceback (most recent call last):
File “/home/vinod/.local/bin/bench”, line 11, in
load_entry_point(‘frappe-bench’, ‘console_scripts’, ‘bench’)()
File “/home/vinod/bench-repo/bench/cli.py”, line 45, in cli
if sys.argv[1] in get_frappe_commands() + ["–site", “–verbose”, “–force”, “–profile”]:
TypeError: unsupported operand type(s) for +: ‘NoneType’ and ‘list’

Help me out please…

In production you don’t have to do bench start It starts with server. This is needed only for develop branch. Your site should be online.

Hello,
when i start my bench i am getting this error shown below:

~/erpnext/frappe-bench$ bench start
WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench

14:21:48 system | redis_socketio.1 started (pid=5893)
14:21:48 redis_socketio.1 | 5900:C 01 Jul 14:21:48.416 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
14:21:48 redis_socketio.1 | 5900:C 01 Jul 14:21:48.416 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=5900, just started
14:21:48 redis_socketio.1 | 5900:C 01 Jul 14:21:48.416 # Configuration loaded
14:21:48 redis_socketio.1 | 5900:M 01 Jul 14:21:48.416 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
14:21:48 redis_socketio.1 | 5900:M 01 Jul 14:21:48.416 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
14:21:48 redis_socketio.1 | 5900:M 01 Jul 14:21:48.416 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
14:21:48 redis_socketio.1 | 5900:M 01 Jul 14:21:48.417 * Running mode=standalone, port=12000.
14:21:48 redis_socketio.1 | 5900:M 01 Jul 14:21:48.417 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:21:48 redis_socketio.1 | 5900:M 01 Jul 14:21:48.417 # Server initialized
14:21:48 redis_socketio.1 | 5900:M 01 Jul 14:21:48.417 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:21:48 redis_socketio.1 | 5900:M 01 Jul 14:21:48.417 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:21:48 redis_socketio.1 | 5900:M 01 Jul 14:21:48.417 * Ready to accept connections
14:21:48 system | worker_long.1 started (pid=5898)
14:21:48 system | worker_default.1 started (pid=5912)
14:21:48 system | socketio.1 started (pid=5906)
14:21:48 system | watch.1 started (pid=5907)
14:21:48 system | redis_cache.1 started (pid=5911)
14:21:48 redis_cache.1 | 5929:C 01 Jul 14:21:48.456 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
14:21:48 redis_cache.1 | 5929:C 01 Jul 14:21:48.456 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=5929, just started
14:21:48 redis_cache.1 | 5929:C 01 Jul 14:21:48.456 # Configuration loaded
14:21:48 redis_cache.1 | 5929:M 01 Jul 14:21:48.456 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
14:21:48 redis_cache.1 | 5929:M 01 Jul 14:21:48.456 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
14:21:48 redis_cache.1 | 5929:M 01 Jul 14:21:48.456 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
14:21:48 redis_cache.1 | 5929:M 01 Jul 14:21:48.456 * Running mode=standalone, port=13000.
14:21:48 redis_cache.1 | 5929:M 01 Jul 14:21:48.457 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:21:48 redis_cache.1 | 5929:M 01 Jul 14:21:48.457 # Server initialized
14:21:48 redis_cache.1 | 5929:M 01 Jul 14:21:48.457 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:21:48 redis_cache.1 | 5929:M 01 Jul 14:21:48.457 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:21:48 redis_cache.1 | 5929:M 01 Jul 14:21:48.457 * Ready to accept connections
14:21:48 system | worker_short.1 started (pid=5908)
14:21:48 system | redis_queue.1 started (pid=5928)
14:21:48 redis_queue.1 | 5937:C 01 Jul 14:21:48.472 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
14:21:48 redis_queue.1 | 5937:C 01 Jul 14:21:48.472 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=5937, just started
14:21:48 redis_queue.1 | 5937:C 01 Jul 14:21:48.472 # Configuration loaded
14:21:48 redis_queue.1 | 5937:M 01 Jul 14:21:48.472 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
14:21:48 redis_queue.1 | 5937:M 01 Jul 14:21:48.472 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
14:21:48 redis_queue.1 | 5937:M 01 Jul 14:21:48.472 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
14:21:48 redis_queue.1 | 5937:M 01 Jul 14:21:48.473 * Running mode=standalone, port=11000.
14:21:48 redis_queue.1 | 5937:M 01 Jul 14:21:48.473 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
14:21:48 redis_queue.1 | 5937:M 01 Jul 14:21:48.473 # Server initialized
14:21:48 redis_queue.1 | 5937:M 01 Jul 14:21:48.473 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
14:21:48 redis_queue.1 | 5937:M 01 Jul 14:21:48.473 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
14:21:48 redis_queue.1 | 5937:M 01 Jul 14:21:48.473 * Ready to accept connections
14:21:48 system | web.1 started (pid=5910)
14:21:48 system | schedule.1 started (pid=5909)
14:21:49 watch.1 | WARN: bench is installed in editable mode!
14:21:49 watch.1 |
14:21:49 watch.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
14:21:49 watch.1 |
14:21:49 socketio.1 | listening on *: 9000
14:21:49 schedule.1 | WARN: bench is installed in editable mode!
14:21:49 schedule.1 |
14:21:49 schedule.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
14:21:49 schedule.1 |
14:21:49 web.1 | WARN: bench is installed in editable mode!
14:21:49 web.1 |
14:21:49 web.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
14:21:49 web.1 |
14:21:50 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
14:21:50 web.1 | * Restarting with inotify reloader
14:21:50 watch.1 | yarn run v1.22.4
14:21:50 watch.1 | $ node rollup/watch.js
14:21:50 web.1 | * Debugger is active!
14:21:50 web.1 | * Debugger PIN: 212-417-661
14:21:51 watch.1 |
14:21:51 watch.1 | Rollup Watcher Started
14:21:51 watch.1 |
14:21:51 watch.1 | Watching…
14:21:51 watch.1 | Rebuilding frappe-web.css
14:21:51 watch.1 | Rebuilding chat.js
14:21:52 watch.1 | Rebuilding frappe-web.min.js
14:21:53 watch.1 | Rebuilding control.min.js
14:21:54 watch.1 | Rebuilding dialog.min.js
14:21:54 watch.1 | Rebuilding desk.min.css
14:21:54 watch.1 | Rebuilding frappe-rtl.css
14:21:54 watch.1 | Rebuilding desk.min.js
14:21:56 watch.1 | Rebuilding module.min.css
14:21:56 watch.1 | Rebuilding form.min.css
14:21:56 watch.1 | Rebuilding form.min.js
14:21:56 watch.1 | (node:6008) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 change listeners added. Use emitter.setMaxListeners() to increase limit
14:21:57 watch.1 | Rebuilding list.min.css
14:21:57 watch.1 | Rebuilding list.min.js
14:21:57 watch.1 | Rebuilding report.min.css
14:21:57 watch.1 | Rebuilding report.min.js
14:21:58 web.1 | 0.0.0.0 does not exist
14:21:58 web.1 | 0.0.0.0 does not exist
14:21:58 web.1 | 0.0.0.0 does not exist
14:21:58 watch.1 | Rebuilding web_form.min.js
14:21:58 watch.1 | Rebuilding web_form.css
14:21:58 watch.1 | Rebuilding print_format_v3.min.js
14:21:59 watch.1 | Rebuilding email.css
14:21:59 watch.1 | Rebuilding erpnext.css
14:21:59 watch.1 | Rebuilding marketplace.css
14:21:59 watch.1 | Rebuilding erpnext-web.min.js
14:21:59 watch.1 | Rebuilding erpnext-web.css
14:21:59 watch.1 | Rebuilding marketplace.min.js
14:22:00 watch.1 | Rebuilding erpnext.min.js
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 watch.1 | Rebuilding item-dashboard.min.js
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:01 web.1 | 0.0.0.0 does not exist
14:22:50 schedule.1 | Traceback (most recent call last):
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/apps/frappe/frappe/utils/scheduler.py”, line 73, in enqueue_events_for_all_sites
14:22:50 schedule.1 | enqueue_events_for_site(site=site, queued_jobs=jobs_per_site[site])
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/apps/frappe/frappe/utils/scheduler.py”, line 105, in enqueue_events_for_site
14:22:50 schedule.1 | log_and_raise()
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/apps/frappe/frappe/utils/scheduler.py”, line 93, in enqueue_events_for_site
14:22:50 schedule.1 | if is_scheduler_disabled():
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/apps/frappe/frappe/utils/scheduler.py”, line 237, in is_scheduler_disabled
14:22:50 schedule.1 | return not frappe.utils.cint(frappe.db.get_single_value(“System Settings”, “enable_scheduler”))
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/apps/frappe/frappe/database.py”, line 642, in get_single_value
14:22:50 schedule.1 | tabSingles where doctype=%s and field=%s""", (doctype, fieldname))
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/apps/frappe/frappe/database.py”, line 199, in sql
14:22:50 schedule.1 | self._cursor.execute(query, values)
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/env/lib/python3.6/site-packages/pymysql/cursors.py”, line 170, in execute
14:22:50 schedule.1 | result = self._query(query)
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/env/lib/python3.6/site-packages/pymysql/cursors.py”, line 328, in _query
14:22:50 schedule.1 | conn.query(q)
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/env/lib/python3.6/site-packages/pymysql/connections.py”, line 517, in query
14:22:50 schedule.1 | self._affected_rows = self._read_query_result(unbuffered=unbuffered)
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/env/lib/python3.6/site-packages/pymysql/connections.py”, line 732, in _read_query_result
14:22:50 schedule.1 | result.read()
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/env/lib/python3.6/site-packages/pymysql/connections.py”, line 1075, in read
14:22:50 schedule.1 | first_packet = self.connection._read_packet()
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/env/lib/python3.6/site-packages/pymysql/connections.py”, line 684, in _read_packet
14:22:50 schedule.1 | packet.check_error()
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/env/lib/python3.6/site-packages/pymysql/protocol.py”, line 220, in check_error
14:22:50 schedule.1 | err.raise_mysql_exception(self._data)
14:22:50 schedule.1 | File “/home/xtract/erpnext/frappe-bench/env/lib/python3.6/site-packages/pymysql/err.py”, line 109, in raise_mysql_exception
14:22:50 schedule.1 | raise errorclass(errno, errval)
14:22:50 schedule.1 | pymysql.err.ProgrammingError: (1146, “Table ‘21c260ad3e52789f.tabSingles’ doesn’t exist”)
14:22:50 schedule.1 |

please help me if anybody knows about it…
Thank You.