Try ERPNext Buy Support Partners Foundation

[Beta] Frappe Mobile built on Flutter(Android/iOS)

Hello Community,

Since past few months, We at Frappe are working on Mobile App for Frappe Framework v13 (branch: develop), you can download latest build here


Fork, Star, Report Issues, Contribute :metal:

Screenshots:

Current Features:

  • Offline First (Data is automatically fetched in background every 30 mins)
  • Create/Update Docs (queued when offline and processed automatically when reconnected to internet)
  • Add/Remove Assignees, Tags
  • Add/Remove/Download Attachments
  • Add Comments, Send Email
  • Appreciate/Criticize Users involved in specified Doc.
  • Timeline
  • Awesombar
33 Likes

Sorry for the language, but it is f****** awsome! Go ERPNext go! :smiley:

4 Likes

Congratulations
We really appreciate the effort you are doing here.
I am sure that Frappe framework will have a bright future.
will test and give feedback as soon as possible.

2 Likes

Great initiative, I couldn’t expect more exciting news about a mobile App.
Will also test as soon as possible and give a feedback.
Thanks again to the Frappe team :clap:

1 Like

Great to hear good news. :ok_hand:

1 Like

Great stuff. Not able to login on Android. Shows Verifying and then button goes back to Login.

are you using latest v13 version of Frappe Framework?

ERPNext: v13.0.0-beta.11 (version-13-beta)

Frappe Framework: v13.0.0-beta.10 (version-13-beta)

That’s my build. Thank you for quick response.

1 Like

@sumitbhanushali Same issue with me. and i think it’s not working with http url, right?

I tried with https:// and without it. Both dont work.
https://erp.mysite.com/ and erp.mysite.com

These are dummy URL

is this site live? because i am unable to access it

yes, my ERPNext url is live.

@sumitbhanushali

Here is log

2021-02-19 16:29:41.206303+0530 Runner[57896:358971] [VERBOSE-2:ui_dart_state.cc(177)] Unhandled Exception: NoSuchMethodError: Class ‘_TypeError’ has no instance getter ‘statusMessage’.

Receiver: Instance of '_TypeError’

Tried calling: statusMessage

#0 Object.noSuchMethod (dart:core-patch/object_patch.dart:54:5)

#1 LoginViewModel.login (package:frappe_app/views/login/login_viewmodel.dart:99:22)

#2 Login.build.. (package:frappe_app/views/login/login_view.dart:100:48)

My site is live on a VPS. Am logged in on browser.

Thanks for the log, I checked the issue, actually API response has been changed in latest develop branch of Frappe Framework, hence you are unable to login. @Muzzy also might have same issue

Most welcome bro, I have to contribute more and more to ERPNext and Frappe.

It is supporting custom script?

2 Likes

Finally!!! Awesoooooome stuff

…I’d also like to know the situation with custom scripts

+1 here