What's Happened with Frappe ?! No longer supported ? Installation V13 IMPOSSIBLE

Hello, I would like to know what is going on with Frappé.

No Stable installation procedure, whatever the Operating System:

  1. Either we have a “returned non-zero exit status 2” problem

  2. Either the installation works but with the message “Sorry, we will be back soon”

If you find it hard to get support for this app, please let us know, it will prevent people like me from investing in this framework, thanks

what os did you try with? what steps or tutorial did you follow docker / bench / ova ?? where did you try to install it like aws or digital ocean or on your machine ?

Hello @YannCoppryDigital,

I am sorry for the troubles you are having. I was also struggling with the installation of ERPNext for a couple of days before I went with the Docker install following these instructions:

With this I was able to install it with no problems all the times for all the tests that I had to do.

I was resisting to go with Docker for years but it is not so horribly difficult as it seems, although I am only at 0,2% of it.

Althought it is not all perfect with this. App installation seems to be a nightmare, and I am still trying to find if it is possible to switch from develop to stable in docker version. But I am afraid it wont be possible.

bench switch-to-branch version-13 frappe erpnext --upgrade

I wish you luck.

Kind regards,

Alb

Hi,

Well, replying to my doubts of switching from develop to stable, it is possible:

1.- As indicated on the lower part of this page:

2.- With nano .env you change erpnext and frappe versions from edge to version-13

3.- You do docker-compose pull

4.- And then docker-compose --project-name <project-name> up -d

5.- You have to do a migration afterwards

6.- For this you go to the bash of python container: docker exec -it yourproject_erpnext-python_1 bash

7.- And on that container you perform the migration: bench --site yoursitename migrate

8.- Then probably you will find problem with a duplicate key as I did:

pymysql.err.IntegrityError: (1062, "Duplicate entry 'Item' for key 'reference_doctype'")

9.- I opted for deleting the complete row of the table, and in that way I was able to finish the migration and move to version 13 stable

I hope this is of any help.

Kind regards,

Alb

The message you’re receiving “Sorry, we will be back soon” just means the site is in “maintenance mode” just run bench set-maintenance-mode off also, run bench restart to make sure all services are running.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.