Try ERPNext Buy Support Partners Foundation

V 12.4 bench update error

Auto-merging cypress/integration/form.js
CONFLICT (content): Merge conflict in cypress/integration/form.js
Automatic merge failed; fix conflicts and then commit the result.
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/sanath/.bench/bench/cli.py”, line 40, in cli
bench_command()
File “/usr/local/lib/python3.5/dist-packages/click/core.py”, line 764, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python3.5/dist-packages/click/core.py”, line 717, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python3.5/dist-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python3.5/dist-packages/click/core.py”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python3.5/dist-packages/click/core.py”, line 555, in invoke
return callback(*args, **kwargs)
File “/home/sanath/.bench/bench/commands/update.py”, line 68, in update
_update(pull, patch, build, bench, auto, restart_supervisor, restart_systemd, requirements, no_backup, force=force, reset=reset)
File “/home/sanath/.bench/bench/commands/update.py”, line 88, in _update
pull_all_apps(bench_path=bench_path, reset=reset)
File “/home/sanath/.bench/bench/app.py”, line 249, in pull_all_apps
remote=remote, branch=get_current_branch(app, bench_path=bench_path)), cwd=app_dir)
File “/home/sanath/.bench/bench/utils.py”, line 188, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git pull upstream version-12
sanath@vmi322735:~/frappe-bench$

I am getting this when I do bench update.
I do not understand still ERP next break when we do update, upgrade, install etc…

That is unfortunate.

Any solution for this?

1 Like

sanath@vmi322735:~/frappe-bench$ bench update
INFO:bench.utils:Updating bench
INFO:bench.utils:git pull
Already up-to-date.
INFO:bench.utils:Bench Updated!
INFO:bench.utils:./env/bin/pip install Pillow
Requirement already satisfied: Pillow in ./env/lib/python3.5/site-packages (6.2.1)
Backing up sites…
Traceback (most recent call last):
File “/home/sanath/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 66, in get_app_commands
app_command_module = importlib.import_module(app + ‘.commands’)
File “/home/sanath/frappe-bench/env/lib/python3.5/importlib/init.py”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 986, in _gcd_import
File “”, line 969, in _find_and_load
File “”, line 958, in _find_and_load_unlocked
File “”, line 673, in _load_unlocked
File “”, line 673, in exec_module
File “”, line 222, in _call_with_frames_removed
File “/home/sanath/frappe-bench/apps/frappe/frappe/commands/init.py”, line 82, in
commands = get_commands()
File “/home/sanath/frappe-bench/apps/frappe/frappe/commands/init.py”, line 76, in get_commands
from .site import commands as site_commands
File “/home/sanath/frappe-bench/apps/frappe/frappe/commands/site.py”, line 8, in
from frappe.installer import update_site_config
File “/home/sanath/frappe-bench/apps/frappe/frappe/installer.py”, line 17, in
from frappe.utils.fixtures import sync_fixtures
File “/home/sanath/frappe-bench/apps/frappe/frappe/utils/fixtures.py”, line 7, in
from frappe.core.doctype.data_import.data_import import import_doc, export_json
File “/home/sanath/frappe-bench/apps/frappe/frappe/core/doctype/data_import/data_import.py”, line 11, in
from frappe.core.doctype.data_import.importer import upload
File “/home/sanath/frappe-bench/apps/frappe/frappe/core/doctype/data_import/importer.py”, line 16, in
from frappe.utils.dateutils import parse_date
File “/home/sanath/frappe-bench/apps/frappe/frappe/utils/dateutils.py”, line 6, in
import frappe.defaults
File “/home/sanath/frappe-bench/apps/frappe/frappe/defaults.py”, line 7, in
from frappe.cache_manager import clear_defaults_cache, common_default_keys
File “/home/sanath/frappe-bench/apps/frappe/frappe/cache_manager.py”, line 119
<<<<<<< HEAD
^
SyntaxError: invalid syntax
Traceback (most recent call last):
File “/home/sanath/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 66, in get_app_commands
app_command_module = importlib.import_module(app + ‘.commands’)
File “/home/sanath/frappe-bench/env/lib/python3.5/importlib/init.py”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 986, in _gcd_import
File “”, line 969, in _find_and_load
File “”, line 958, in _find_and_load_unlocked
File “”, line 673, in _load_unlocked
File “”, line 673, in exec_module
File “”, line 222, in _call_with_frames_removed
File “/home/sanath/frappe-bench/apps/erpnext/erpnext/commands/init.py”, line 7, in
from frappe.commands import pass_context, get_site
File “/home/sanath/frappe-bench/apps/frappe/frappe/commands/init.py”, line 82, in
commands = get_commands()
File “/home/sanath/frappe-bench/apps/frappe/frappe/commands/init.py”, line 76, in get_commands
from .site import commands as site_commands
File “/home/sanath/frappe-bench/apps/frappe/frappe/commands/site.py”, line 8, in
from frappe.installer import update_site_config
File “/home/sanath/frappe-bench/apps/frappe/frappe/installer.py”, line 17, in
from frappe.utils.fixtures import sync_fixtures
File “/home/sanath/frappe-bench/apps/frappe/frappe/utils/fixtures.py”, line 7, in
from frappe.core.doctype.data_import.data_import import import_doc, export_json
File “/home/sanath/frappe-bench/apps/frappe/frappe/core/doctype/data_import/data_import.py”, line 11, in
from frappe.core.doctype.data_import.importer import upload
File “/home/sanath/frappe-bench/apps/frappe/frappe/core/doctype/data_import/importer.py”, line 16, in
from frappe.utils.dateutils import parse_date
File “/home/sanath/frappe-bench/apps/frappe/frappe/utils/dateutils.py”, line 6, in
import frappe.defaults
File “/home/sanath/frappe-bench/apps/frappe/frappe/defaults.py”, line 7, in
from frappe.cache_manager import clear_defaults_cache, common_default_keys
File “/home/sanath/frappe-bench/apps/frappe/frappe/cache_manager.py”, line 119
<<<<<<< HEAD
^
SyntaxError: invalid syntax
Usage: bench frappe [OPTIONS] COMMAND [ARGS]…
Try “bench frappe --help” for help.

Error: No such command “backup”.
sanath@vmi322735:~/frappe-bench$

i have same problem too…how to fix it?

Welcome to ERPNext!

One option to overcome a merge conflict is to try this Broken after bench update