URL to use for production systems

Hi All

from docuemtnation Ic an see that a http://localhost:8000 is used to test the installation.

what about testing the same from other remote node ?
mainly what is the port to use?

is there any detail guide or Framwork Diagram to udnerstand the ALL system?

@spect

Your server will listen at port 8000 for ERPNext. So if you can send request from remote node to your server at port 8000 you can access ERPNext.

You can edit your procfile to start the main process at another port

In your frappe-bench\Procfile, edit:

web: bench serve --port 8001

Thanks Metha for your quick answer.

I’m wondering if there is a sort of detailed procedure/Manual for basic tasks like this. I was not able to find it. moreover at least for daily basif maintenance I need to have ready to use instructions otherwise maintenance of the ERPNext/Frappe could result in very expensive sofwtare to mantain and this is out of our badget.

thank for your support

that’s not correct.
here we have network expert . they found localhost/127.0.0.1 is just for internal access not addressable from outside. moreover no 8000 port is in listebning mode for the other IP configured to the host.
8000 port is used for internal wsgi interface.

when cpoming from outside you have to use nginx listening port.

Hello

My erpnext is not showing desk after login.please help

Uncaught TypeError: Cannot read property ‘forEach’ of undefined
at init.load_bootinfo (pageview.js:184)
at init.startup (pageview.js:53)
at new init (pageview.js:45)
at Object.frappe.start_app (pageview.js:22)
at HTMLDocument. (pageview.js:24)
at i (jquery.min.js:2)
at Object.fireWith [as resolveWith] (jquery.min.js:2)
at Function.ready (jquery.min.js:2)
at HTMLDocument.J (jquery.min.js:2)
libs.min.js?ver=1575998982.0:235 WebSocket connection to ‘ws://168.235.109.49:8008/socket.io/?EIO=3&transport=websocket&sid=DAYEdW0jKLvKmAYZAAAA’ failed: Error during WebSocket handshake: Unexpected response code: 400
n.doOpen @ libs.min.js?ver=1575998982.0:235
socket.io/?EIO=3&transport=polling&t=MyUO1S4&sid=DAYEdW0jKLvKmAYZAAAA:1 Failed to load resource: the server responded with a status of 502 (Bad Gateway)
socket.io/?EIO=3&transport=polling&t=MyUO3XE&sid=DAYEdW0jKLvKmAYZAAAA:1 Failed to load resource: the server responded with a status of 502 (Bad Gateway)
socket.io/?EIO=3&transport=polling&t=MyUO3na:1 Failed to load resource: the server responded with a status of 502 (Bad Gateway)
socket.io/?EIO=3&transport=polling&t=MyUO4m4:1 Failed to load resource: the server responded with a status of 502 (Bad Gateway)
libs.min.js?ver=1575998982.0:235 WebSocket connection to ‘ws://168.235.109.49:8008/socket.io/?EIO=3&transport=websocket&sid=oQtPnMeXOC7z6OWdAAAA’ failed: Error during WebSocket handshake: Unexpected response code: 400

Please give details re version, environment and working history of your instance?

Here’s a long list of clues!