Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

Upgrading v12 to V13

I just install ERPNext on Digital Ocean and discovered that the version i installed is version 12, but what i want is version 13, how do i upgrade the ERPNext

Use this link.

This is not working yet. I think we need to change the node source to

curl -fsSL https://deb.nodesource.com/setup_14.x | sudo -E bash -

Also take a backup of the server before doing bench switch-to-branch… Saves a lot of time :slight_smile:

This fails when on custom scripts. Don’t know why.

Traceback (most recent call last):
File “/srv/bench/frappe-bench/apps/frappe/frappe/modules/utils.py”, line 203, in load_doctype_module
doctype_python_modules[key] = frappe.get_module(module_name)
File “/srv/bench/frappe-bench/apps/frappe/frappe/init.py”, line 941, in get_module
return importlib.import_module(modulename)
File “/srv/bench/frappe-bench/env/lib/python3.8/importlib/init.py”, line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 1014, in _gcd_import
File “”, line 991, in _find_and_load
File “”, line 961, in _find_and_load_unlocked
File “”, line 219, in _call_with_frames_removed
File “”, line 1014, in _gcd_import
File “”, line 991, in _find_and_load
File “”, line 973, in _find_and_load_unlocked
ModuleNotFoundError: No module named ‘frappe.core.doctype.custom_script’

@satishvijayan In version 13 doctype Custom Script is changed to Client Script

if you have custom app . then follow below steps

  1. goto custom_app/fixtures/custom_script.json . change ‘Custom Script’ to ‘Client Script’ from custom_script.json
  2. rename custom/fixtures/custom_script.json to custom/fixtures/client_script.json
  3. goto custom_app /hook.py , then change “dt”: “Custom Script” to “dt”: “Client Script”
1 Like

That is great, thanks!!!

Along the same lines. I get the same error for desk_page.

I deleted desk_page.json and it sailed through. I have to recreated the desk-pages, but that is not so painful.