Upgrading ERPNext from Version 13 to 14 on VirtualBox

Hi,

I am trying to upgrade ERPNext Version-13 to Version-14 on VM.

Can someone list here all the commands to install ERPNext Version 14 successfully?

I run this command.

bench switch-to-branch version-14 frappe erpnext --upgrade

I am getting below errors
ERROR: Command errored out with exit status 1:
command: /home/frappe/frappe-bench/env/bin/python /home/frappe/frappe-bench/env/lib/python3.6/site-packages/pip/_vendor/pep517/in_process/_in_process.py get_requires_for_build_editable /tmp/tmpb2gxcg5l
cwd: /home/frappe/frappe-bench/apps/frappe
Complete output (17 lines):
Traceback (most recent call last):
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pip/_vendor/pep517/in_process/_in_process.py”, line 363, in
main()
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pip/_vendor/pep517/in_process/_in_process.py”, line 345, in main
json_out[‘return_val’] = hook(**hook_input[‘kwargs’])
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/pip/_vendor/pep517/in_process/_in_process.py”, line 144, in get_requires_for_build_editable
return hook(config_settings)
File “/tmp/pip-build-env-_hoao3rn/overlay/lib/python3.6/site-packages/flit_core/buildapi.py”, line 32, in get_requires_for_build_wheel
docstring, version = get_docstring_and_version_via_ast(module)
File “/tmp/pip-build-env-_hoao3rn/overlay/lib/python3.6/site-packages/flit_core/common.py”, line 132, in get_docstring_and_version_via_ast
node = ast.parse(f.read())
File “/usr/lib/python3.6/ast.py”, line 35, in parse
return compile(source, filename, mode, PyCF_ONLY_AST)
File “”, line 1080
if key := can_cache_doc(args):
^
SyntaxError: invalid syntax
WARNING: Discarding file:///home/frappe/frappe-bench/apps/frappe. Command errored out with exit status 1: /home/frappe/frappe-bench/env/bin/python /home/frappe/frappe-bench/env/lib/python3.6/site-packages/pip/_vendor/pep517/in_process/_in_process.py get_requires_for_build_editable /tmp/tmpb2gxcg5l Check the logs for full command output.
ERROR: Command errored out with exit status 1: /home/frappe/frappe-bench/env/bin/python /home/frappe/frappe-bench/env/lib/python3.6/site-packages/pip/_vendor/pep517/in_process/_in_process.py get_requires_for_build_editable /tmp/tmpb2gxcg5l Check the logs for full command output.
ERROR:
Traceback (most recent call last):
File “/home/frappe/.local/bin/bench”, line 8, in
sys.exit(cli())
File “/home/frappe/.local/lib/python3.6/site-packages/bench/cli.py”, line 121, in cli
raise e
File “/home/frappe/.local/lib/python3.6/site-packages/bench/cli.py”, line 111, in cli
bench_command()
File “/usr/local/lib/python3.6/dist-packages/click/core.py”, line 764, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python3.6/dist-packages/click/core.py”, line 717, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python3.6/dist-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python3.6/dist-packages/click/core.py”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python3.6/dist-packages/click/core.py”, line 555, in invoke
return callback(*args, **kwargs)
File “/home/frappe/.local/lib/python3.6/site-packages/bench/commands/update.py”, line 41, in switch_to_branch
switch_to_branch(branch=branch, apps=list(apps), upgrade=upgrade)
File “/home/frappe/.local/lib/python3.6/site-packages/bench/utils/app.py”, line 103, in switch_to_branch
switch_branch(branch, apps=apps, bench_path=bench_path, upgrade=upgrade)
File “/home/frappe/.local/lib/python3.6/site-packages/bench/utils/app.py”, line 95, in switch_branch
Bench(bench_path).setup.requirements()
File “/home/frappe/.local/lib/python3.6/site-packages/bench/utils/render.py”, line 95, in wrapper_fn
return fn(*args, **kwargs)
File “/home/frappe/.local/lib/python3.6/site-packages/bench/bench.py”, line 444, in requirements
skip_assets=True, restart_bench=False, ignore_resolution=True
File “/home/frappe/.local/lib/python3.6/site-packages/bench/utils/render.py”, line 110, in wrapper_fn
return fn(*args, **kwargs)
File “/home/frappe/.local/lib/python3.6/site-packages/bench/app.py”, line 239, in install
resolution=self.local_resolution
File “/home/frappe/.local/lib/python3.6/site-packages/bench/app.py”, line 553, in install_app
bench.run(f"{bench.python} -m pip install {quiet_flag} --upgrade -e {app_path} {cache_flag}")
File “/home/frappe/.local/lib/python3.6/site-packages/bench/bench.py”, line 47, in run
return exec_cmd(cmd, cwd=cwd or self.cwd)
File “/home/frappe/.local/lib/python3.6/site-packages/bench/utils/init.py”, line 153, in exec_cmd
raise CommandFailedError
bench.exceptions.CommandFailedError

@stepsibg

May this helps: