UOM search doesn't work anymore

Hi,
When creating a new Item, typing in UOM box no longer presents the items and i only have advance search and create new uom. advance search is empty too.
The UOMs are all there in UOM list and if i type nos and TAB it recognizes it as Nos.

check the role permission of the UOM of your user.
to do that go to Role Permissions Manager
search for UOM and click select , read , and create for your user

I am the Administrator.

anyone else experiencing this?
I did a bench update --reset to be sure. it’s still there.

can you share doctype and form field which is not auto-completing?

New Item.
any UOM field (both default and UOM table)

Any news if this is a bug or just me?

Did you check the UOM doctype list? Is the UOM item enable?

Yes, and non of the UOMs show up. It’s not just NOS or square meter.

I faced this locally too. Root cause is UOM are disabled by default. If you enable them you’ll be able to start seeing them in auto-complete.

You can do “bulk edit” and enable the ones you use frequently. I’ll think of a fix/patch.

OMG yeah. does it happen after each update?
I can bulk enable them so it’s not a big problem.

No enabled should stay enabled after update too.

open issue on github for tracking: https://github.com/frappe/erpnext/issues/28749