Unable To Run Scheduled Tasks

**I try to run the schedule tasks in version 8 it not work ** I follow this link https://frappe.github.io/frappe/user/en/tutorial/task-runner I run bench execute library_management.tasks.all it working but its not working automatically I also check the scheduler status and also enable the scheduler with bench command but its still not working. kindly help

@saboorkhan123

Seems like your scheduler are not enable.

Try, bench enable-scheduler command.

Yes I enable the enable-scheduler command but its still not working

@saboorkhan123,

run the bench enable-scheduler command with --site parameter

e.g. bench --site your_sitename enable-scheduler

it will enable the scheduler for the site your_sitename site, to check the which site has running scheduler please run the bench doctor command

3 Likes

@makarand_b I run this command its work but when run bench doctor command its gives me
File “/Users/user/Documents/ERPNext-19-04-2017/frappe-bench/apps/frappe/frappe/utils/scheduler.py”, line 207, in is_scheduler_disabled
return not frappe.utils.cint(frappe.db.get_single_value(“System Settings”, “enable_scheduler”))
File “/Users/user/Documents/ERPNext-19-04-2017/frappe-bench/apps/frappe/frappe/database.py”, line 554, in get_single_value
tabSingles where doctype=%s and field=%s""", (doctype, fieldname))
File “/Users/user/Documents/ERPNext-19-04-2017/frappe-bench/apps/frappe/frappe/database.py”, line 107, in sql
self.connect()
File “/Users/user/Documents/ERPNext-19-04-2017/frappe-bench/apps/frappe/frappe/database.py”, line 53, in connect
use_unicode=True, charset=‘utf8mb4’)
File “/Users/user/Documents/ERPNext-19-04-2017/frappe-bench/env/lib/python2.7/site-packages/MySQLdb/init.py”, line 81, in Connect
return Connection(*args, **kwargs)
File “/Users/user/Documents/ERPNext-19-04-2017/frappe-bench/env/lib/python2.7/site-packages/MySQLdb/connections.py”, line 193, in init
super(Connection, self).init(*args, **kwargs2)
_mysql_exceptions.OperationalError: (1045, “Access denied for user ‘1bd3e0294da19198’@‘localhost’ (using password: YES)”)

Were you able to solve your issue??? i am having the exact issue with mine.

1 Like

I have faced similar type issue. Please guide me

thanks