Try ERPNext Buy Support Partners Foundation

Unable to Install Frappe Bench on ubuntu

Good Evening guys,

i am having issue installing ErpNext on my Local ubuntu 16.04.
below is my error. any help please

 Can't rollback cryptography, nothing uninstalled.
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-q8lonrrg/cryptography/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-hnxc2rng-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-q8lonrrg/cryptography/
You are using pip version 8.1.1, however version 20.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Traceback (most recent call last):
  File "install.py", line 436, in <module>
    install_prerequisites()
  File "install.py", line 143, in install_prerequisites
    'python3': "sudo -H python3 -m pip install --upgrade setuptools cryptography ansible==2.8.5 pip"
  File "install.py", line 118, in run_os_command
    returncode = subprocess.check_call(command, shell=True, stdout=log_stream, stderr=sys.stderr)
  File "/usr/lib/python2.7/subprocess.py", line 541, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command 'sudo -H python3 -m pip install --upgrade setuptools cryptography ansible==2.8.5 pip' returned non-zero exit status 1

Awaits response

As Error message suggests, you are using older version of pip. upgrading it will help you install all required packages easily.

Assuming you are using frappe as user

su - frappe
cd ~/frappe-bench/
./env/bin/pip install --upgrade pip

If you are installing ERPNext v12, then it is recommended you use virtual environment + python 3.6+

This is error i get updating the pip

Defaulting to user installation because normal site-packages is not writeable
Requirement already up-to-date: pip in ./.local/lib/python2.7/site-packages (20.0.2)

i have not even installed ErpNext yet
the command that led to that error is

python install.py --production --user frappe

Your local python version due to misconfiguration may lead to even more errors, try isolating your environments to not break your OS python modules and dependencies.

Search for how to install python version 3+ without removing your existing python on your machine once installed try following:

python3 install.py --production --version 12 --python python3 --user frappe

Note: if it is broken during install. You may safely delete frappe user and its home directory if you want to clean start.

If you are familiar with docker then now you have option to deploy erpnext and its components using docker. it is far more clean, easier to deploy approach is above one does not work for you.

checkout: https://github.com/frappe/frappe_docker