TwoFactor send_token_via_sms whitelisted

Hi, I am trying to have this enabled but because there is no whitelisted def i am not able to modify it.
My sms is via an IP address (http://10.192.8.104/cgi/WebCGI?11401=account=username&password=pwd&port=1&destination=) and i have already changed the old sms settings to it and override the send_sms.

How can i have either the twofactor under my app validations and on the System Settings to be called from there ?

Or can we have the send_token_via_sms whitelisted so i can override?

Why not extend the SMS settings so that you can send it via an IP and send a pull-request?

I have already changed the SMS settings send_via_gateway and send_request to accept my settings …
But the issue is that two_factor calls from frappe.core.doctype.sms_settings.sms_settings import send_request
while mine should be from angola_erp.angola_erpnext.validations.sms_settings import send_request

Also my IP sends all together as you can see on the address
(http://10.192.8.104/cgi/WebCGI?11401=account=username&password=pwd&port=1&destination=244222222&context=Invoice Emailed)

so when calling send_request i do send_request(myipadress,"")