ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

Timesheet Hours only work with Timer Feature (v11) when "Standard Working Hours" Set

timesheets

#1

bench version
erpnext 11.1.11
frappe 11.1.11

Issue: When attempting to add “hours” to a timesheet entry in the timesheet detail entry, the hours revert back to zero, whether entering directly in the hours field, or selecting an end time. When entering hours in the hours field, it appropriately adjusts the end time, but then the hours reverts to 0. This causes the system to not add time, nor can timesheets be submitted.

However, if the “Timer” function is employed, the time is properly submitted and the hours stay populated.

I am not sure if I am missing a setting that accidentally became enabled that requires the timer function, or if something is corrupted.

What has already been attempted:

  • Permission reset for Timesheet DocType
  • bench reset-perms
  • Removed erpenext and re-added
  • Bench -site reinstall with database and file restore
  • Prior to restore, issue did not exist, after restore of database issue returned.

Makes me believe there is a setting that I am missing somewhere, or some sort of database corruption. I’ve searched in as many places as I could think to search that would have something related to time, but cannot seem to determine what would be causing this issue. Again, does not happen on a fresh install.

Any assistance would be greatly appreciated.


#2

I Have Same issue , please somebody help


#3

@sammish Glad to hear I am not the only one. I can actually help now!! Let me guess, you set the Standard Working Hours in your Company setup? Simply clear that. You will be good to go.


#4

I believe this is a bug in the logic of how the following setting found in Accounts/Company, when enabled, causes the timesheet detail “hours” field to revert to “0”:

Default Values (Section)
Standard Working Hours

When set to anything other than “0.000” this field breaks timesheets.

Issue can be reproduced easily by entering any value into that field. When the value is reverted back to zero, you can go back to the timesheet, change something on the timesheet and click “Save” the values will reappear and the timesheet can be properly submitted.


#5

@frappe This seems to be clear bug. Either that, or perhaps some documentation on how the “Standard Working Hours” setting is supposed to behave in relationship to the Timesheet functionality. This settings appears to break the ability to enter time into Timesheets in version 11.


#6