Task series changed automatically

We had created a few tasks in ERPNext and the numbering was in TASK##### format. Our last generated number was TASK00016. We wanted to bump the series to TASK04300. So after searching on the forum for solutions we found that it can not be done from Update Naming Series option but has to be done from database itself. So we updated the tabSeries table entry of TASK series to 4300 and tried to create a new task.

Now the series changed automatically to TASK-2020-00001.
image

This same naming series in shown in Update Naming Series as well. We tries to update task.json to set series as ‘TASK######’ but no luck.

Any pointer how this can be resolved since we want to have task numbering in continuation of our old PMS series.

Can you check what is the naming series set in the Task doctype? Go to DocType list > Task and check under NAMING section.

If it is set as shown in the screenshot above, change it to TASK#####

Hope this helps.

Thanks for the help. It finally worked!! But we have to enable the developer mode first using this link https://frappeframework.com/docs/user/en/guides/app-development/how-enable-developer-mode-in-frappe and then login as Administrator to be able to change the series.

Also this command is broken

bench set-config developer_mode 1

It asks for --site option but when provided throws the same error. But actually the developer_mode gets enabled. Better to edit site_config.json manually.