Stripe issue in web portal

Inside of a payable invoice, I click the “pay” button and I get text page not the payment link…

{"message":{"payment_url":"https://adeebo.com/integrations/stripe_checkout?reference_doctype=Payment+Request&description=Payment+Request+for+SINV-00001&......=PR00001","naming_series":"PR","creation":"2017-08-01 22:04:36.941221","doctype":"Payment Request","currency":"USD","owner":"Administrator","message":"<p> Thank You for being a part of {{ doc.company }}! We hope you are enjoying the service.</p>\n\n<p> Please find enclosed the E Bill statement. The outstanding amount is {{ doc.grand_total }}.</p>\n\n<a href=\"{{ payment_url }}\"> click here to pay </a>","subject":"Payment Request for SINV-00001","reference_doctype":"Sales Invoice","modified_by":"Administrator","payment_account":"Stripe - EF","docstatus":1,"status":"Initiated","reference_name":"SINV-00001","mute_email":0,"email_to":"email","payment_gateway":"Stripe","grand_total":34.0,"name":"PR00001","idx":0,"modified":"2017-08-01 22:04:44.678758","make_sales_invoice":0,"payment_gateway_account":"Stripe - USD"}}

The payment url works but the button in ERPnext doesn’t.

@joshreeder

Please share the steps to reproduce the issue.

I create an order and create and invoice.

I login with a different browser as the customer and see both.

I signed up for stripe and got the api keys.

I added the API keys to the stripe integration and in payment gateways allowed for shopping cart checkout.

In the customer portal i click the “pay” button and instead of bringing up the stripe window, it brings up the above raw text in the viewer.

I can highlight the payment url and open it and it shows the same as when you click on the email link. But the actual pay now button isn’t working.

Thanks for reporting.

Fixing via https://github.com/frappe/erpnext/pull/10265