ERPNext Conference 2019* ERPNext.com Blog

SSL Certificate is not working properly

erpnext

#1

I was trying add SSL certificate in my erpnext implementation. For that first i’ve done reverse proxying with nginx for instance ip address with port (x.x.x.x:8000). now this is working without https, i was able to login erpnext without entering port number 8000.

After that i tried to add https for the website. I’ve installed let’sencrypt certificate manually. Now https is working but it is not leading to my erpnext implementation. Showing nginx page with https.

Issue is erpnext page is coming without adding ssl certificate, If i add ssl certificate erpnext page is not coming but only nginx start page.

Can anybody help me out on this issue ?


#2

Please example your problem in detail. Why did you manually changed the reverse proxy ? And what are you trying to achieve when there is good documentation on making the erpnext site SSL with lets encrypt.

How did you try to do this?

Why like this ? When there is multi-tenant setup already present.

Why manually? Any specific requirement ?

From all this I think as you have started the whole SSL process manually you might have to add SSl manually to the nginx for the site and also make it force redirect to HTTPS.


#3

The command to make SSL is not working in my installation. I posted that issue before this but didn’t get proper solution for it.

did manually from other web page because sudo bench setup lets-encrypt [site-name]. I’ve mentioned it on that post . So i made ssl certificates with pem keys and all, Then added them in the nginx.conf file.