[Socket.io] ListView not refreshed

Hi guys,

I am experiencing strange issue on development servers. I think it is connected with couple of others but here is the case:

Adding an item using “New” then dialog pops up, saving and the list is not refreshed. I have to manually refresh it.
Error occurs on V6 & V7, either in production/development and either when using my instance or virtualbox image.

I can see it working on ERPNext free plan that I have.
Is it configuration issue, what can I do about it? Not sure it’s redis/socket.io, no clue at all for the moment.

Same as this issue. Although it seems @rmehta was unable to replicate it:

Regards,
CKSGB

@Chude_Osiegbu,

Already replied on this issue - easy to replicate by downloading image on Virtual Box.
GIF below shows use case:

@rmehta Maybe you should take a look at it.

@rmehta

We got it working on production. Unfortunately no luck on development :frowning:

Oh, maybe related to nodejs/socketio or schema migration etc.

1 Like

@Marcin_Walkow remove currentsite.txt -that usualy causes a lot of problems

1 Like

@rmehta

Done - removed file & regenerated all configs:

bench setup socketio
bench setup redis
bench setup nginx

After that did

bench setup procfile

Had an issue with site path (procfile didn’t specify it in bench serve) - fixed manually.
Above works.

@yashodhan (as you said)
Now we got old issue:

09:33:56 web.1 | 89.229.234.14 - - [08/Aug/2016 09:33:56]
“GET /socket.io/?EIO=3&transport=polling&t=1470641743818-66 HTTP/1.1” 404

Any tips? :slight_smile:

Issue resolved on production setup - probably it does NOT work on development server (built-in web server) as for my knowledge. I hope to check with the core team and let you all guys know.

It is know issue with socketio related to worker processes if worker (more than 1) /socketio does not ends properly, causes socketio to unable to communicate.

Only workaround I found that, to keep worker to 1 only on development machines, which pretty much solves the problem.

Thanks for the tip - not sure where to set workers? Didn’t find any bench specific command (only for queues), should we do it in redis?

socketio works pretty reliably on my local development server.

Sometimes the node version causes some problems too.

I am having the same issue with development installation as Marcin, can you point us to where can we limit the workers processes?

@yashodhan
You mentioned workers, can you specify how to limit them to 1?

@rmehta
What version of nodejs do you use?

I am just trying to understand the issue since it is not that uncommon and can persist. Please share the info with us :slight_smile: thank you!

We resolved socket.io 404 by setting 1 worker but ListView is still not refreshed. We were able to reproduce it on multiple development machines, production works fine.