Try ERPNext Buy Support Partners Foundation

Setup Wizzard / Error

Hi,

i installed a ERPnext with easy install script on my german ubuntu 18.4.4 (i tried 18.4.2 already).
(with some help from thread " Easy Install Complete Guide Ubuntu 18.04.3 ERPNEXT V12 /Sorry! We will be back soon Don’t panic fixed

After that i type some info in the setup wizzard on webgui. (german language and timezone and so on)

After Wizzard/5 i press next. But it stocks 3minutes later with:
“Request Timed Out” / “Setup failed - Could not start up: Error in setup” Message

Can you tell me how to fix or debug?

@bumann Seems there’s a time zone bug. Maybe you can try with English and then change setting after setup wizard completes?

1 Like

i try english and country “bahamas”
but the error is the same

Try English any country in +1 timezone

1 Like

i set english,
country to “botswana”
and Timezone “unknown region GMT +1”
currency us dollar
domains “services”

same problem

Okay try country Nigeria. At least i installed yesterday and set up without issues.

1 Like

same problem.

Thanks for help, can you tell me about language setting in your ubuntu and ubuntu version?

Language setting is english usa and ubuntu version is 18.04.03 LTS

1 Like

I try wit ubuntu 18.04.03 server.
i use english us in setup
did not change dns or ip settings
and the following commands:
#sudo apt-get install python3-minimal build-essential python3-setuptools
#sudo usermod -aG sudo frappeusr
#su frappeusr
#export LC_ALL=C.UTF-8
#sudo wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py
#sudo -H python3 install.py --production --user frappeusr --mysql-root-password myadminpw --admin-password myadminpw
#cd
#cd frappe-bench
#bench setup nginx
#sudo reboot

after that i see the wizzard, i tried many different options but it stocks every time …

i try to install erpnext a few days, but i did not get it working

Run
./env/bin/pip install Werkzeug==0.16.0 and then sudo bench restart and try again.

Are you installing on a local machine or a cloud VPS?

1 Like

i get same error

i install it on a vm on local proxmox kvm host.

i got some warnings from the installer:

Checking System Compatibility...
ubuntu 18 is compatible!

curl already installed!
wget already installed!
git already installed!
Installing pip3...
pip3 installed!
 [WARNING]: No inventory was parsed, only implicit localhost is available
 [WARNING]: provided hosts list is empty, only localhost is available. Note
that the implicit localhost does not match 'all'
Input MySQL and Frappe Administrator passwords:
Passwords saved at ~/passwords.txt
 [WARNING]: No inventory was parsed, only implicit localhost is available
 [WARNING]: provided hosts list is empty, only localhost is available. Note
that the implicit localhost does not match 'all'
 [WARNING]: Could not find aptitude. Using apt-get instead
 [WARNING]: Consider using the get_url or uri module rather than running
'curl'.  If you need to use command because get_url or uri is insufficient you
can add 'warn: false' to this command task or set 'command_warnings=False' in
ansible.cfg to get rid of this message.
[DEPRECATION WARNING]: evaluating [] as a bare variable, this behaviour will go
 away and you might need to add |bool to the expression in the future. Also see
 CONDITIONAL_BARE_VARS configuration toggle.. This feature will be removed in
version 2.12. Deprecation warnings can be disabled by setting
deprecation_warnings=False in ansible.cfg.
 [WARNING]: Consider using the file module with owner rather than running
'chown'.  If you need to use command because file is insufficient you can add
'warn: false' to this command task or set 'command_warnings=False' in
ansible.cfg to get rid of this message.
 [WARNING]: Module remote_tmp /home/frappeusr/.ansible/tmp did not exist and
was created with a mode of 0700, this may cause issues when running as another
user. To avoid this, create the remote_tmp dir with the correct permissions
manually
Bench + Frappe + ERPNext has been successfully installed!

those warnings are by ansible and are unrelated. to ERPNext’s functioning

You are seeing this: Wizard won't finish

1 Like

Here’s how I finally got going: Wizard won’t finish (post #18)

After succeeding with Bitnami, I took a database backup and restored it to the installation where the Wizard refused to complete.

1 Like

Unlike me intelligent people will probably just stick with Bitnami, and not bother messing with an installation of their own.

1 Like