Try ERPNext Buy Support Partners Foundation

Sending SMS feature: "No reponse"

I have configured in SMS Settings (Please see the below fields)

When I send the url from my browser like:

http://smsplus.routesms.com:8080/bulksms/bulksms?username=XYZ&password=***&type=5&dlr=0&destination=8801709651222&source=TRADEHUB&message=Demo%20Message

It respond 1701|8801709651222|d548a7a6-f417-4080-b4c6-7d91c6c0d27e. So my API is working fine.

But from any module like “Sales Invoice”, If I choose “Send SMS”. It is not replying anything. No functionality has been occured. “Send” button grayed and there is no pop up dialog for successfully sent.

Could anyone please know where is the problem and how to solve this.

Here you can see the image after sending sms. No response and no sms has been sent.

@razen.jazzy you have any message in Browser console?

Actually when I’ve tried from browser then it sends message… Browser means hit the url in the browser address bar…But when I send it through erpnext nothing happens…

I am facing similar case. Getting successful response, but message is not delivered. However, if I send the same using http URL, it is working.

@mijan1373 probably because your SMS Gateway settings is configured to use post, but the Provider expect a get request, so verify your SMS Gateway settings and disable the use post option

@max_morais_dmm

http://sms..com/pushapi/dynamic/server.php?msisdn=+88017**&sms=Test5&user=&pass=***&sid=*******&csmsid=987654

works fine in browser.

But, above configuration not working, although it is showing Success Message.

`

Hi Guys,

This has been resolved after removing special character from password. That means had to replace special character with alphanumeric characters. Can you point any mistake I made?

Regards