Recording URL in Exotel Integration


  • As we had assigned the exophones to the system user whenever a customer calls no system user gets a notification nor does any pop-up comes in the system.
  • They are only able to see in the call log.
  • In the call log status of all calls comes as “Ringing” only.
  • No one can justify which kind of call “Ringing”, “In Progress”, “No Answer”, “Completed”, “Busy” and “Failed”.
  • Unable to Fetch any outgoing call record in ERPNext system which are done by the System user as only able to see the call records of incoming calls only.
  • No call Duration is shown for how much time period/span the communication has taken place between customer and system user.
  • Unable to fetch the recording URL from Exotel.
  • No call recording is stored in the ERPNext system.
  • There is one call back button that is showing the error of the phone_call.handler.
  • Not able to make any outgoing calls from the system.
  • No Softphone option is available through which users can directly call from the system and communicate with the customer without using the phone.
  • It only shows call logs of incoming calls from the customer.

@netchampfaris @rmehta @revant_one @surajshetty @ankush

1 Like

@Foram few of these issues are fixed with following PR

About recording, make sure you have enabled it in your flow app from your dashboard.

Also, please make sure if you have configured things correctly for the call popup. (Reference)

Outgoing calls are not yet supported.

1 Like

Thank you for your reply.

Screenshot from 2022-08-23 11-35-22

I had already ticked the “Record this call” but still, it’s not fetching the URL.

Screenshot from 2022-08-23 11-39-28

For pop-up feature I followed the documentation Pop-up.
Added the link in the Exotel app flow,(http://site_name/api/method/erpnext.erpnext_integrations.exotel_integration.handle_incoming_call)

Screenshot from 2022-08-23 11-46-18

Screenshot from 2022-08-23 11-46-53

So please you can help on the same.
Thanks and Regards

You have enter double slash after site_name.

Hey, it’s just a typing error. Otherwise, in the Exotel setup I had used single slash only.


Please guide me on the same.