Prompted to enter Exchange Rate

Hello, 

I'm running v3.8.9.

I have defined Currency Exchange Rates under the Accounts module.
When I create a new Purchase Invoice, the "Exchange Rate" always defaults to "1.000"
When I attempt to save a new Purchase Invoice, the system prompts me to specify an exchange rate.

Why is the system not loading the appropriate exchange rate that I have defined?

Thank you,
-Jev



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/d1fb1a3d-821b-49d9-93b1-3ba2be70d26e%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hi Jev,

What is your default currency, the currency in which your Invoice is, and the values in the From Currency and To Currency fields of Currency Exchange you have specified?


Thanks,
Anand.


On Sun, Mar 9, 2014 at 2:51 AM, Jev Björsell <eb…@gmail.com> wrote:
Hello,

I’m running v3.8.9.

I have defined Currency Exchange Rates under the Accounts module.
When I create a new Purchase Invoice, the "Exchange Rate" always defaults to "1.000"
When I attempt to save a new Purchase Invoice, the system prompts me to specify an exchange rate.

Why is the system not loading the appropriate exchange rate that I have defined?

Thank you,
-Jev



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/d1fb1a3d-821b-49d9-93b1-3ba2be70d26e%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/CAAQzbF3rMm0tV%2BYvuPmUZHDr%2Bs1%2ByN4O29HtvhCFYG9qK%2BNEog%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

Default currency is EUR.

I have USD to EUR and GBP to EUR defined in the Currency Exchange table.


Thanks,
-Jev


On Sunday, March 9, 2014 7:29:19 AM UTC-7, Anand Doshi wrote:
Hi Jev,

What is your default currency, the currency in which your Invoice is, and the values in the From Currency and To Currency fields of Currency Exchange you have specified?


Thanks,
Anand.


On Sun, Mar 9, 2014 at 2:51 AM, Jev Björsell <eb…@gmail.com> wrote:
Hello, 

I’m running v3.8.9.

I have defined Currency Exchange Rates under the Accounts module.
When I create a new Purchase Invoice, the "Exchange Rate" always defaults to "1.000"
When I attempt to save a new Purchase Invoice, the system prompts me to specify an exchange rate.

Why is the system not loading the appropriate exchange rate that I have defined?

Thank you,
-Jev



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/d1fb1a3d-821b-49d9-93b1-3ba2be70d26e%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/f435f63e-41d9-4ec6-b5ec-9c13fc212d52%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hello Jev,

Thanks for reporting this issue. I can replicate it in my test account as well.

Currency Exchange Rate is fetched correctly when Customer Currency is selected manually. If Currency is fetched more Customer master, then Exchange Rate is not updated.

For now, please manually select Customer Currency, even after it is fetched from the customer master. We shall update you when this issue is fixed.


On Mon, Mar 10, 2014 at 8:28 PM, Jev Björsell <eb...@gmail.com> wrote:
Default currency is EUR.

I have USD to EUR and GBP to EUR defined in the Currency Exchange table.


Thanks,
-Jev


On Sunday, March 9, 2014 7:29:19 AM UTC-7, Anand Doshi wrote:
Hi Jev,

What is your default currency, the currency in which your Invoice is, and the values in the From Currency and To Currency fields of Currency Exchange you have specified?


Thanks,
Anand.


On Sun, Mar 9, 2014 at 2:51 AM, Jev Björsell <eb…@gmail.com> wrote:
Hello,

I’m running v3.8.9.

I have defined Currency Exchange Rates under the Accounts module.
When I create a new Purchase Invoice, the "Exchange Rate" always defaults to "1.000"
When I attempt to save a new Purchase Invoice, the system prompts me to specify an exchange rate.

Why is the system not loading the appropriate exchange rate that I have defined?

Thank you,
-Jev



You received this message because you are subscribed to the Google Groups "ERPNext User's Forum" group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/d1fb1a3d-821b-49d9-93b1-3ba2be70d26e%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/f435f63e-41d9-4ec6-b5ec-9c13fc212d52%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



--
Thanks and Regards,
Umair Sayyed
www.erpnext.com
Hi Umair,

Does this https://github.com/frappe/erpnext/issues/1465 issue correspond to the issue I reported in this thread?

Thanks,
-Jev

On Wednesday, March 12, 2014 6:10:20 AM UTC-7, Umair Sayyed wrote:
Hello Jev,

Thanks for reporting this issue. I can replicate it in my test account as well.

Currency Exchange Rate is fetched correctly when Customer Currency is selected manually. If Currency is fetched more Customer master, then Exchange Rate is not updated.

For now, please manually select Customer Currency, even after it is fetched from the customer master. We shall update you when this issue is fixed.


On Mon, Mar 10, 2014 at 8:28 PM, Jev Björsell <eb...@gmail.com> wrote:
Default currency is EUR.

I have USD to EUR and GBP to EUR defined in the Currency Exchange table.


Thanks,
-Jev


On Sunday, March 9, 2014 7:29:19 AM UTC-7, Anand Doshi wrote:
Hi Jev,

What is your default currency, the currency in which your Invoice is, and the values in the From Currency and To Currency fields of Currency Exchange you have specified?


Thanks,
Anand.


On Sun, Mar 9, 2014 at 2:51 AM, Jev Björsell <eb…@gmail.com> wrote:
Hello, 

I’m running v3.8.9.

I have defined Currency Exchange Rates under the Accounts module.
When I create a new Purchase Invoice, the "Exchange Rate" always defaults to "1.000"
When I attempt to save a new Purchase Invoice, the system prompts me to specify an exchange rate.

Why is the system not loading the appropriate exchange rate that I have defined?

Thank you,
-Jev



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/d1fb1a3d-821b-49d9-93b1-3ba2be70d26e%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/f435f63e-41d9-4ec6-b5ec-9c13fc212d52%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



--
Thanks and Regards,
Umair Sayyed
www.erpnext.com



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/e0c87579-43a2-4ec0-86da-60dd567f8126%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Yes, it is the same issue, we will fix it soon. The issue is, if you have mentioned default currency in customer master, on selection of customer, currency fetched but no exchange rate is not fetching. For now, after selection of customer, if you reselect currency, it will fetch the exchange rate.

On 22-Mar-2014, at 8:02 am, Jev Björsell <eb...@gmail.com> wrote:

Hi Umair,

Does this https://github.com/frappe/erpnext/issues/1465 issue correspond to the issue I reported in this thread?

Thanks,
-Jev

On Wednesday, March 12, 2014 6:10:20 AM UTC-7, Umair Sayyed wrote:
Hello Jev,

Thanks for reporting this issue. I can replicate it in my test account as well.

Currency Exchange Rate is fetched correctly when Customer Currency is selected manually. If Currency is fetched more Customer master, then Exchange Rate is not updated.

For now, please manually select Customer Currency, even after it is fetched from the customer master. We shall update you when this issue is fixed.


On Mon, Mar 10, 2014 at 8:28 PM, Jev Björsell <eb...@gmail.com> wrote:
Default currency is EUR.

I have USD to EUR and GBP to EUR defined in the Currency Exchange table.


Thanks,
-Jev


On Sunday, March 9, 2014 7:29:19 AM UTC-7, Anand Doshi wrote:
Hi Jev,

What is your default currency, the currency in which your Invoice is, and the values in the From Currency and To Currency fields of Currency Exchange you have specified?


Thanks,
Anand.


On Sun, Mar 9, 2014 at 2:51 AM, Jev Björsell <eb…@gmail.com> wrote:
Hello, 

I’m running v3.8.9.

I have defined Currency Exchange Rates under the Accounts module.
When I create a new Purchase Invoice, the "Exchange Rate" always defaults to "1.000"
When I attempt to save a new Purchase Invoice, the system prompts me to specify an exchange rate.

Why is the system not loading the appropriate exchange rate that I have defined?

Thank you,
-Jev



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/d1fb1a3d-821b-49d9-93b1-3ba2be70d26e%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.





You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/f435f63e-41d9-4ec6-b5ec-9c13fc212d52%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



--
Thanks and Regards,
Umair Sayyed
www.erpnext.com



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/e0c87579-43a2-4ec0-86da-60dd567f8126%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-user-forum/B39CB256-4A40-48C4-87B2-63FF6CF76AEC%40iwebnotes.com.

For more options, visit https://groups.google.com/d/optout.