ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

Problem initializing ERPNext using Bench on CentOS 7

Hello,

I’m trying to initializing the erpnext deployment using bench as instructed. However when I enter the command

cd /opt/bench
bench init erpnext && cd erpnext

I keep getting:

Getting frappe
$ git clone https://github.com/frappe/frappe.git --depth 1 --origin upstream
Cloning into 'frappe'...
remote: Enumerating objects: 3037, done.
remote: Counting objects: 100% (3037/3037), done.
remote: Compressing objects: 100% (2706/2706), done.
remote: Total 3037 (delta 440), reused 1090 (delta 247), pack-reused 0
Receiving objects: 100% (3037/3037), 16.45 MiB | 12.97 MiB/s, done.
Resolving deltas: 100% (440/440), done.

Installing frappe
$ erpnext/env/bin/python -m pip install -q -U -e erpnext/apps/frappe
ERROR: Could not find a version that satisfies the requirement ipython~=7.27.0 (from frapp
e) (from versions: 0.10, 0.10.1, 0.10.2, 0.11, 0.12, 0.12.1, 0.13, 0.13.1, 0.13.2, 1.0.0,
1.1.0, 1.2.0, 1.2.1, 2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 3.0.0, 3.1.0, 3.2.0,
3.2.1, 3.2.2, 3.2.3, 4.0.0b1, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.1.0rc1, 4.1.0rc2, 4.1.0, 4.1.
1, 4.1.2, 4.2.0, 4.2.1, 5.0.0b1, 5.0.0b2, 5.0.0b3, 5.0.0b4, 5.0.0rc1, 5.0.0, 5.1.0, 5.2.0,
5.2.1, 5.2.2, 5.3.0, 5.4.0, 5.4.1, 5.5.0, 5.6.0, 5.7.0, 5.8.0, 5.9.0, 5.10.0, 6.0.0rc1, 6
.0.0, 6.1.0, 6.2.0, 6.2.1, 6.3.0, 6.3.1, 6.4.0, 6.5.0, 7.0.0b1, 7.0.0rc1, 7.0.0, 7.0.1, 7.
1.0, 7.1.1, 7.2.0, 7.3.0, 7.4.0, 7.5.0, 7.6.0, 7.6.1, 7.7.0, 7.8.0, 7.9.0, 7.10.0, 7.10.1,
7.10.2, 7.11.0, 7.11.1, 7.12.0, 7.13.0, 7.14.0, 7.15.0, 7.16.0, 7.16.1)
ERROR: No matching distribution found for ipython~=7.27.0

I though I would install ipython 7.27.0 using:

pip3 install -Iv ipython==7.27.0

But again I got:

(requires-pyt
hon:>=3.7) is incompatible with the pythonversion in use. Acceptable python versions are:>
=3.7
Could not find a version that satisfies the requirement ipython==7.27.0 (from versions:
0.10, 0.10.1, 0.10.2, 0.11, 0.12, 0.12.1, 0.13, 0.13.1, 0.13.2, 1.0.0, 1.1.0, 1.2.0, 1.2.1
, 2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 3.0.0, 3.1.0, 3.2.0, 3.2.1, 3.2.2, 3.2.
3, 4.0.0b1, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.1.0rc1, 4.1.0rc2, 4.1.0, 4.1.1, 4.1.2, 4.2.0, 4.
2.1, 5.0.0b1, 5.0.0b2, 5.0.0b3, 5.0.0b4, 5.0.0rc1, 5.0.0, 5.1.0, 5.2.0, 5.2.1, 5.2.2, 5.3.
0, 5.4.0, 5.4.1, 5.5.0, 5.6.0, 5.7.0, 5.8.0, 5.9.0, 5.10.0, 6.0.0rc1, 6.0.0, 6.1.0, 6.2.0,
6.2.1, 6.3.0, 6.3.1, 6.4.0, 6.5.0, 7.0.0b1, 7.0.0rc1, 7.0.0, 7.0.1, 7.1.0, 7.1.1, 7.2.0,
7.3.0, 7.4.0, 7.5.0, 7.6.0, 7.6.1, 7.7.0, 7.8.0, 7.9.0, 7.10.0, 7.10.1, 7.10.2, 7.11.0, 7.
11.1, 7.12.0, 7.13.0, 7.14.0, 7.15.0, 7.16.0, 7.16.1)
Cleaning up...
No matching distribution found for ipython==7.27.0

Should I upgrade my python version to >= 3.7 ? Would that solve the issue?

Checkout: https://www.youtube.com/watch?v=MfKnvCC_eZQ

1 Like

Actually it seems we have to compile it manually

I think you can get more success with CentOS 8 (or AlmaLinux 8 for that matter)

You’re quite likely using python 3.6 and trying to install develop branch?

We dropped support for python 3.6 for next version. 3.6 will be officially EOL by end of this year, so supporting it in next version wouldn’t be wise.

Alternatively you can use version-13 branches if you want to continue using 3.6.

Reference: https://github.com/frappe/frappe/pull/14237

the video is very detailed, thanks for sharing. I’m stuck now on the new-site creation, specifically:

bench new-site myerp

I’m getting Database not installed, this can due to lack of permission, or that the database name exists.

I’m running mariadb 10.4, and the password is entered correctly, any thoughts or steps on how to troubleshoot this?

Try the later first.

  • (optional) use ssh to see in the directory sites if the site already exist.
  • use --force to force creation of the new-site

To check if the database is installed you can try to log in to the database

  • mysql -u username -p

I made sure the site in the sites folder is cleared, also I dropped the database and used --force but I’m getting the same error. I also tried running the command as root but got the same error.