ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

Not able to access 0.0.0.0:8000 after successful installation

installation_problem

#1

I am new to ERPNEXT and ubuntu.

I installed ERPNEXT in ubuntu 16.04 by easy install from instructions in https://github.com/frappe/bench

bench start worked fine . But when i tried accessing it through browser using 0.0.0.0:8000 i got following error message
09:02:05 web.1 | 0.0.0.0 does not exist
09:02:05 web.1 | ----------------------------------------
09:02:05 web.1 | Exception happened during processing of request from (‘127.0.0.1’, 54980)
09:02:05 web.1 | Traceback (most recent call last):
09:02:05 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 596, in process_request_thread
09:02:05 web.1 | self.finish_request(request, client_address)
09:02:05 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 331, in finish_request
09:02:05 web.1 | self.RequestHandlerClass(request, client_address, self)
09:02:05 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 652, in init
09:02:05 web.1 | self.handle()
09:02:05 web.1 | File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 216, in handle
09:02:05 web.1 | rv = BaseHTTPRequestHandler.handle(self)
09:02:05 web.1 | File “/usr/lib/python2.7/BaseHTTPServer.py”, line 340, in handle
09:02:05 web.1 | self.handle_one_request()
09:02:05 web.1 | File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 251, in handle_one_request
09:02:05 web.1 | return self.run_wsgi()
09:02:05 web.1 | File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 193, in run_wsgi
09:02:05 web.1 | execute(self.server.app)
09:02:05 web.1 | File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 183, in execute
09:02:05 web.1 | for data in application_iter:
09:02:05 web.1 | File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/debug/init.py”, line 284, in debug_application
09:02:05 web.1 | app_iter = self.app(environ, start_response)
09:02:05 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/middlewares.py”, line 15, in call
09:02:05 web.1 | return super(StaticDataMiddleware, self).call(environ, start_response)
09:02:05 web.1 | File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wsgi.py”, line 599, in call
09:02:05 web.1 | return self.app(environ, start_response)
09:02:05 web.1 | File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wsgi.py”, line 599, in call
09:02:05 web.1 | return self.app(environ, start_response)
09:02:05 web.1 | File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/local.py”, line 228, in application
09:02:05 web.1 | return ClosingIterator(app(environ, start_response), self.cleanup)
09:02:05 web.1 | File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wrappers.py”, line 291, in application
09:02:05 web.1 | return f(*args[:-2] + (request,))(*args[-2:])
09:02:05 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/app.py”, line 52, in application
09:02:05 web.1 | init_request(request)
09:02:05 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/app.py”, line 103, in init_request
09:02:05 web.1 | frappe.init(site=site, sites_path=_sites_path)
09:02:05 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 120, in init
09:02:05 web.1 | local.conf = _dict(get_site_config())
09:02:05 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 175, in get_site_config
09:02:05 web.1 | sys.exit(1)
09:02:05 web.1 | SystemExit: 1
09:02:05 web.1 | ----------------------------------------
Please help


#2

try to have a bench update


#3

@vijaykrishnan
You can use following command :
bench serve --port 9090

That port number can be any port other than 8000.

Thanks,
Mohini


#4

same error !!!


#5

Hi ,
I am facing same problem .
pooja@pooja:~/frappe-bench$ bench start
22:13:11 system | redis_queue.1 started (pid=31449)
22:13:11 redis_queue.1 | 31458:M 01 Jan 22:13:11.312 * Increased maximum number of open files to 10032 (it was originally set to 1024).
22:13:11 redis_queue.1 | .
22:13:11 redis_queue.1 | .-__ ''-._ 22:13:11 redis_queue.1 | _.- .. ‘’-._ Redis 3.0.6 (00000000/0) 64 bit
22:13:11 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 22:13:11 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 22:13:11 redis_queue.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 11000 22:13:11 redis_queue.1 | |-. ._ / _.-' | PID: 31458 22:13:11 redis_queue.1 |-._ -._-./ .-’ .-’
22:13:11 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 22:13:11 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 22:13:11 redis_queue.1 |-._ -._-..-’.-’ .-’
22:13:11 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 22:13:11 redis_queue.1 | |-.
-._ _.-'_.-' | 22:13:11 redis_queue.1 |-._ -._-.
.-’.-’ .-’
22:13:11 redis_queue.1 | -._-..-’ _.-’
22:13:11 redis_queue.1 | -._ _.-' 22:13:11 redis_queue.1 |-.
.-’
22:13:11 redis_queue.1 |
22:13:11 redis_queue.1 | 31458:M 01 Jan 22:13:11.312 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
22:13:11 redis_queue.1 | 31458:M 01 Jan 22:13:11.312 # Server started, Redis version 3.0.6
22:13:11 redis_queue.1 | 31458:M 01 Jan 22:13:11.312 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
22:13:11 redis_queue.1 | 31458:M 01 Jan 22:13:11.312 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
22:13:11 redis_queue.1 | 31458:M 01 Jan 22:13:11.312 * The server is now ready to accept connections on port 11000
22:13:11 system | web.1 started (pid=31450)
22:13:11 system | watch.1 started (pid=31457)
22:13:11 system | schedule.1 started (pid=31451)
22:13:11 system | worker_long.1 started (pid=31453)
22:13:11 system | worker_default.1 started (pid=31452)
22:13:11 system | worker_short.1 started (pid=31455)
22:13:11 system | redis_socketio.1 started (pid=31456)
22:13:11 redis_socketio.1 | 31479:M 01 Jan 22:13:11.367 * Increased maximum number of open files to 10032 (it was originally set to 1024).
22:13:11 redis_socketio.1 | .
22:13:11 redis_socketio.1 | .-__ ''-._ 22:13:11 redis_socketio.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
22:13:11 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 22:13:11 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 22:13:11 redis_socketio.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 12000 22:13:11 redis_socketio.1 | |-._ ._ / _.-' | PID: 31479 22:13:11 redis_socketio.1 |-._ -._-./ .-’ .-’
22:13:11 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 22:13:11 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 22:13:11 redis_socketio.1 |-._ -._-..-’.-’ .-’
22:13:11 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 22:13:11 redis_socketio.1 | |-.
-._ _.-'_.-' | 22:13:11 redis_socketio.1 |-._ -._-.
.-’.-’ .-’
22:13:11 redis_socketio.1 | -._-..-’ _.-’
22:13:11 redis_socketio.1 | -._ _.-' 22:13:11 redis_socketio.1 |-.
.-’
22:13:11 redis_socketio.1 |
22:13:11 redis_socketio.1 | 31479:M 01 Jan 22:13:11.368 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
22:13:11 redis_socketio.1 | 31479:M 01 Jan 22:13:11.368 # Server started, Redis version 3.0.6
22:13:11 redis_socketio.1 | 31479:M 01 Jan 22:13:11.368 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
22:13:11 redis_socketio.1 | 31479:M 01 Jan 22:13:11.368 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
22:13:11 redis_socketio.1 | 31479:M 01 Jan 22:13:11.368 * The server is now ready to accept connections on port 12000
22:13:11 system | socketio.1 started (pid=31454)
22:13:11 system | redis_cache.1 started (pid=31462)
22:13:11 redis_cache.1 | 31483:M 01 Jan 22:13:11.401 * Increased maximum number of open files to 10032 (it was originally set to 1024).
22:13:11 redis_cache.1 | .
22:13:11 redis_cache.1 | .-__ ''-._ 22:13:11 redis_cache.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
22:13:11 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 22:13:11 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 22:13:11 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 22:13:11 redis_cache.1 | |-._ ._ / _.-' | PID: 31483 22:13:11 redis_cache.1 |-._ -._-./ .-’ .-’
22:13:11 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 22:13:11 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 22:13:11 redis_cache.1 |-._ -._-..-’.-’ .-’
22:13:11 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 22:13:11 redis_cache.1 | |-.
-._ _.-'_.-' | 22:13:11 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
22:13:11 redis_cache.1 | -._-..-’ _.-’
22:13:11 redis_cache.1 | -._ _.-' 22:13:11 redis_cache.1 |-.
.-’
22:13:11 redis_cache.1 |
22:13:11 redis_cache.1 | 31483:M 01 Jan 22:13:11.402 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
22:13:11 redis_cache.1 | 31483:M 01 Jan 22:13:11.402 # Server started, Redis version 3.0.6
22:13:11 redis_cache.1 | 31483:M 01 Jan 22:13:11.402 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
22:13:11 redis_cache.1 | 31483:M 01 Jan 22:13:11.402 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
22:13:11 redis_cache.1 | 31483:M 01 Jan 22:13:11.402 * The server is now ready to accept connections on port 13000
22:13:14 socketio.1 | listening on *: 9000
22:13:19 worker_long.1 | 22:13:19 RQ worker u’rq:worker:pooja.31464.long’ started, version 0.7.1
22:13:19 worker_long.1 | 22:13:19 Cleaning registries for queue: long
22:13:19 worker_short.1 | 22:13:19 RQ worker u’rq:worker:pooja.31470.short’ started, version 0.7.1
22:13:19 worker_long.1 | 22:13:19
22:13:19 worker_long.1 | 22:13:19 *** Listening on long…
22:13:19 worker_short.1 | 22:13:19 Cleaning registries for queue: short
22:13:19 worker_short.1 | 22:13:19
22:13:19 worker_short.1 | 22:13:19 *** Listening on short…
22:13:19 worker_default.1 | 22:13:19 RQ worker u’rq:worker:pooja.31467.default’ started, version 0.7.1
22:13:19 worker_default.1 | 22:13:19 Cleaning registries for queue: default
22:13:19 worker_default.1 | 22:13:19
22:13:19 worker_default.1 | 22:13:19 *** Listening on default…
22:13:19 watch.1 | Wrote ./assets/js/print_format_v3.min.js - 25k
22:13:19 watch.1 | Wrote ./assets/js/frappe-web.min.js - 141k
22:13:19 watch.1 | Wrote ./assets/js/form.min.js - 177k
22:13:19 watch.1 | Wrote ./assets/js/report.min.js - 253k
22:13:19 watch.1 | Wrote ./assets/css/list.min.css - 9k
22:13:19 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
22:13:19 watch.1 | Wrote ./assets/js/d3.min.js - 380k
22:13:19 watch.1 | Wrote ./assets/css/report.min.css - 8k
22:13:19 watch.1 | Wrote ./assets/css/frappe-web.css - 64k
22:13:19 watch.1 | Wrote ./assets/js/list.min.js - 118k
22:13:19 watch.1 | Wrote ./assets/js/dialog.min.js - 83k
22:13:19 web.1 | * Restarting with inotify reloader
22:13:19 watch.1 | Wrote ./assets/js/desk.min.js - 328k
22:13:19 watch.1 | Wrote ./assets/css/form.min.css - 4k
22:13:19 watch.1 | Wrote ./assets/js/editor.min.js - 45k
22:13:19 watch.1 | Wrote ./assets/js/libs.min.js - 691k
22:13:19 watch.1 | Wrote ./assets/css/desk.min.css - 257k
22:13:19 watch.1 | Wrote ./assets/css/module.min.css - 2k
22:13:19 web.1 | * Debugger is active!
22:13:19 web.1 | * Debugger pin code: 241-869-600
22:13:29 web.1 | 0.0.0.0 does not exist
22:13:29 web.1 | ----------------------------------------
22:13:29 web.1 | Exception happened during processing of request from (‘127.0.0.1’, 38044)
22:13:29 web.1 | Traceback (most recent call last):
22:13:29 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 596, in process_request_thread
22:13:29 web.1 | self.finish_request(request, client_address)
22:13:29 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 331, in finish_request
22:13:29 web.1 | self.RequestHandlerClass(request, client_address, self)
22:13:29 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 652, in init
22:13:29 web.1 | self.handle()
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 228, in handle
22:13:29 web.1 | rv = BaseHTTPRequestHandler.handle(self)
22:13:29 web.1 | File “/usr/lib/python2.7/BaseHTTPServer.py”, line 340, in handle
22:13:29 web.1 | self.handle_one_request()
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 263, in handle_one_request
22:13:29 web.1 | return self.run_wsgi()
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 205, in run_wsgi
22:13:29 web.1 | execute(self.server.app)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 195, in execute
22:13:29 web.1 | for data in application_iter:
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/debug/init.py”, line 284, in debug_application
22:13:29 web.1 | app_iter = self.app(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/middlewares.py”, line 15, in call
22:13:29 web.1 | return super(StaticDataMiddleware, self).call(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wsgi.py”, line 599, in call
22:13:29 web.1 | return self.app(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wsgi.py”, line 599, in call
22:13:29 web.1 | return self.app(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/local.py”, line 228, in application
22:13:29 web.1 | return ClosingIterator(app(environ, start_response), self.cleanup)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wrappers.py”, line 291, in application
22:13:29 web.1 | return f(*args[:-2] + (request,))(*args[-2:])
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/app.py”, line 52, in application
22:13:29 web.1 | init_request(request)
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/app.py”, line 103, in init_request
22:13:29 web.1 | frappe.init(site=site, sites_path=_sites_path)
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/init.py”, line 130, in init
22:13:29 web.1 | local.conf = _dict(get_site_config())
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/init.py”, line 185, in get_site_config
22:13:29 web.1 | sys.exit(1)
22:13:29 web.1 | SystemExit: 1
22:13:29 web.1 | ----------------------------------------
22:13:29 web.1 | 0.0.0.0 does not exist
22:13:29 web.1 | ----------------------------------------
22:13:29 web.1 | Exception happened during processing of request from (‘127.0.0.1’, 38046)
22:13:29 web.1 | Traceback (most recent call last):
22:13:29 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 596, in process_request_thread
22:13:29 web.1 | self.finish_request(request, client_address)
22:13:29 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 331, in finish_request
22:13:29 web.1 | self.RequestHandlerClass(request, client_address, self)
22:13:29 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 652, in init
22:13:29 web.1 | self.handle()
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 228, in handle
22:13:29 web.1 | rv = BaseHTTPRequestHandler.handle(self)
22:13:29 web.1 | File “/usr/lib/python2.7/BaseHTTPServer.py”, line 340, in handle
22:13:29 web.1 | self.handle_one_request()
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 263, in handle_one_request
22:13:29 web.1 | return self.run_wsgi()
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 205, in run_wsgi
22:13:29 web.1 | execute(self.server.app)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 195, in execute
22:13:29 web.1 | for data in application_iter:
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/debug/init.py”, line 284, in debug_application
22:13:29 web.1 | app_iter = self.app(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/middlewares.py”, line 15, in call
22:13:29 web.1 | return super(StaticDataMiddleware, self).call(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wsgi.py”, line 599, in call
22:13:29 web.1 | return self.app(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wsgi.py”, line 599, in call
22:13:29 web.1 | return self.app(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/local.py”, line 228, in application
22:13:29 web.1 | return ClosingIterator(app(environ, start_response), self.cleanup)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wrappers.py”, line 291, in application
22:13:29 web.1 | return f(*args[:-2] + (request,))(*args[-2:])
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/app.py”, line 52, in application
22:13:29 web.1 | init_request(request)
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/app.py”, line 103, in init_request
22:13:29 web.1 | frappe.init(site=site, sites_path=_sites_path)
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/init.py”, line 130, in init
22:13:29 web.1 | local.conf = _dict(get_site_config())
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/init.py”, line 185, in get_site_config
22:13:29 web.1 | sys.exit(1)
22:13:29 web.1 | SystemExit: 1
22:13:29 web.1 | ----------------------------------------
22:13:29 web.1 | 0.0.0.0 does not exist
22:13:29 web.1 | ----------------------------------------
22:13:29 web.1 | Exception happened during processing of request from (‘127.0.0.1’, 38048)
22:13:29 web.1 | Traceback (most recent call last):
22:13:29 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 596, in process_request_thread
22:13:29 web.1 | self.finish_request(request, client_address)
22:13:29 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 331, in finish_request
22:13:29 web.1 | self.RequestHandlerClass(request, client_address, self)
22:13:29 web.1 | File “/usr/lib/python2.7/SocketServer.py”, line 652, in init
22:13:29 web.1 | self.handle()
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 228, in handle
22:13:29 web.1 | rv = BaseHTTPRequestHandler.handle(self)
22:13:29 web.1 | File “/usr/lib/python2.7/BaseHTTPServer.py”, line 340, in handle
22:13:29 web.1 | self.handle_one_request()
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 263, in handle_one_request
22:13:29 web.1 | return self.run_wsgi()
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 205, in run_wsgi
22:13:29 web.1 | execute(self.server.app)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/serving.py”, line 195, in execute
22:13:29 web.1 | for data in application_iter:
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/debug/init.py”, line 284, in debug_application
22:13:29 web.1 | app_iter = self.app(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/middlewares.py”, line 15, in call
22:13:29 web.1 | return super(StaticDataMiddleware, self).call(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wsgi.py”, line 599, in call
22:13:29 web.1 | return self.app(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wsgi.py”, line 599, in call
22:13:29 web.1 | return self.app(environ, start_response)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/local.py”, line 228, in application
22:13:29 web.1 | return ClosingIterator(app(environ, start_response), self.cleanup)
22:13:29 web.1 | File “/home/pooja/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/wrappers.py”, line 291, in application
22:13:29 web.1 | return f(*args[:-2] + (request,))(*args[-2:])
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/app.py”, line 52, in application
22:13:29 web.1 | init_request(request)
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/app.py”, line 103, in init_request
22:13:29 web.1 | frappe.init(site=site, sites_path=_sites_path)
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/init.py”, line 130, in init
22:13:29 web.1 | local.conf = _dict(get_site_config())
22:13:29 web.1 | File “/home/pooja/frappe-bench/apps/frappe/frappe/init.py”, line 185, in get_site_config
22:13:29 web.1 | sys.exit(1)
22:13:29 web.1 | SystemExit: 1
22:13:29 web.1 | ----------------------------------------


#6

I solved the problem by manually adding site

Add site

Frappe apps are run by frappe sites and you will have to create at least one
site. The new-site command allows you to do that.

bench new-site site1.local
Install erpnext

To install erpnext on your new site, use the bench install-app command

bench --site site1.local install-app erpnext


#7

Thanks, Vijaykrishnan, you saved my day. I faced the same issue and could resolve it by adding a new site as you mentioned.

That said, it seems to me that everyone who is following “Easy Install” steps given on https://github.com/frappe/bench is suffering from same problem. The confusion arises from the documentation that says, the easy install script Creates a new site on the bench letting user think that he or she doesn’t have to create a new site. I think a slight correction there will help.