New item did not showed on website

If I add a new item, and want to see on the webpage
i get this error:

Oops, a server error has occured

Traceback (most recent call last):

File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 32, in render
data = render_page_by_language(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 101, in render_page_by_language
return render_page(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 117, in render_page
return build(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 124, in build
return build_page(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 137, in build_page
context = get_context(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/context.py”, line 14, in get_context
context = get_page_context(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/router.py”, line 35, in get_page_context
page_context = make_page_context(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/router.py”, line 44, in make_page_context
context = resolve_route(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/router.py”, line 18, in resolve_route
context = get_page_context_from_template(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/router.py”, line 66, in get_page_context_from_template
if os.path.exists(o) and not os.path.isdir(o):
File “/home/frappe/frappe-bench/env/lib/python2.7/genericpath.py”, line 18, in exists
os.stat(path)
UnicodeEncodeError: ‘ascii’ codec can’t encode character u’\xf6’ in position 51: ordinal not in range(128)

@krnkris

Does your item name has some special character? Since looking at the error it seems like system is not able to encode the character in proper manner.

Hello,

very simple,
the name is:
KK-1115


OK.
it seem I made myself hard time.
I just translate ERPnext to Hungarian, it causing problems…
I recently updated frappe bench, it updates the translation as well.

It seem the URL for products was /products
and from 2016-11-22 it is /Termékek (as of Hungarian)

It seem this word causing problem: Termékek

Can you help me out on this?


I translated a lot on :slight_smile:
https://translate.erpnext.com/
Some “Verified” definitions are not correct, but I have no 100 Karma and can’t revise those.
How can I get some Karma?

In the mean time I installed a new instance in English.
Then I switched the usr language to Hungary.
Then all the main URL on website are in English like:

Setup:
http://localhost:8080/desk#modules/Setup

The item KK1115:

http://localhost:8080/all-item-groups/products/kk1115

It seem the URL name cause difficulties:

http://localhost:8080/összes-tétel-csoport/termékek/kk1115