Maximum call stack size exceeded libs.min.js:9922

// Code from http://stackoverflow.com/questions/3561493/is-there-a-regexp-escape-function-in-javascript
function $(a) {
return _(a.replace("\", “”).replace(/\([)|\(])|[([^][]*)]|\(.)/g, function(a, b, c, d, e) {
return b || c || d || e
}))
}
Fresh frappe/erpnext installation on the wizard/4 selecting “domain” I get this error all the time and “NEXT” button doesn’t work. Stuck with this issue for a couples of days now, I have tried different installation with different computer and OS (Always using VirtualBox VM).
The console takes me on this line of JS code and “Maximum call stack size exceeded” appears.

Thanks

2 Likes

Hi @jokermao,

I have the same error, and so does @tmatteson. We don’t have a solution. Not sure what is causing this. But as a workaround:

  1. I use the “Back” button to return to the previous page.
  2. I use the “Next” button to go back to “Domain”
  3. After this, I can click “Next” without errors.

Let me know if this works? Here’s our thread. The 3rd post mentions the error you have. Hopefully you do not have the Calendar error too.


1 Like

@brian_pond, @jokermao I’m having this error too!

And after continue to setup, following your procedure @brian_pond I’m getting various errors in reports, like General Ledger or forms that have a Date field :frowning:

1 Like

@brian_pond,

I have done that already, I can move forward not problem but after I have problem with calendar on different browsers (Safari, Chrome, Edge) they almost freeze.
I have replicated this issue on MacOX and Windows 10 as host machine and using VirtualBox for VM with different installations. Seems to me a Bootstrap issue not new to this kind of stuff expecially with date time_picker.

Thanks

@rmehta @KanchanChauhan

Over the past week, we now have 4 different users experiencing identical problems with the ERPNext Setup Wizard. Root cause is unconfirmed, but strongly points at date_picker and calendar.

  • This is happening on various browsers.
  • This is happening on various O/S.
  • In all cases, this happens for newly installed Frappe and ERPNext.

This is preventing us from performing a clean install, so we can move forward with using/learning/improving the product. Is there an escalation process we should be following? I am happy to commit time to discussing with others, sharing screens, etc. Whatever it takes to make progress on this bug.

In the meantime, I may try to rollback to an earlier, more stable version. I’m thinking probably October time. If I can get that to work successfully, I will share version numbers and steps. That will hopefully give all of us something to use, while this is being resolved.

1 Like

@brian_pond,

Please, let me know how you make out with older version.

Thanks a lot
Maurizio

I’ll keep you updated. It doesn’t look easy to install older versions. There’s a few bench commands where you can change branches. But … those don’t appear to be working either. Bench always downloads the latest development version of Frappe from github (right now 7.2.18).

I’ll start another post about that, since it’s a separate issue…

1 Like

Thanks for reporting. We will try and replicate and fix this in a few hours

Unable to replicate the issue.

@brian_pond @max_morais_dmm @jokermao Can you please share the data what you are putting in the first 3 slides? May be the error depends on that. Also share the traceback from the browser console, if there is any.

Last login: Mon Feb 20 19:46:59 on ttys000
Maurizios-MacBook-Pro:~ MaurizioCasu$ ssh frappe@192.168.0.24
frappe@192.168.0.24’s password:
Welcome to Ubuntu 16.10 (GNU/Linux 4.8.0-37-generic x86_64)

  • Documentation: https://help.ubuntu.com
  • Management: https://landscape.canonical.com
  • Support: https://ubuntu.com/advantage
    Last login: Wed Feb 22 07:10:03 2017
    frappe@ubuntu:~$ cd frappe-bench
    frappe@ubuntu:~/frappe-bench$ bench start
    07:10:53 system | watch.1 started (pid=1052)
    07:10:53 system | redis_queue.1 started (pid=1053)
    07:10:53 redis_queue.1 | 1059:M 22 Feb 07:10:53.263 * Increased maximum number of open files to 10032 (it was originally set to 1024).
    07:10:53 redis_queue.1 | .
    07:10:53 redis_queue.1 | .-__ ''-._ 07:10:53 redis_queue.1 | _.- .. ‘’-._ Redis 3.2.1 (00000000/0) 64 bit
    07:10:53 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 07:10:53 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 07:10:53 redis_queue.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 11000 07:10:53 redis_queue.1 | |-. ._ / _.-' | PID: 1059 07:10:53 redis_queue.1 |-._ -._-./ .-’ .-’
    07:10:53 redis_queue.1 | |-._-.
    -.__.-' _.-'_.-'| 07:10:53 redis_queue.1 | |-.
    -._ _.-'_.-' | http://redis.io 07:10:53 redis_queue.1 |-._ -._-..-’.-’ .-’
    07:10:53 redis_queue.1 | |-._-.
    -.__.-' _.-'_.-'| 07:10:53 redis_queue.1 | |-.
    -._ _.-'_.-' | 07:10:53 redis_queue.1 |-._ -._-.
    .-’.-’ .-’
    07:10:53 redis_queue.1 | -._-..-’ _.-’
    07:10:53 redis_queue.1 | -._ _.-' 07:10:53 redis_queue.1 |-.
    .-’
    07:10:53 redis_queue.1 |
    07:10:53 redis_queue.1 | 1059:M 22 Feb 07:10:53.272 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
    07:10:53 redis_queue.1 | 1059:M 22 Feb 07:10:53.272 # Server started, Redis version 3.2.1
    07:10:53 redis_queue.1 | 1059:M 22 Feb 07:10:53.272 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
    07:10:53 redis_queue.1 | 1059:M 22 Feb 07:10:53.272 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
    07:10:53 redis_queue.1 | 1059:M 22 Feb 07:10:53.272 * The server is now ready to accept connections on port 11000
    07:10:53 system | redis_socketio.1 started (pid=1064)
    07:10:53 redis_socketio.1 | 1072:M 22 Feb 07:10:53.293 * Increased maximum number of open files to 10032 (it was originally set to 1024).
    07:10:53 redis_socketio.1 | .
    07:10:53 redis_socketio.1 | .-__ ''-._ 07:10:53 redis_socketio.1 | _.- .. ‘’-.
    Redis 3.2.1 (00000000/0) 64 bit
    07:10:53 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 07:10:53 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 07:10:53 redis_socketio.1 | |`-._`-...-` __...-.-.
    |’_.-'| Port: 12000 07:10:53 redis_socketio.1 | |-._ ._ / _.-' | PID: 1072 07:10:53 redis_socketio.1 |-._ -._-./ .-’ .-’
    07:10:53 redis_socketio.1 | |-._-.
    -.__.-' _.-'_.-'| 07:10:53 redis_socketio.1 | |-.
    -._ _.-'_.-' | http://redis.io 07:10:53 redis_socketio.1 |-._ -._-..-’.-’ .-’
    07:10:53 redis_socketio.1 | |-._-.
    -.__.-' _.-'_.-'| 07:10:53 redis_socketio.1 | |-.
    -._ _.-'_.-' | 07:10:53 redis_socketio.1 |-._ -._-.
    .-’.-’ .-’
    07:10:53 redis_socketio.1 | -._-..-’ _.-’
    07:10:53 redis_socketio.1 | -._ _.-' 07:10:53 redis_socketio.1 |-.
    .-’
    07:10:53 redis_socketio.1 |
    07:10:53 redis_socketio.1 | 1072:M 22 Feb 07:10:53.294 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
    07:10:53 redis_socketio.1 | 1072:M 22 Feb 07:10:53.294 # Server started, Redis version 3.2.1
    07:10:53 redis_socketio.1 | 1072:M 22 Feb 07:10:53.294 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
    07:10:53 redis_socketio.1 | 1072:M 22 Feb 07:10:53.301 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
    07:10:53 redis_socketio.1 | 1072:M 22 Feb 07:10:53.301 * The server is now ready to accept connections on port 12000
    07:10:53 system | web.1 started (pid=1058)
    07:10:53 system | redis_cache.1 started (pid=1055)
    07:10:53 redis_cache.1 | 1069:M 22 Feb 07:10:53.289 * Increased maximum number of open files to 10032 (it was originally set to 1024).
    07:10:53 redis_cache.1 | .
    07:10:53 redis_cache.1 | .-__ ''-._ 07:10:53 redis_cache.1 | _.- .. ‘’-.
    Redis 3.2.1 (00000000/0) 64 bit
    07:10:53 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 07:10:53 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 07:10:53 redis_cache.1 | |`-._`-...-` __...-.-.
    |’_.-'| Port: 13000 07:10:53 redis_cache.1 | |-._ ._ / _.-' | PID: 1069 07:10:53 redis_cache.1 |-._ -._-./ .-’ .-’
    07:10:53 redis_cache.1 | |-._-.
    -.__.-' _.-'_.-'| 07:10:53 redis_cache.1 | |-.
    -._ _.-'_.-' | http://redis.io 07:10:53 redis_cache.1 |-._ -._-..-’.-’ .-’
    07:10:53 redis_cache.1 | |-._-.
    -.__.-' _.-'_.-'| 07:10:53 redis_cache.1 | |-.
    -._ _.-'_.-' | 07:10:53 redis_cache.1 |-._ -._-.
    .-’.-’ .-’
    07:10:53 redis_cache.1 | -._-..-’ _.-’
    07:10:53 redis_cache.1 | -._ _.-' 07:10:53 redis_cache.1 |-.
    .-’
    07:10:53 redis_cache.1 |
    07:10:53 redis_cache.1 | 1069:M 22 Feb 07:10:53.289 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
    07:10:53 redis_cache.1 | 1069:M 22 Feb 07:10:53.289 # Server started, Redis version 3.2.1
    07:10:53 redis_cache.1 | 1069:M 22 Feb 07:10:53.289 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
    07:10:53 system | worker_default.1 started (pid=1054)
    07:10:53 system | schedule.1 started (pid=1067)
    07:10:53 system | worker_short.1 started (pid=1056)
    07:10:53 redis_cache.1 | 1069:M 22 Feb 07:10:53.289 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
    07:10:53 redis_cache.1 | 1069:M 22 Feb 07:10:53.289 * The server is now ready to accept connections on port 13000
    07:10:53 system | worker_long.1 started (pid=1060)
    07:10:53 system | socketio.1 started (pid=1081)
    07:10:56 socketio.1 | listening on *: 9000
    07:11:01 worker_default.1 | 07:11:01 RQ worker u’rq:worker:ubuntu.1068.default’ started, version 0.7.1
    07:11:01 worker_default.1 | 07:11:01 Cleaning registries for queue: default
    07:11:01 worker_default.1 | 07:11:01
    07:11:01 worker_default.1 | 07:11:01 *** Listening on default…
    07:11:01 watch.1 | Wrote ./assets/js/print_format_v3.min.js - 25k
    07:11:01 watch.1 | Wrote ./assets/js/frappe-web.min.js - 141k
    07:11:01 worker_short.1 | 07:11:01 RQ worker u’rq:worker:ubuntu.1082.short’ started, version 0.7.1
    07:11:01 worker_short.1 | 07:11:01 Cleaning registries for queue: short
    07:11:01 worker_short.1 | 07:11:01
    07:11:01 worker_short.1 | 07:11:01 *** Listening on short…
    07:11:01 watch.1 | Wrote ./assets/js/form.min.js - 186k
    07:11:01 watch.1 | Wrote ./assets/js/report.min.js - 255k
    07:11:01 watch.1 | Wrote ./assets/js/erpnext.min.js - 107k
    07:11:01 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
    07:11:01 watch.1 | Wrote ./assets/css/list.min.css - 10k
    07:11:01 watch.1 | Wrote ./assets/js/item-dashboard.min.js - 7k
    07:11:01 watch.1 | Wrote ./assets/js/d3.min.js - 380k
    07:11:01 watch.1 | Wrote ./assets/css/report.min.css - 8k
    07:11:01 watch.1 | Wrote ./assets/css/frappe-web.css - 64k
    07:11:01 web.1 | * Restarting with inotify reloader
    07:11:01 watch.1 | Wrote ./assets/js/list.min.js - 127k
    07:11:01 watch.1 | Wrote ./assets/js/dialog.min.js - 83k
    07:11:01 worker_long.1 | 07:11:01 RQ worker u’rq:worker:ubuntu.1084.long’ started, version 0.7.1
    07:11:01 worker_long.1 | 07:11:01 Cleaning registries for queue: long
    07:11:01 worker_long.1 | 07:11:01
    07:11:01 worker_long.1 | 07:11:01 *** Listening on long…
    07:11:01 watch.1 | Wrote ./assets/js/desk.min.js - 359k
    07:11:01 watch.1 | Wrote ./assets/css/form.min.css - 4k
    07:11:01 watch.1 | Wrote ./assets/css/erpnext.css - 4k
    07:11:01 watch.1 | Wrote ./assets/js/libs.min.js - 896k
    07:11:01 watch.1 | Wrote ./assets/js/erpnext-web.min.js - 4k
    07:11:01 watch.1 | Wrote ./assets/css/desk.min.css - 275k
    07:11:01 watch.1 | Wrote ./assets/css/frappe-rtl.css - 31k
    07:11:01 watch.1 | Wrote ./assets/css/module.min.css - 2k
    07:11:01 web.1 | * Debugger is active!
    07:11:01 web.1 | * Debugger pin code: 797-093-662
    07:11:40 web.1 | 192.168.0.12 - - [22/Feb/2017 07:11:40] “GET /assets/js/erpnext-web.min.js HTTP/1.1” 200 -
    07:11:40 web.1 | 192.168.0.12 - - [22/Feb/2017 07:11:40] “GET /assets/erpnext/css/website.css HTTP/1.1” 304 -
    07:11:40 web.1 | 192.168.0.12 - - [22/Feb/2017 07:11:40] “GET /assets/js/frappe-web.min.js HTTP/1.1” 200 -
    07:11:40 web.1 | 192.168.0.12 - - [22/Feb/2017 07:11:40] “GET /assets/css/frappe-web.css HTTP/1.1” 200 -
    07:11:40 web.1 | 192.168.0.12 - - [22/Feb/2017 07:11:40] “GET /assets/frappe/js/lib/jquery/jquery.min.js HTTP/1.1” 304 -
    07:11:40 web.1 | 192.168.0.12 - - [22/Feb/2017 07:11:40] “GET /assets/frappe/css/bootstrap.css HTTP/1.1” 304 -
    07:11:40 worker_default.1 | 07:11:40 default: frappe.utils.background_jobs.execute_job(async=True, event=None, job_name=u’frappe.utils.global_search.update_global_search’, kwargs={‘doc’: <frappe.core.doctype.authentication_log.authentication_log.AuthenticationLog object at 0x7f5635da5850>}, method=u’frappe.utils.global_search.update_global_search’, site=‘mvs’, user=None) (08a77e63-b1c0-440e-9a52-1fbd737c3329)
    07:11:40 worker_default.1 | 07:11:40 default: Job OK (08a77e63-b1c0-440e-9a52-1fbd737c3329)
    07:11:40 worker_default.1 | 07:11:40 Result is kept for 500 seconds
    07:11:40 worker_default.1 | 07:11:40
    07:11:40 worker_default.1 | 07:11:40 *** Listening on default…
    07:11:40 web.1 | 192.168.0.12 - - [22/Feb/2017 07:11:40] “GET / HTTP/1.1” 200 -
    07:11:40 web.1 | 192.168.0.12 - - [22/Feb/2017 07:11:40] “GET /website_script.js HTTP/1.1” 200 -
    07:11:40 web.1 | 192.168.0.12 - - [22/Feb/2017 07:11:40] “GET /website_theme.css HTTP/1.1” 200 -
    07:12:09 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:09] “GET /assets/frappe/css/octicons/octicons.woff HTTP/1.1” 200 -
    07:12:19 worker_default.1 | 07:12:19 default: frappe.utils.background_jobs.execute_job(async=True, event=None, job_name=u’frappe.utils.global_search.update_global_search’, kwargs={‘doc’: <frappe.core.doctype.authentication_log.authentication_log.AuthenticationLog object at 0x7f562c2e3c90>}, method=u’frappe.utils.global_search.update_global_search’, site=‘mvs’, user=u’Administrator’) (d5e6395d-1304-4e85-847d-99670cc6dc34)
    07:12:19 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:19] “POST / HTTP/1.1” 200 -
    07:12:19 worker_default.1 | 07:12:19 default: Job OK (d5e6395d-1304-4e85-847d-99670cc6dc34)
    07:12:19 worker_default.1 | 07:12:19 Result is kept for 500 seconds
    07:12:19 worker_default.1 | 07:12:19
    07:12:19 worker_default.1 | 07:12:19 *** Listening on default…
    07:12:26 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:26] “GET /desk HTTP/1.1” 200 -
    07:12:26 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:26] “GET /assets/css/list.min.css HTTP/1.1” 200 -
    07:12:26 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:26] “GET /assets/css/form.min.css HTTP/1.1” 200 -
    07:12:26 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:26] “GET /assets/erpnext/images/erp-icon.svg HTTP/1.1” 200 -
    07:12:26 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:26] “GET /assets/css/report.min.css HTTP/1.1” 200 -
    07:12:26 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:26] “GET /assets/css/module.min.css HTTP/1.1” 200 -
    07:12:26 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:26] “GET /assets/css/erpnext.css HTTP/1.1” 200 -
    07:12:26 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:26] “GET /assets/css/desk.min.css HTTP/1.1” 200 -
    07:12:26 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:26] “GET /assets/js/desk.min.js HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/js/d3.min.js HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/frappe/js/frappe/toolbar.js HTTP/1.1” 304 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/js/erpnext.min.js HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/js/report.min.js HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/js/list.min.js HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/js/libs.min.js HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/js/form.min.js HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.24 - - [22/Feb/2017 07:12:27] “GET /api/method/frappe.async.get_user_info?sid=befbbc5f9b1261dfd75bb8165e9b672de2d0d381e83e48312c6e3840 HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] "GET /?items=%5B%22%2Fassets%2Ffrappe%2Fcss%2Fanimate.min.css%22%2C%22assets%2Ferpnext%2Fjs%2Fsetup_wizard.js%22%5D&cmd=frappe.client.get_js&
    =1487765546957 HTTP/1.1" 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “POST / HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/frappe/css/fonts/fontawesome/fontawesome-webfont.woff2?v=4.7.0 HTTP/1.1” 304 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/frappe/sounds/error.mp3 HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/frappe/sounds/delete.mp3 HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/frappe/sounds/email.mp3 HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/frappe/sounds/click.mp3 HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/frappe/sounds/submit.mp3 HTTP/1.1” 200 -
    07:12:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:27] “GET /assets/frappe/sounds/cancel.mp3 HTTP/1.1” 200 -
    07:12:28 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:28] “GET /assets/frappe/sounds/error.mp3 HTTP/1.1” 200 -
    07:12:28 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:28] “GET /assets/frappe/sounds/email.mp3 HTTP/1.1” 200 -
    07:12:28 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:28] “GET /assets/frappe/sounds/delete.mp3 HTTP/1.1” 200 -
    07:12:28 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:28] “GET /assets/frappe/sounds/click.mp3 HTTP/1.1” 200 -
    07:12:28 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:28] “GET /assets/frappe/sounds/submit.mp3 HTTP/1.1” 200 -
    07:12:28 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:28] “GET /assets/frappe/sounds/cancel.mp3 HTTP/1.1” 200 -
    07:12:28 worker_default.1 | 07:12:28 default: frappe.utils.background_jobs.execute_job(async=True, event=None, job_name=u’frappe.utils.global_search.update_global_search’, kwargs={‘doc’: <frappe.core.doctype.defaultvalue.defaultvalue.DefaultValue object at 0x7f562c337a50>}, method=u’frappe.utils.global_search.update_global_search’, site=‘mvs’, user=u’Administrator’) (739ac619-1c9b-4b01-a892-3ad31026d880)
    07:12:28 worker_default.1 | 07:12:28 default: Job OK (739ac619-1c9b-4b01-a892-3ad31026d880)
    07:12:28 worker_default.1 | 07:12:28 Result is kept for 500 seconds
    07:12:28 worker_default.1 | 07:12:28
    07:12:28 worker_default.1 | 07:12:28 *** Listening on default…
    07:12:28 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:28] “POST / HTTP/1.1” 200 -
    07:12:29 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:29] “POST / HTTP/1.1” 200 -
    07:12:45 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:45] “POST / HTTP/1.1” 200 -
    07:12:57 web.1 | 192.168.0.12 - - [22/Feb/2017 07:12:57] “POST / HTTP/1.1” 200 -
    07:13:02 web.1 | 192.168.0.12 - - [22/Feb/2017 07:13:02] "GET /?doctype=Currency&name=CAD&cmd=frappe.desk.form.load.getdoc&
    =1487765546958 HTTP/1.1" 200 -
    07:13:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:13:27] “POST / HTTP/1.1” 200 -
    07:13:57 web.1 | 192.168.0.12 - - [22/Feb/2017 07:13:57] “POST / HTTP/1.1” 200 -
    07:14:06 web.1 | 192.168.0.12 - - [22/Feb/2017 07:14:06] “POST / HTTP/1.1” 200 -
    07:14:16 web.1 | 192.168.0.12 - - [22/Feb/2017 07:14:16] “GET /assets/css/awesomplete.css.map HTTP/1.1” 404 -
    07:14:16 web.1 | 192.168.0.12 - - [22/Feb/2017 07:14:16] “GET /assets/js/awesomplete.min.js.map HTTP/1.1” 404 -
    07:14:27 web.1 | 192.168.0.12 - - [22/Feb/2017 07:14:27] “POST / HTTP/1.1” 200 -

@nabinhait, just enter demo.erpnext.com, go to Accounts / General Ledger and click into refresh button

2 Likes

Just to add to what @max_morais_dmm said.

  1. Go to here: https://demo.erpnext.com/desk#
  2. Click on Accounts
  3. Click on General Ledger

  1. Now, I’m going to edit that first date field, and change from 01-08-2014, to something else.
  2. I use the calendar pop-up, and click on “Today”
  3. It changes to 04-04-2014
  4. I manually enter “01-01-2017”, and click tab.
  5. It changes to 02-07-2014
  6. I open it again, and use the calendar pop-up to select 01-01-2010
  7. Instead of that date, it selects 02-20-2007.

No matter what dates you enter, it always enters a different and almost random date.

Outside of the demo website. It’s doing exactly the same thing on the very first Setup Wizard, when you install ERPNext manually from scratch. And from what @jokermao is saying, the VM’s are broken too.

The problem with clicking on “Domain” and nothing happening is directly related to this. Because selecting a Domain performs actions with dates and times. And these are clearly broken right now.

1 Like

Also, please read this thread, that was started earlier. Same exact problem. I noted problems with datepicker. Since there were GitHub changes in December, I thought it might be related.

1 Like

@brian_pond the point with Setup Wizard, is because in the domain pages, you need enter too the firscal year, begin and end date, so anywhere that have a Date or Datetime field, this error is raised.

I tried to debug the Date field, but is very, very hard to understand, where is the recursion error. I got that it start in set_input method of class, but going down into code, I can’t find any other referencing junping it up again. :weary:

1 Like

@brian_pond, @max_morais_dmm, @nabinhait
As a test I have installed a production version from image ERPNext-Production.ova on a VirtualBox VM hosted by window 10 and I have not issue with datatime_picker or any JS minimized scripts, all run smooth and my console is clean form errors.

Just hope dev version will be fixed soon.

Cheers!

Still I can’t replicate the issue, even in demo.erpnext.com. Seems like it is something related to your local machine.

Can anyone share his screen with me to help debugging this issue?

1 Like

@nabinhait I can

Ok, Screenhero?

@nabinhait yes, max.morais.dmm@gmail.com