Keep on showing Welcome to Nginx

Hi,
I am installing ERPNExt on digitalocean using Ubuntu 12.04, i am following the step from :
this link https://github.com/frappe/erpnext/wiki/How-to-Install-ERPNext then
this link https://github.com/webnotes/erpnext/wiki/Migrating-your-erpnext-instance-to-wsgi
and finally following this instructions here https://github.com/webnotes/erpnext/wiki/WSGI-Production-Deployment

the problem is I only get "Welcome to Nginx" message as the final result.

No error message shown either on console or web page, it just keep on showing that messages. Any body can advise me on this please? 

Thanks
Eka



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/9a8fe4cc-080a-4e0d-b55f-a73810ca402e%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

Hi Eka,

On Sat, Mar 22, 2014 at 5:40 PM, Eka ek...@gmail.com wrote:

Hi,
I am installing ERPNExt on digitalocean using Ubuntu 12.04, i am following
the step from :
this link https://github.com/frappe/erpnext/wiki/How-to-Install-ERPNext then
this link
https://github.com/webnotes/erpnext/wiki/Migrating-your-erpnext-instance-to-wsgi
and finally following this instructions here
https://github.com/webnotes/erpnext/wiki/WSGI-Production-Deployment

the problem is I only get “Welcome to Nginx” message as the final result.

Did you reload nginx config?

You can do it with
sudo service nginx reload

No error message shown either on console or web page, it just keep on
showing that messages. Any body can advise me on this please?

Thanks
Eka


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/9a8fe4cc-080a-4e0d-b55f-a73810ca402e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks,

Pratik
erpnext

Hi Pratik,
Thank you for your prompt response. I did it and it work now.

I move to my next goal to restore database from previous installation. I follow this link:

https://github.com/webnotes/erpnext/wiki/Restoring-From-ERPNext-Backup

However after a few error, I found a solution by  follow this link from googlegroups:

https://groups.google.com/forum/#!searchin/erpnext-developer-forum/restore$20backup/erpnext-developer-forum/LAzcktEOxgM/dhGv6X_8h9gJ


I use the command  .lib/wnf.py --mysql < /path/to/backupfile.sql
it works, at less no error generated. The problem is if I login using my regular user,  the system only showing blank pages with ERP NExt symbol in the middle. But if I log in as Administrator, the system work perfectly (I do not see error so far). I can see all data from previous installation to include the access log from activity module. Again, no error message. Please advise, what can I do to solve this? Or what did I do wrong here?

Thank you.
Eka


On 3/22/14, 9:43 PM, Pratik Vyas wrote:
Hi Eka,

On Sat, Mar 22, 2014 at 5:40 PM, Eka <ek…@gmail.com> wrote:



Hi,
I am installing ERPNExt on digitalocean using Ubuntu 12.04, i am following
the step from :
this link https://github.com/frappe/erpnext/wiki/How-to-Install-ERPNext then
this link
https://github.com/webnotes/erpnext/wiki/Migrating-your-erpnext-instance-to-wsgi
and finally following this instructions here
https://github.com/webnotes/erpnext/wiki/WSGI-Production-Deployment

the problem is I only get “Welcome to Nginx” message as the final result.

Did you reload nginx config?

You can do it with
sudo service nginx reload

No error message shown either on console or web page, it just keep on
showing that messages. Any body can advise me on this please?

Thanks
Eka


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un…@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/9a8fe4cc-080a-4e0d-b55f-a73810ca402e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



Thanks,






Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/532DB874.9080004%40gmail.com.

    For more options, visit https://groups.google.com/d/optout.

Hi Eka,

On Sat, Mar 22, 2014 at 9:51 PM, Agus Eka Maharta ek...@gmail.com wrote:

Hi Pratik,
Thank you for your prompt response. I did it and it work now.

I move to my next goal to restore database from previous installation. I
follow this link:

From which version are you restoring? Slow branch?

https://github.com/webnotes/erpnext/wiki/Restoring-From-ERPNext-Backup

However after a few error, I found a solution by follow this link from
googlegroups:

https://groups.google.com/forum/#!searchin/erpnext-developer-forum/restore$20backup/erpnext-developer-forum/LAzcktEOxgM/dhGv6X_8h9gJ

I use the command .lib/wnf.py --mysql < /path/to/backupfile.sql

Try running ./lib/wnf.py --latest

it works, at less no error generated. The problem is if I login using my
regular user, the system only showing blank pages with ERP NExt symbol in
the middle. But if I log in as Administrator, the system work perfectly (I
do not see error so far). I can see all data from previous installation to
include the access log from activity module. Again, no error message. Please
advise, what can I do to solve this? Or what did I do wrong here?

There must be a clue in the Javascript console. You can access it
with Ctrl + Shift + K on firefox and Ctrl + Shift + J on chrome.

Thank you.
Eka

Thanks,

Pratik
erpnext

Hi Pratik,
Thanks for the help. It works by runing the code

./lib/wnf.py --latest

One sharing, I also have error: “Unable to complete request:parse error”
But I solved this by running

./lib/wnf.py -build_web_cache
./lib/wnf.py --update_origin_master
memcached -d

I hope this is help others who has same problem like me.

Thank you

Eka

On 3/23/14, 1:18 AM, Pratik Vyas wrote:

Hi Eka,

On Sat, Mar 22, 2014 at 9:51 PM, Agus Eka Maharta ek...@gmail.com wrote:

Hi Pratik,
Thank you for your prompt response. I did it and it work now.

I move to my next goal to restore database from previous installation. I
follow this link:

From which version are you restoring? Slow branch?

https://github.com/webnotes/erpnext/wiki/Restoring-From-ERPNext-Backup

However after a few error, I found a solution by follow this link from
googlegroups:

https://groups.google.com/forum/#!searchin/erpnext-developer-forum/restore$20backup/erpnext-developer-forum/LAzcktEOxgM/dhGv6X_8h9gJ

I use the command .lib/wnf.py --mysql < /path/to/backupfile.sql
Try running ./lib/wnf.py --latest

it works, at less no error generated. The problem is if I login using my
regular user, the system only showing blank pages with ERP NExt symbol in
the middle. But if I log in as Administrator, the system work perfectly (I
do not see error so far). I can see all data from previous installation to
include the access log from activity module. Again, no error message. Please
advise, what can I do to solve this? Or what did I do wrong here?

There must be a clue in the Javascript console. You can access it
with Ctrl + Shift + K on firefox and Ctrl + Shift + J on chrome.

Thank you.
Eka

Thanks,


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

End of Note

You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/532ECDC0.8090706%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hello all,

I am trying to install ERPNext on digitalocean using Ubuntu 14.04, I followed the steps as mentioned by Eka above,
1. https://github.com/frappe/erpnext/wiki/How-to-Install-ERPNext 
2. https://github.com/webnotes/erpnext/wiki/Migrating-your-erpnext-instance-to-wsgi
3. https://github.com/webnotes/erpnext/wiki/WSGI-Production-Deployment

The problem is I only get "Welcome to Nginx" message as the final result on my server IP. (I have reloaded supervisor and ngnix) 
gist here : https://gist.github.com/anonymous/0395b57e38f28d4fd853

Although I was unable to upgrade to mysql-python==1.2.4, the error log is here : https://gist.github.com/anonymous/e316fc81d49babed1c74 (I tried installing 1.2.5 as mentioned in another discussion but got the same type of error).
I also had to create the /etc/supervisor and/etc/ngnix directories on my own to create the configuration files. (They were not created during the installation)

Should I change the IP address in the "ngnix.conf" file to IP address of my server? 
upstream erpnext {
        server 127.0.0.0:800 fail_timeout=0;
    }

Sorry if the question is too vague/non-focused I am new to all this.

Regards,
Ankit Chiplunkar

On Saturday, March 22, 2014 5:40:56 PM UTC+5:30, Eka wrote:
Hi,
I am installing ERPNExt on digitalocean using Ubuntu 12.04, i am following the step from :
and finally following this instructions here https://github.com/webnotes/erpnext/wiki/WSGI-Production-Deployment

the problem is I only get "Welcome to Nginx" message as the final result.

No error message shown either on console or web page, it just keep on showing that messages. Any body can advise me on this please? 

Thanks
Eka



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/6914a2b2-6420-4f63-bb41-274323723cd9%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.
Sorry for the old pages (fixed)

Use frappe-bench


On 21-May-2014, at 5:52 pm, ankit chiplunkar <an...@gmail.com> wrote:

Hello all,

I am trying to install ERPNext on digitalocean using Ubuntu 14.04, I followed the steps as mentioned by Eka above,

The problem is I only get "Welcome to Nginx" message as the final result on my server IP. (I have reloaded supervisor and ngnix) 

Although I was unable to upgrade to mysql-python==1.2.4, the error log is here : https://gist.github.com/anonymous/e316fc81d49babed1c74 (I tried installing 1.2.5 as mentioned in another discussion but got the same type of error).
I also had to create the /etc/supervisor and/etc/ngnix directories on my own to create the configuration files. (They were not created during the installation)

Should I change the IP address in the "ngnix.conf" file to IP address of my server? 
upstream erpnext {
        server 127.0.0.0:800 fail_timeout=0;
    }

Sorry if the question is too vague/non-focused I am new to all this.

Regards,
Ankit Chiplunkar

On Saturday, March 22, 2014 5:40:56 PM UTC+5:30, Eka wrote:
Hi,
I am installing ERPNExt on digitalocean using Ubuntu 12.04, i am following the step from :
and finally following this instructions here https://github.com/webnotes/erpnext/wiki/WSGI-Production-Deployment

the problem is I only get "Welcome to Nginx" message as the final result.

No error message shown either on console or web page, it just keep on showing that messages. Any body can advise me on this please? 

Thanks
Eka



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/6914a2b2-6420-4f63-bb41-274323723cd9%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/1C209801-A541-4603-8AEE-C6AD49118A67%40gmail.com.

    For more options, visit https://groups.google.com/d/optout.