ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

Kanban Board - Issue

Hi,

I have configured Kanban Board for Task list, on first click ERP asked to create Kanban Board. I created with Status and it load successfully.
Second time when I click on configured Kanban Board, it didnt load nor give any error.
I also checked with other doc type, issue is same that first time It show the accurate Kanban board, but next time it is not showing anything.

Same thing happening with all doc type.

I also checked Kanban Board list, all configured Kanban is showing there as list but not showing board, if I click Show Kanban Board.

Another point, I tried to open Kanban Board directly by typing url “http://XXX.XXX.XX.XX:XXXX/app/todo/view/kanban/Todo” and it is opening.

Can anyone suggest cause and solution for this.

When you switch to the kanban board, is the browser console showing any error traces?

here is Console Trace

Uncaught (in promise) TypeError: e.slice is not a function
at Object.convert_from_standard_route (router.js:301)
at router.js:253
at new Promise ()
at Object.set_route (router.js:251)
at Object.frappe.set_route (router.js:427)
at frappe.views.ListViewSelect.setup_kanban_boards (list_view_select.js:269)
at HTMLAnchorElement.action (list_view_select.js:120)
at HTMLAnchorElement.dispatch (jquery.min.js:3)
at HTMLAnchorElement.r.handle (jquery.min.js:3)

Any solution

I noticed that I cannot get into my kanban boards within any project for project tasks. I click the kanban board button and nothing happens. I looked in the error log and there was no errors listed. I deleted the cookies and cleared the cache, logged back in, nothing still. I logged into my ERPNext on another browser, same result.

Would love some insight here, does anyone else have issues with their kanban boards right now?

I have a kanban board that arranges the status for my projects at a macro level and that actually works fine, just not sure what happened to my task kanbans within each project.

With update to 13.8 it was fixed with a minor issue.
Please go through below url

For Kanban View not loading (Close with V13.8)

For Kanban Resources not found (Open)

But temporarily, I fixed it with update V13.8 and then rename each Kanban Board Name to require resources name

Thank you for updating the post with these links. I updated my version to v13.8 and it got worse.

My kanban boards are broken now, even the one that was still operating before the v13.8 update. I commented on the link with these screenshots, button calls the wrong kanban board, which has an error and can’t load anyway.

In the screenshot, note: Gripstone Mezz project is trying to open a kanban board, and “Griffin Event Center” is trying to load

I tried renaming boards per your suggestion, and that didn’t help in my case. Wasn’t sure what you meant by ‘require resources name’

As message shows, in your case require resources name is [“21012 Griffin Event Center”] if you had rename your kanban board to text shown then it would work.

Now, there is new release, so udpdate erpnext once more hope this time it work.

It seems the problem has fixed itself. Maybe re-naming the boards is what did it. However it wasn’t fixed right away, but later.

Thank you