Invalid Version String when Bench Init

Dear all,

Today I did bench init using frappe version-12, after a while it appears that I had an error saying that Invalid release string as stated on pictures. I checked the code and yes the version in Frappe had ‘Release’ on it, not only integer. Is that causing error?

thank you!

Can you point to the specific code?

__version__ is not a semver.

as docker images are built using git repo tags, it is available for installation https://hub.docker.com/layers/frappe/frappe-worker/v12.22.1/images/sha256-146b8120b2d93f32700d796a8176bc5d7e116dcde7955aeaea3014d48adbe363

This error was due to a recent mistake in the official Frappe repository code. The __version__ variable was given invalid characters.

It appears this was fixed about 5 hours ago, however. Here’s a link to the GitHub fix:

1 Like