Try ERPNext Buy Support Partners Foundation

Integrate with Google Drive

Hello here is i try to make a Google Backup on google Drive
I follow this document https://docs.erpnext.com/docs/user/manual/en/erpnext_integration/google_settings
i successfully do it but when I try to take back Up


It tell Me " Queued for backup. It may take a few minutes to an hour "
but nothing Is backup In Google Drive Folder
So WHAT`S THE problem Here ?

1 Like

same things happen with me also…

1 Like

I may be wrong but I remember having a conversation about this with another developer several weeks ago and they indicated that this kind of problem might be related to either the scheduler not being turned on or the scheduler not having permissions necessary to move the file off of the server (to external destination like GoogleDrive).

Again, this was just a passing conversation that may not be relevant to your problem and I may not be remembering it completely, but it can’t hurt to look into it as a possibility.

Hope this helps…

BKM

or the scheduler not having permissions necessary to move the file off of the server ->
How can i know if the scheduler Get the Right permissions ?!

Not sure. This was something that were were casually chatting about and comparing notes on other but related topics.

The problem had been noticed on CentOS servers where files were trying to be moved across the internet to another server. This is normally done with a common utility called “scp” and requires there to be secret keys traded between servers and set in config files so they can cooperate with the file move across the internet.

We had noticed that even thought the secret keys were correctly in place (and the transfer would work when done manually from a ssh console) the OS would not allow the file to move when there was not an active login via ssh. In other words, it could not happen automatically via a scheduler. The error logs kept hinting that there was a permission problem with regard to the process being allowed to use the secret keys.

We abandoned the CentOS platform and moved to Ubuntu and the problem went away. Since all of the servers are cloud VPS it really didn’t matter to me what the OS was as long as I got the result I needed.

Again, this was just casual conversation from quite some time ago and I thought I would at least pass along some places to start looking. This may or may not apply to your situation.

I hope you find your own solution.

BKM

Hi, where you able to find a solution, i am having the exact same issue

1 Like

Hello Guys,
I was facing the same issue, followed all the steps in Documentation but skipped one important step to enable Google Drive API from API library.

On enabling Google Drive API, the backup works well.

Hi , can you support us by posting video screen for all your steps from a-z
thanks in advanced

For example try a search like this
https://console.cloud.google.com/apis/library/drive.googleapis.com?q=google

“The Google Drive API allows clients to access resources from Google Drive.”

Try to set the scheduler on.
bench enable-scheduler

https://frappeframework.com/docs/user/en/bench/resources/bench-commands-cheatsheet#scheduler

Dear Can you help me with video because i am facing issue at Authorized Redirect URL.