Installing version-14-beta for development

Installation of ERPNext System version-14-beta on Ubuntu 20.04 Server

Hello @all,

have tried to install a ERPNext System for development purposes in version-14-beta from scratch. While doing so I ran into few problems and finally did not succeed with the local installation.

Debugging the problems that appeared in the console while installation was possible, although did not change the result. In the end we have a seemingly error-free installation prozedure and when we open the website we get a Not found. Bad Request 404-Error in the browser.

Bench itself is up and running and does reflect the html request shown in the browser. There are no further debug messages that hint towards a resolution of the problem. Help from other developers appreciated

Few details towards an installation guide:

npm install --save onscan.js

npm install --save html2canvas

bench init /home/adm_phamos/frappe-bench --frappe-path https://github.com/frappe/frappe --frappe-branch version-14-beta --python python3

bench get-app ERPNext https://github.com/frappe/erpnext --branch version-14-beta

I wasn’t successful at switching from 13, rather I uninstalled 13 from installed apps, dropped the site , created a new site, then bench get-app --branch version-14-beta-pre-release erpnext and bench --site <new sitename> install-app erpnext,

https://discuss.erpnext.com/t/switch-to-branch-14/85803/7

what does bench version report now?

Do not know right now. Left the bench version unchanged.

Me, I was successfull switching from 13 to 14 with bench switch-branch-to although did drop the site as you did before switching.

I think we need a full from scratch guide or when I interpret the results correctly a version-13 installation guide with added switching to version-14-beta.

Version 5.0.0 it is, updated to 5.8.1

After updating your bench as I’ve seen in your latest post, I recommend you to try something (just for testing purposes):

  • Create a new site: bench new-site [site_name_here]
  • bench use [site_name_here] -at this point do not run it or configure your site yet, move straight forward to the following steps-
  • bench --site [site_name_here] install-app erpnext
  • bench switch-to-branch version-14-beta erpnext
  • bench build
  • bench start
    Then you can configure developer mode in your site_config.json
    Is there any difference or are you still getting the same error?

The steps are correct. And I am on version-14-beta now. With

  • bench switch-to-branch version-14-beta frappe erpnext

it became easy.

1 Like