Installing Frappe on VPS ubuntu14.04LTS fails - dev

Hi everyone
I have been installing development version successfully for the last 3 weeks n VPS, suddenly in the last 2 days I am struggling to install Frappe successfully, First install failed, ran the setup --develop again,got this
~/frappe-bench$ bench new-site site1
INFO:bench.utils:creating new site site1
frappe app is not installed. Run the following command to install frappe
bench get-app https://github.com/frappe/frappe.git
/bin/sh: 1: /home/frappeuser/frappe-bench/env/bin/frappe: not found
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappeuser/.bench/bench/cli.py”, line 40, in cli
bench_command()
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 716, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 696, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 534, in invoke
return callback(*args, **kwargs)
File “/home/frappeuser/.bench/bench/commands/make.py”, line 56, in new_site
new_site(site, mariadb_root_password=mariadb_root_password, admin_password=admin_password)
File “/home/frappeuser/.bench/bench/utils.py”, line 150, in new_site
), cwd=os.path.join(bench_path, ‘sites’))
File “/home/frappeuser/.bench/bench/utils.py”, line 127, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: /home/frappeuser/frappe-bench/env/bin/frappe site1 --install 8e62d73f72


so what has changed. I still have few working snapshots but really would want a fresh install. I had to install pip 8.1.2 from /usr/local/lib/python2.7/dist-packages (python 2.7), Python 2.7.6.
any help greatly appreciated.
UPDATE **************************************************
if I run bench get-app https://github.com/frappe/frappe.git (after removing frappe folder) as mentioned above I get this
Command “/home/frappeuser/frappe-bench/env/bin/python -u -c “import setuptools, tokenize;file=’/tmp/pip-build-884BIB/python-ldap/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-q5XzAb-record/install-record.txt --single-version-externally-managed --compile --install-headers /home/frappeuser/frappe-bench/env/include/site/python2.7/python-ldap” failed with error code 1 in /tmp/pip-build-884BIB/python-ldap/

this should solve your problem. Frappe V 7.1-Beta: LDAP Dependancies

Thank you so much, that worked. Had to start a fresh installation though. Any idea if we were to update our snapshots with the dependencies, will it work?

@CoffeeHolic Open New Thread with more specific details. closing this for now.