Installation issue Mac

when I try same command the message
fatal: destination path ‘frappe’ already exists and is not an empty directory.
bench get-app https://github.com/frappe/frappe.git

1 --origin upstream
➜ frappe-bench bench new-site site1.local
INFO:bench.utils:creating new site site1.local
frappe app is not installed. Run the following command to install frappe
bench get-app https://github.com/frappe/frappe.git
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/Users/apple/Dev/bench-repo/bench/cli.py”, line 40, in cli
bench_command()
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/Users/apple/Dev/bench-repo/bench/commands/make.py”, line 64, in new_site
new_site(site, mariadb_root_password=mariadb_root_password, admin_password=admin_password)
File “/Users/apple/Dev/bench-repo/bench/utils.py”, line 192, in new_site
db_name=hashlib.sha1(site).hexdigest()[:10],
TypeError: Unicode-objects must be encoded before hashing

Delete the folder ‘frappe’ and try installing the app again.

I am biggner pls tell exact path in mac under Dev / frappe-bench need to delete

Did you try out this?

I try this

when bench start error show

2018-03-09 14:38:06 [1849] [ERROR] Procfile does not exist or is not a file

Can you check your frappe-bench folder and see if Procfile is present? If not you will need to create one.

Try this command in the frappe-bench folder: bench setup procfile

Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
sys.exit(cli())
File “/usr/local/lib/python3.6/site-packages/bench/cli.py”, line 40, in cli
bench_command()
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python3.6/site-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/usr/local/lib/python3.6/site-packages/bench/commands/setup.py”, line 123, in setup_procfile
setup_procfile(’.’)
File “/usr/local/lib/python3.6/site-packages/bench/config/procfile.py”, line 13, in setup_procfile
procfile = bench.env.get_template(‘Procfile’).render(
File “/usr/local/lib/python3.6/site-packages/jinja2/environment.py”, line 830, in get_template
return self._load_template(name, self.make_globals(globals))
File “/usr/local/lib/python3.6/site-packages/jinja2/environment.py”, line 804, in _load_template
template = self.loader.load(self, name, globals)
File “/usr/local/lib/python3.6/site-packages/jinja2/loaders.py”, line 113, in load
source, filename, uptodate = self.get_source(environment, name)
File “/usr/local/lib/python3.6/site-packages/jinja2/loaders.py”, line 235, in get_source
raise TemplateNotFound(template)
jinja2.exceptions.TemplateNotFound: Procfile

python 3.6 may be the problem here - ERPNext is only meant to run on python 2.7