Installation complete but erpnext i dont see!

Hello

I install erpnext with success i going in myip:8000 and i show error connection refuse

Only warning during installation it’s this

TASK [locale : Check current locale] ***************************************************************
skipping: [localhost]

TASK [locale : Set Locale] *************************************************************************
[WARNING]: when statements should not include jinja2 templating delimiters such as {{ }} or {% %}.
Found: (ansible_distribution == ‘Centos’ or ansible_distribution == ‘Ubuntu’) and
locale_test.stdout.find(‘LANG={{ locale_lang }}’) == -1

skipping: [localhost]

TASK [locale : Set keymap] *************************************************************************
[WARNING]: when statements should not include jinja2 templating delimiters such as {{ }} or {% %}.
Found: (ansible_distribution == ‘Centos’ or ansible_distribution == ‘Ubuntu’) and
locale_test.stdout.find(‘Keymap: {{locale_keymap}}’) == -1

skipping: [localhost]

Did you give any site name during installation of erpnext ? If yes, you should try to add the site name to your etc/hosts and access try to access it with sitename:8000

No not ask me where install or insert domain

It is not working.
I tried with the virtual box instance (a) Production one and (b) development one.
not one time, couple of time last few days I download and install the virtual instance

Some time back, it worked perfectly, now I guess it has something to do with the virtual instance itself, hope some one from ERPNext check the files and confirm
Thanks
Joseph John

CC @codingCoffee

@caygri Can you specify the exact steps to reproduce the error?? Which commands did you use to install ERPNext? The error log you posted isn’t helpful. Please post the last part if some error popped up. Did you see the message ‘ERPNext has been installed successfully’.

If you installed using the --production flag, it’ll be accessible on YOUR_IP, and if you’ve installed using the --develop flag, you’ll have to run the bench start command from the frappe-bench folder and only then it’ll be accessible on the YOUR_IP:8000.

@jjk_saji can you post an error log? It’ll help us in debugging the issue. :slight_smile:

i follow step by step your official tutorial. https://github.com/frappe/bench

and yes i see the messagge "ERPNext has been installed successfully’.

Only warning I have it’s this
[WARNING]: Host file not found: /etc/ansible/hosts

[WARNING]: provided hosts list is empty, only localhost is available

Which of these commands did you use?

sudo python install.py --develop

or

sudo python install.py --production

develop. it’s wrong?

i restore my vps and try with --production and show this error

TASK [swap : Set swapiness] ************************************************************************

fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: “echo 1 | tee /proc/sys/vm/swappiness”, “delta”: “0:00:00.097528”, “end”: “2018-02-07 12:56:28.852718”, “failed”: true, “rc”: 1, “start”: “2018-02-07 12:56:28.755190”, “stderr”: “tee: /proc/sys/vm/swappiness: Permission denied”, “stderr_lines”: [“tee: /proc/sys/vm/swappiness: Permission denied”], “stdout”: “1”, “stdout_lines”: [“1”]}
to retry, use: --limit @/tmp/.bench/playbooks/production/install.retry

PLAY RECAP *****************************************************************************************
localhost : ok=7 changed=4 unreachable=0 failed=1

@codingCoffee
Thanks for the reply. I will state the steps
I have used the virtual machine image from the download page “https://erpnext.com/download
Then I opened (imported ) it to virtual box ( couple of times, I changed the network setting to bridge, some times I did with the default network settings
Then started with the virtual box instance
once the instance is up, I logged using ‘frappe’ and found what is my ip address is
then I went to the host machine, types the IP address and the port IP:8080
got the message server not accessible
For trouble shooting I again logged into the guest (erpnext ) instance and from the command line, gave “telnet IP 8080” I got message connection closed by foreign host, this means the service which has to using the port 8080 not running.
This step I have done so many time, since yesterday and today
Hope I know where it is gone wrong
thanks

Hey @jjk_saji,

I’m still not able to debug the issue. Can you mention your system specifications? Where are you running the virtualbox instance?

Here’s what I tried to reproduce the issue:

  1. Downloaded the ERPNext-Production.ova
  2. Imported it into Virtualbox on my PC
  3. Started the imported machine
  4. Opened localhost:8080 in my browser and I was able to access it.

I also tried the same with the development instance:

  1. Downloaded the ERPNext-Dev.ova
  2. Imported it into Virtualbox on my PC
  3. Started the imported machine
  4. Logged in as frappe using password frappe
  5. Entered the frappe-bench directory using cd frappe-bench command
  6. Did a bench start
  7. Opened localhost:8000 in my browser and I was able to access it

@caygri are you running the script as root user? I’m not able to reproduce the issue. Can you post a few lines above and below this as well

yes like a root user.
i try all installation.

I dont understand what is the problem.

Seems like your VPS is not allowing you to set up a SWAP file. Can you post a few lines above and below this as well.

@codingCoffee
when you mention

Opened localhost:8080 in my browser and I was able to access it.
it is from the guest or from the host you are tryin, default virtual box image which is downloaded do not have a GUI, from where did u run the browser.
It it not better to mention IP_Address:8080 than saying localhost

I installed VirtualBox on my PC, and started the ERPNext virtual machine. Then in my PC’s browser I was able to access it on localhost.

If you have a dedicated IP on which you’re using the Virtual Machine, in that case you can use [IP_Address] instead of localhost.

guy i’m confusing a need to open new discussion for my problem?

Hi @codingCoffee,

I have a similar issue here

But the detailed error log on my end is this -

TASK [locale : Set Locale as en_US] **********************************************************************
ok: [localhost] => (item=LC_ALL=en_US.UTF-8)
ok: [localhost] => (item=LC_CTYPE=en_US.UTF-8)
ok: [localhost] => (item=LANG=en_US.UTF-8)

TASK [swap : Create swap space] **************************************************************************
skipping: [localhost]

TASK [swap : Make swap] **********************************************************************************
skipping: [localhost]

TASK [swap : Add to fstab] *******************************************************************************
skipping: [localhost]

TASK [swap : Turn swap on] *******************************************************************************
skipping: [localhost]

TASK [swap : Set swapiness] ******************************************************************************
fatal: [localhost]: FAILED! => {"changed": true, "cmd": "echo 1 | tee /proc/sys/vm/swappiness", "delta": "0:00:00.004686", "end": "2018-03-14 12:29:40.728648", "failed": true, "msg": "non-zero return code", "rc": 1, "start": "2018-03-14 12:29:40.723962", "stderr": "tee: /proc/sys/vm/swappiness: Permission denied", "stderr_lines": ["tee: /proc/sys/vm/swappiness: Permission denied"], "stdout": "1", "stdout_lines": ["1"]}
	to retry, use: --limit @/tmp/.bench/playbooks/site.retry

PLAY RECAP ***********************************************************************************************
localhost                  : ok=4    changed=1    unreachable=0    failed=1   

Traceback (most recent call last):
  File "install.py", line 387, in <module>
    install_bench(args)
  File "install.py", line 109, in install_bench
    run_playbook('site.yml', sudo=True, extra_vars=extra_vars)
  File "install.py", line 325, in run_playbook
    success = subprocess.check_call(args, cwd=os.path.join(cwd, 'playbooks'))
  File "/usr/lib64/python2.7/subprocess.py", line 542, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['ansible-playbook', '-c', 'local', 'site.yml', '-e', '@/tmp/extra_vars.json', '--become', '--become-user=frappe']' returned non-zero exit status 2

I am using a VPS from inmotionhosting and I am performing this operation as a root user. Any suggestions?

Please help, Thanks :slightly_smiling_face:

Can you try executing these commands, in your VPS, one by one, as root.
And post the error here log if any.

# dd if=/dev/zero of=/extraswap bs=1M count=1024
# mkswap /extraswap
# echo '/swapfile none swap sw 0 0' | sudo tee -a /etc/fstab
# swapon -a
# echo 1 | tee /proc/sys/vm/swappiness

Hi,

I did and I think there were errors. This is the output from the first command -

root@vps30915 [~]# dd if=/dev/zero of=/extraswap bs=1M count=1024
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 22.4528 s, 47.8 MB/s
root@vps30915 [~]# mkswap /extraswap
Setting up swapspace version 1, size = 1048572 KiB
no label, UUID=265e0253-909b-46b0-81cd-b2762caf9f99
root@vps30915 [~]# echo '/swapfile none swap sw 0 0' | sudo tee -a /etc/fstab
/swapfile none swap sw 0 0
root@vps30915 [~]# swapon -a
swapon: stat failed /swapfile: No such file or directory
root@vps30915 [~]# echo 1 | tee /proc/sys/vm/swappiness
tee: /proc/sys/vm/swappiness: Permission denied
1
root@vps30915 [~]#