How to make language selectable at first login?


I just installed v4 and want to set up everything before updating.
So I added my language files for Bosnian language (BS.CSV) to:

  • /home/erpnext/frappe-bench/apps/erpnext/erpnext/translations
  • /home/erpnext/frappe-bench/apps/frappe/frappe/translations
  • /home/erpnext/frappe-bench/apps/shopping_cart/shopping_cart/translations
    but there is no Bosnian on startup (see image bellow).

How to make newly added language selectable during initial startup?

See section #5

I see.
So when I added BS.CSV to those 3 folders, now I need to update languages.txt (step 4)?
Could you please tell me the location of languages.txt?
I can find it.

Is this it:

I guess not, because the first file has many languages listed and the second only english and when I add line “bs bosnian” to both files, dropdown language list is the same as in the screenshot above.

Please help.

there are 4 language.txt files:

  1. /home/erpnext/frappe-bench/apps/frappe/frappe/data/languages.txt
  2. /home/erpnext/frappe-bench/apps/frappe/test_sites/languages.txt
  3. /home/erpnext/frappe-bench/apps/erpnext/test_sites/languages.txt
  4. /home/erpnext/frappe-bench/sites/languages.txt

To answer my own post: one needs to edit the file:
and in line 63 add a language.
My line 63 now looks like this:

options: ["english", "العربية", "deutsch", "ελληνικά", "español", "français", "हिंदी","bosnian", "hrvatski",

And now I have Bosnian language on the dropdown menu at initial setup.

You guys need to update those instructions at:

Thanks added to our website list.

I’m glad I helped! :smile:


Which version are you using? Recent update in Version 4 loads the languages in Setup Wizard from languages.txt and is not at a hardcoded list:


I am using VirtualBox image downloaded from: but without update.

Updating it would fix this :smile: