How to access my ERP account after installing ERPNext on my Virtual box

Hi
I had installed ERPNext on my Virtualbox and it asked me to give username and password.After that all I can see is the command line.Please guide me to host it on webserver.

Try going to a website as
127.0.0.1:8080
or
127.0.0.1:8001

Hi
Unfortunately it doesn’t work.I can’t deploy and I don’t know how to obtain IP address for my machine.Please help me out from this situation and thanks for the reply

For getting VM IP type
ip addr show

try it with :8000 or :8080 or :8001 or just that ip

1 Like

Hi
I can’t get with it.Its just getting harder.Do You know any easy way to solve this problem…?

Hello
Sorry.I forget to tell You that I didn’t update my ERP image.I had tried a lot and every method is quite embarrassing.I hope You will help me to get update My ERP image.Thanks

enter ip addr show from vm app’s terminal, not from your pc’s terminal.

VirtualBox_ERPNext-Dev_15_10_2017_17_23_04

Thanks.
What to try next…?

try
bench start

after 3-4min

try 127.0.0.1 with :8000 or :8080 or :8001 or just that ip

Thanks.
Would You please guide me how to do bench start.VirtualBox_ERPNext-Dev_15_10_2017_17_27_34

I missed
Type,
cd frappe-bench
Then,
bench start

2 Likes

Thanks.
It works.I don’t know how to thank You.Yet I’m not finished.Hope you will guide me on next part.
See You later.
Bye

No issue. Create new post for any topic.

Also mark post as solved.

Hi
I encountered another problem.The Ip deployment failed when I tried to enter the software today.
The VM just shows this.VirtualBox_ERPNext-Dev_16_10_2017_13_25_54
I’m stucked.Please help me to figure out what is the problem…

How are you trying to access the application? If it is through a browser on your host machine goto http://your-vm-ip-address:8000 and wait for a while. This is assuming you have gone through the following commands.
~erp-vm:~$cd
~erp-vm:~$cd frappe-bench
~erp-vm:~$bench start
wait for a while till the application gets ready.

Hope it helps.

Hi
I had done as You had instructed Me.But the result is as follows


It is not loading…I hope You can provide me a
solution

First of you can not use 127.0.0.1 as an ip address for the Virtual Machine. If your virtual machine software is VirtualBox go to your virtual machine network settings and
-> select Bridge Networking then
-> select the actual network interface you are using to access the outside network.
-> Then goto you virtual machine stop the running app and run
$ifdown eth0
$ifup eth0
$ifconfig (gives you the ip address of the eth0 interface on the VM)

-> get the ip address from the output
-> run the previous commands to start the app.
-> replace the 127.0.0.1 with the ip you got on bullet one.

P.S.

You may have to use ifup and ifdown commands with sudo.