ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

How do you access Bench Manager after installing?


#1

I’ve installed a fresh copy of ERPNext on Ubuntu. I normally get to the site by going to localhost:8000. I installed the Bench Manager for the first time today to see how it works and it is installed to the bench-manager.local site. I’ve tried accessing it by going to bench-manager.local:8000 (and 8001), but the site is not available. How do you access Bench Manager?


#2

It’s on port 8080 on my setup, If possible , look at /etc/nginx/conf.d/frappe-bench.conf , you can see the server blocks. You could also try: bench setup nginx , it might report the port bindings. Or try bench set-nginx-port [sitename] [port] to set the port manually, restarting nginx after running it might be necessary.


#3

Ok it says that the port for bench-manager.local is 8001 when doing bench setup nginx. So is it correct to go to bench-manager.local:8001? Or should I be accessing it a different way? Also, my other site (site1.local) is not accessed by that name, but localhost. Why is that?


#4

In a browser , try: localhost:8001 in the address bar. Your Ubuntu install is not a VM? If it is you have to configre the port mappings.


#5

localhost:8001 did not work, which seems strange since that is the port for bench-manager. I am running ubuntu through a VM, but haven’t configured ports in the past on this setup. Any tips on how to configure them correctly?


#6

If you are using Virtualbox, the ports can be configured by clicking on Configuration, Network , Advanced. Try forwarding 8001 on the guest to 8001 on the host. If using a different virtualization platform or a VPS , consult the documentation for port forwarding.


#7

Ok thank you. That actually worked for my main site, which is localhost:8000. I forwarded it to port 80 and I am able to access it. But the issue still remains for the other (localhost:8001 forwarded to 81). I get “The site can’t be reached.” Is there anything you have to do other than installing and forwarding the ports for Bench Manager?


#8

It seems like you need to determine which port, if any Manaager is running on. In the VM console, what does: bench setup nginx return?


#9

Port configuration list:
Site site1.local assigned port: 80
Site bench-manager.local assigned port 8001


#10

Try sudo service nginx reload.


#11

In the console: sudo apt install lynx, then lynx localhost:8001

lynx is a command line web browser. Using it will tell us if the site is indeed up on the VM or not. If it is , your port forward isn’t right.


#12

This yields:
nginx: unrecognized service


#13

Installed lynx and it did indeed fail at accessing localhost:8001. So I’m assuming this means that the bench-manager.local site is not actually a proper site?


#14

The site might not be running or is misconfigured. You can try bench use bench-manager.local, which shouldn’t make a diffeence. Otherwise retrace your steps and make sure manager was installed to the site, I think I did it something like:

bench --site bench-manager.local install-app bench_manager
bench use bench-manager.local
bench setup manager