How do I install v10 or v11 production with easy install script now that v12 is the default? [Question Revised for Clarity]

Late last night I tried to install v10 on a fresh server and it came up as v12!!

I used this command to do the install as I always have:

python install.py --production --user [your user] --frappe-branch v10.x.x --erpnext-branch v10.x.x

So what changed?

What is the new syntax for me to be able to install v10 or v11 now?

BKM

Hi BKM,

Probably what you want to force and/or look for is a smoking gun error here -

Some git repos reference ‘plumbing’ has possibly changed and needs to be manually updated?

Just now I refreshed my local repos (circa v9) from remote for erpnext:

frappe@erpnext:~/frappe-bench/apps/erpnext$ git remote update upstream --prune

that reported this:

  • [new branch] v10.x.x -> upstream/v10.x.x
  • [new branch] v9.x.x -> upstream/v9.x.x
  • [new branch] version-11 -> upstream/version-11
  • [new branch] version-11-hotfix -> upstream/version-11-hotfix
  • [new branch] version-12 -> upstream/version-12
  • [new branch] version-12-hotfix -> upstream/version-12-hotfix

and similarly for frappe:

frappe@erpnext:~/frappe-bench/apps/frappe$ git remote update upstream --prune

  • [new branch] v10.x.x -> upstream/v10.x.x
    2ce0f70…e8f9fbb v8.x.x -> upstream/v8.x.x
  • [new branch] v9.x.x -> upstream/v9.x.x
  • [new branch] version-11 -> upstream/version-11
  • [new branch] version-11-hotfix -> upstream/version-11-hotfix
  • [new branch] version-12 -> upstream/version-12
  • [new branch] version-12-hotfix -> upstream/version-12-hotfix

To refresh your local repos see this reference https://stackoverflow.com/questions/36358265/when-does-git-refresh-the-list-of-remote-branches

This may break things for you or OTOH may help?

I think you missed the point.

There were no errors. I simply used the same command that I use all the time to install v10 and when it was done the actual version installed was v12.

Soooo, The old command syntax no longer does what it is supposed to do, but it doesn’t generate errors either. BTW… This worked only 4 days ago and now it does something different.

I guess the clearer question would be:

How do I install v10 now that v12 is the default?

BKM

Right that’s the question. My guess is this change to the bench to make v12 the default, broke the branch arguments you refer to

[Question that started the thread now revised for clarity]

Wow… That is what I get for 'assuming" the new activity was an intended function and not a bug indicating a broken function in the code.

Sooooooo, now we wait for it to be tested, approved, merged, and released.

Ugh!

BKM

That may solve loooooots of problems as version-11 is a sound alternative now for our broken production systems. Have you tried to branch version-11? Maybe the install script gets this by chance? Obvious that I haven’t checked the code.

@bkm Horrible timing I really need v10 installed, can’t seem to restore my v10 backup on v12 at all and migrate and I dont even have any special apps or modules.

Did this get resolved? Last night I tried your line and it would only install v12 :frowning:

@Airbag888 I attempted to upgrade from v10 to v12 and faced myriad issues. I had to go through countless mumbo jumbo and after several hours of fixing this and that (which unfortunately i did not take any time to document), i found myself in v11. Every attempt to move to v12 from there failed. But good thing was that i was then able to set up a fresh server and restore the v11 backup which would not have been possible with v10.

Thank you. So basically I should attempt to install v11 and restore the db on there, perform a migrate and hope for the best?

Have you seen that there’s apparently an issue choosing the version you want via the install script now? Or is it working for v11?

Currently there is no way to install v11 as you will be presented with v12 no matter what you do. So attempt to upgrade from v10 following steps provided in this post below:

You might encounter some issues. Resolve them and once you are able to launch the upgraded v11, make a backup and install a fresh v12 instance. Restore your created backup and you should be fine from here on. That’s the way i solved my latest attempt to migrate from v10 - v12.

You can install v11 if you don’t use easy install. And it’s not all that hard!

Thanks

Jay

Please understand I don’t have your level of expertise. I don’t mind going to go the ‘long way’ which btw I have and the instructions could not be followed 100% because at various spots there was issues such as adding the repo for maria (fresh ubuntu 18.04 btw. Anyway, can you point to some instructions to find out where to install v10? I’ve scrapped my vm and recreated it likely almost 10 times in the past 2 days to try and sort this out. Plus the baby is sick, life is tough right now.

Thanks

I see, so what you propose is upgrading v10 and going through the motion that you linked… I must admit I’m super scared to touch the v10 install after seeing how much could/went wrong and how somehow v10 and v11 disappeared from the repo and no one thought good to rectify this so far…

@JayRam,

Please provide me a link with info how to install v11 manually.
Will appreciate.

Thanks,
John.

Use the Manual Install link here:

Replace the bench init frappe-bench

with the command:

bench init --version 11 frappe-bench

Rest are the same.

Hope this helps.

Thanks

Jay

this may not exactly relevant with your question, but this is what I do to install previous version when master is still on v11.x.x using easy install script.

Also please look at this too as this is my original question for installing previous version of ERPnext

@JayRam,

Thanks - the below worked for me

bench init --frappe-branch version-11  --python /usr/bin/python3 frappe-bench

@Tufan_Kaynak2,

This works - thank you.

having same issue

try to install v10 from last week but v12 with develop version only installed

anyone kindly share the solution for this