Hiding fields from selected users (permission level question)

I want to hide financial data for Purchase Orders for certain roles.  In other words, I'd like certain roles to access Purchase Orders but only for certain fields (supplier, item, quantity).  

I understand certain fields have perm level >0 and this is configurable, but if I set the role to only access perm level = 0 for the form, the Purchase Order form does not load properly.  It doesn't say "you are not permitted" -- it appears to load and then just stops mid-way.  What you end up seeing is an incomplete form with certain fields showing but mostly not.

My immediate concern is specific to the Purchase Order field but the broader question is for all forms.  A related thread here asks if fields can simply be hidden by user but I'm not sure how this ended up.

To ask my question more directly: how do we know what Purchase Order fields are required to be permission-accessible in order to load the PO form properly?



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

If you assign a role to access only perm level 0, then the user will be able to see only fields which have perm level 0. In other word, if you want to show a field to a role, you have to give at-least READ permission for that perm level.
Did you checked the perm level of the fields which are not loading in PO?

On 15-Aug-2013, at 2:36 PM, lxnow wrote:

question



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

if you want to show a field to a role, you have to give at-least READ permission for that perm level

Yes I understand this already, but my goal is to hide the field so I shouldn't give read permission at all.

Did you checked the perm level of the fields which are not loading in PO?

I cannot tell what fields are not loading as the form looks messed up.  No real value is shown except the Doc # and the Created by and Modified by data. The rest are just blank. Item table also does not show. 

I understand I can do trial-and-error (which I'll probably get to when I find time) but I am throwing out the question here in case there's a general rule on what the "bare minimums" are for a form to load properly. 

Isn't the way it should work is if I set all fields to perm level 1, except, says, Supplier field which I retain at perm level 0, then a role with only access to read perm level 0 should *still* be able to load the Purchase Order but only see the Supplier name? (and the doc number and user creator I guess)?

On Thursday, August 15, 2013 5:41:07 PM UTC+8, Nabin Hait wrote:
If you assign a role to access only perm level 0, then the user will be able to see only fields which have perm level 0. In other word, if you want to show a field to a role, you have to give at-least READ permission for that perm level.
Did you checked the perm level of the fields which are not loading in PO?

On 15-Aug-2013, at 2:36 PM, lxnow wrote:

question



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

It should work as per your expectation. And it is working that way only in my local machine. Can you inspect little bit more whether you have changed anything apart from the perm level?

On 15-Aug-2013, at 3:33 PM, lxnow wrote:

if you want to show a field to a role, you have to give at-least READ permission for that perm level

Yes I understand this already, but my goal is to hide the field so I shouldn't give read permission at all.

Did you checked the perm level of the fields which are not loading in PO?

I cannot tell what fields are not loading as the form looks messed up.  No real value is shown except the Doc # and the Created by and Modified by data. The rest are just blank. Item table also does not show. 

I understand I can do trial-and-error (which I'll probably get to when I find time) but I am throwing out the question here in case there's a general rule on what the "bare minimums" are for a form to load properly. 

Isn't the way it should work is if I set all fields to perm level 1, except, says, Supplier field which I retain at perm level 0, then a role with only access to read perm level 0 should *still* be able to load the Purchase Order but only see the Supplier name? (and the doc number and user creator I guess)?

On Thursday, August 15, 2013 5:41:07 PM UTC+8, Nabin Hait wrote:
If you assign a role to access only perm level 0, then the user will be able to see only fields which have perm level 0. In other word, if you want to show a field to a role, you have to give at-least READ permission for that perm level.
Did you checked the perm level of the fields which are not loading in PO?

On 15-Aug-2013, at 2:36 PM, lxnow wrote:

question




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

Figured it out. When a field has a higher permission level and is marked as "required", the form won't load properly.  

Removing the "required" property allows access now.

On Thursday, August 15, 2013 6:23:54 PM UTC+8, Nabin Hait wrote:
It should work as per your expectation. And it is working that way only in my local machine. Can you inspect little bit more whether you have changed anything apart from the perm level?

On 15-Aug-2013, at 3:33 PM, lxnow wrote:

if you want to show a field to a role, you have to give at-least READ permission for that perm level

Yes I understand this already, but my goal is to hide the field so I shouldn't give read permission at all.

Did you checked the perm level of the fields which are not loading in PO?

I cannot tell what fields are not loading as the form looks messed up.  No real value is shown except the Doc # and the Created by and Modified by data. The rest are just blank. Item table also does not show. 

I understand I can do trial-and-error (which I'll probably get to when I find time) but I am throwing out the question here in case there's a general rule on what the "bare minimums" are for a form to load properly. 

Isn't the way it should work is if I set all fields to perm level 1, except, says, Supplier field which I retain at perm level 0, then a role with only access to read perm level 0 should *still* be able to load the Purchase Order but only see the Supplier name? (and the doc number and user creator I guess)?

On Thursday, August 15, 2013 5:41:07 PM UTC+8, Nabin Hait wrote:
If you assign a role to access only perm level 0, then the user will be able to see only fields which have perm level 0. In other word, if you want to show a field to a role, you have to give at-least READ permission for that perm level.
Did you checked the perm level of the fields which are not loading in PO?

On 15-Aug-2013, at 2:36 PM, lxnow wrote:

question




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

Noticed something strange this time... fields with permission level 1 are viewable with a role that is only set to read perm level 0.  Is this the way it should work?

On Friday, August 16, 2013 9:51:25 AM UTC+8, lxnow wrote:
Figured it out. When a field has a higher permission level and is marked as "required", the form won't load properly.  

Removing the "required" property allows access now.

On Thursday, August 15, 2013 6:23:54 PM UTC+8, Nabin Hait wrote:
It should work as per your expectation. And it is working that way only in my local machine. Can you inspect little bit more whether you have changed anything apart from the perm level?

On 15-Aug-2013, at 3:33 PM, lxnow wrote:

if you want to show a field to a role, you have to give at-least READ permission for that perm level

Yes I understand this already, but my goal is to hide the field so I shouldn't give read permission at all.

Did you checked the perm level of the fields which are not loading in PO?

I cannot tell what fields are not loading as the form looks messed up.  No real value is shown except the Doc # and the Created by and Modified by data. The rest are just blank. Item table also does not show. 

I understand I can do trial-and-error (which I'll probably get to when I find time) but I am throwing out the question here in case there's a general rule on what the "bare minimums" are for a form to load properly. 

Isn't the way it should work is if I set all fields to perm level 1, except, says, Supplier field which I retain at perm level 0, then a role with only access to read perm level 0 should *still* be able to load the Purchase Order but only see the Supplier name? (and the doc number and user creator I guess)?

On Thursday, August 15, 2013 5:41:07 PM UTC+8, Nabin Hait wrote:
If you assign a role to access only perm level 0, then the user will be able to see only fields which have perm level 0. In other word, if you want to show a field to a role, you have to give at-least READ permission for that perm level.
Did you checked the perm level of the fields which are not loading in PO?

On 15-Aug-2013, at 2:36 PM, lxnow wrote:

question




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

No, that should not be the behaviour. We will try to replicate it at our end. Can you replicate it with other form and users? May be user has another role which allows him to see the field with perm level 1.

On 16 Aug 2013 07:27, "lxnow" <la...@union.ph> wrote:
Noticed something strange this time... fields with permission level 1 are viewable with a role that is only set to read perm level 0. Is this the way it should work?

On Friday, August 16, 2013 9:51:25 AM UTC+8, lxnow wrote:
Figured it out. When a field has a higher permission level and is marked as "required", the form won't load properly.

Removing the "required" property allows access now.

On Thursday, August 15, 2013 6:23:54 PM UTC+8, Nabin Hait wrote:
It should work as per your expectation. And it is working that way only in my local machine. Can you inspect little bit more whether you have changed anything apart from the perm level?

On 15-Aug-2013, at 3:33 PM, lxnow wrote:

if you want to show a field to a role, you have to give at-least READ permission for that perm level

Yes I understand this already, but my goal is to hide the field so I shouldn't give read permission at all.

Did you checked the perm level of the fields which are not loading in PO?

I cannot tell what fields are not loading as the form looks messed up. No real value is shown except the Doc # and the Created by and Modified by data. The rest are just blank. Item table also does not show.

I understand I can do trial-and-error (which I'll probably get to when I find time) but I am throwing out the question here in case there's a general rule on what the "bare minimums" are for a form to load properly.

Isn't the way it should work is if I set all fields to perm level 1, except, says, Supplier field which I retain at perm level 0, then a role with only access to read perm level 0 should *still* be able to load the Purchase Order but only see the Supplier name? (and the doc number and user creator I guess)?

On Thursday, August 15, 2013 5:41:07 PM UTC+8, Nabin Hait wrote:
If you assign a role to access only perm level 0, then the user will be able to see only fields which have perm level 0. In other word, if you want to show a field to a role, you have to give at-least READ permission for that perm level.
Did you checked the perm level of the fields which are not loading in PO?

On 15-Aug-2013, at 2:36 PM, lxnow wrote:

question




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

Already using a test user with a test role .  User has only one role.  And the role only has one permission set in the perm engine: read access to Purchase Order form at perm level 0.

So it can't be an overlap.

On Friday, August 16, 2013 12:10:23 PM UTC+8, Nabin Hait wrote:

No, that should not be the behaviour. We will try to replicate it at our end. Can you replicate it with other form and users? May be user has another role which allows him to see the field with perm level 1.

On 16 Aug 2013 07:27, "lxnow" <la...@union.ph> wrote:
Noticed something strange this time... fields with permission level 1 are viewable with a role that is only set to read perm level 0.  Is this the way it should work?

On Friday, August 16, 2013 9:51:25 AM UTC+8, lxnow wrote:
Figured it out. When a field has a higher permission level and is marked as "required", the form won't load properly.  

Removing the "required" property allows access now.

On Thursday, August 15, 2013 6:23:54 PM UTC+8, Nabin Hait wrote:
It should work as per your expectation. And it is working that way only in my local machine. Can you inspect little bit more whether you have changed anything apart from the perm level?

On 15-Aug-2013, at 3:33 PM, lxnow wrote:

if you want to show a field to a role, you have to give at-least READ permission for that perm level

Yes I understand this already, but my goal is to hide the field so I shouldn't give read permission at all.

Did you checked the perm level of the fields which are not loading in PO?

I cannot tell what fields are not loading as the form looks messed up.  No real value is shown except the Doc # and the Created by and Modified by data. The rest are just blank. Item table also does not show. 

I understand I can do trial-and-error (which I'll probably get to when I find time) but I am throwing out the question here in case there's a general rule on what the "bare minimums" are for a form to load properly. 

Isn't the way it should work is if I set all fields to perm level 1, except, says, Supplier field which I retain at perm level 0, then a role with only access to read perm level 0 should *still* be able to load the Purchase Order but only see the Supplier name? (and the doc number and user creator I guess)?

On Thursday, August 15, 2013 5:41:07 PM UTC+8, Nabin Hait wrote:
If you assign a role to access only perm level 0, then the user will be able to see only fields which have perm level 0. In other word, if you want to show a field to a role, you have to give at-least READ permission for that perm level.
Did you checked the perm level of the fields which are not loading in PO?

On 15-Aug-2013, at 2:36 PM, lxnow wrote:

question




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

Sorry, my mistake. I clicked on the wrong role with the user. Please disregard previous messages; I will do some more testing.

On Friday, August 16, 2013 12:14:31 PM UTC+8, lxnow wrote:
Already using a test user with a test role .  User has only one role.  And the role only has one permission set in the perm engine: read access to Purchase Order form at perm level 0.

So it can't be an overlap.

On Friday, August 16, 2013 12:10:23 PM UTC+8, Nabin Hait wrote:

No, that should not be the behaviour. We will try to replicate it at our end. Can you replicate it with other form and users? May be user has another role which allows him to see the field with perm level 1.

On 16 Aug 2013 07:27, "lxnow" <la...@union.ph> wrote:
Noticed something strange this time... fields with permission level 1 are viewable with a role that is only set to read perm level 0.  Is this the way it should work?

On Friday, August 16, 2013 9:51:25 AM UTC+8, lxnow wrote:
Figured it out. When a field has a higher permission level and is marked as "required", the form won't load properly.  

Removing the "required" property allows access now.

On Thursday, August 15, 2013 6:23:54 PM UTC+8, Nabin Hait wrote:
It should work as per your expectation. And it is working that way only in my local machine. Can you inspect little bit more whether you have changed anything apart from the perm level?

On 15-Aug-2013, at 3:33 PM, lxnow wrote:

if you want to show a field to a role, you have to give at-least READ permission for that perm level

Yes I understand this already, but my goal is to hide the field so I shouldn't give read permission at all.

Did you checked the perm level of the fields which are not loading in PO?

I cannot tell what fields are not loading as the form looks messed up.  No real value is shown except the Doc # and the Created by and Modified by data. The rest are just blank. Item table also does not show. 

I understand I can do trial-and-error (which I'll probably get to when I find time) but I am throwing out the question here in case there's a general rule on what the "bare minimums" are for a form to load properly. 

Isn't the way it should work is if I set all fields to perm level 1, except, says, Supplier field which I retain at perm level 0, then a role with only access to read perm level 0 should *still* be able to load the Purchase Order but only see the Supplier name? (and the doc number and user creator I guess)?

On Thursday, August 15, 2013 5:41:07 PM UTC+8, Nabin Hait wrote:
If you assign a role to access only perm level 0, then the user will be able to see only fields which have perm level 0. In other word, if you want to show a field to a role, you have to give at-least READ permission for that perm level.
Did you checked the perm level of the fields which are not loading in PO?

On 15-Aug-2013, at 2:36 PM, lxnow wrote:

question




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.



You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

There was an issue related to permlevel and in_listview property for fields in grid. We have fixed that, please check at your end.

On 16-Aug-2013, at 9:46 AM, lxnow wrote:

Sorry, my mistake. I clicked on the wrong role with the user. Please disregard previous messages; I will do some more testing.

On Friday, August 16, 2013 12:14:31 PM UTC+8, lxnow wrote:
Already using a test user with a test role .  User has only one role.  And the role only has one permission set in the perm engine: read access to Purchase Order form at perm level 0.

So it can't be an overlap.

On Friday, August 16, 2013 12:10:23 PM UTC+8, Nabin Hait wrote:

No, that should not be the behaviour. We will try to replicate it at our end. Can you replicate it with other form and users? May be user has another role which allows him to see the field with perm level 1.

On 16 Aug 2013 07:27, "lxnow" <la...@union.ph> wrote:
Noticed something strange this time... fields with permission level 1 are viewable with a role that is only set to read perm level 0.  Is this the way it should work?

On Friday, August 16, 2013 9:51:25 AM UTC+8, lxnow wrote:
Figured it out. When a field has a higher permission level and is marked as "required", the form won't load properly.  

Removing the "required" property allows access now.

On Thursday, August 15, 2013 6:23:54 PM UTC+8, Nabin Hait wrote:
It should work as per your expectation. And it is working that way only in my local machine. Can you inspect little bit more whether you have changed anything apart from the perm level?

On 15-Aug-2013, at 3:33 PM, lxnow wrote:

if you want to show a field to a role, you have to give at-least READ permission for that perm level

Yes I understand this already, but my goal is to hide the field so I shouldn't give read permission at all.

Did you checked the perm level of the fields which are not loading in PO?

I cannot tell what fields are not loading as the form looks messed up.  No real value is shown except the Doc # and the Created by and Modified by data. The rest are just blank. Item table also does not show. 

I understand I can do trial-and-error (which I'll probably get to when I find time) but I am throwing out the question here in case there's a general rule on what the "bare minimums" are for a form to load properly. 

Isn't the way it should work is if I set all fields to perm level 1, except, says, Supplier field which I retain at perm level 0, then a role with only access to read perm level 0 should *still* be able to load the Purchase Order but only see the Supplier name? (and the doc number and user creator I guess)?

On Thursday, August 15, 2013 5:41:07 PM UTC+8, Nabin Hait wrote:
If you assign a role to access only perm level 0, then the user will be able to see only fields which have perm level 0. In other word, if you want to show a field to a role, you have to give at-least READ permission for that perm level.
Did you checked the perm level of the fields which are not loading in PO?

On 15-Aug-2013, at 2:36 PM, lxnow wrote:

question




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.





You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

Great, works now.  So for anyone else reading this, I figured the steps to hide fields are:
  1. Set field perm level higher than what role is allowed to READ
  2. Field should not be Required
  3. Field should not be In List View


On Friday, August 16, 2013 3:08:13 PM UTC+8, Nabin Hait wrote:
There was an issue related to permlevel and in_listview property for fields in grid. We have fixed that, please check at your end.

On 16-Aug-2013, at 9:46 AM, lxnow wrote:

Sorry, my mistake. I clicked on the wrong role with the user. Please disregard previous messages; I will do some more testing.

On Friday, August 16, 2013 12:14:31 PM UTC+8, lxnow wrote:
Already using a test user with a test role .  User has only one role.  And the role only has one permission set in the perm engine: read access to Purchase Order form at perm level 0.

So it can't be an overlap.

On Friday, August 16, 2013 12:10:23 PM UTC+8, Nabin Hait wrote:

No, that should not be the behaviour. We will try to replicate it at our end. Can you replicate it with other form and users? May be user has another role which allows him to see the field with perm level 1.

On 16 Aug 2013 07:27, "lxnow" <la...@union.ph> wrote:
Noticed something strange this time... fields with permission level 1 are viewable with a role that is only set to read perm level 0.  Is this the way it should work?

On Friday, August 16, 2013 9:51:25 AM UTC+8, lxnow wrote:
Figured it out. When a field has a higher permission level and is marked as "required", the form won't load properly.  

Removing the "required" property allows access now.

On Thursday, August 15, 2013 6:23:54 PM UTC+8, Nabin Hait wrote:
It should work as per your expectation. And it is working that way only in my local machine. Can you inspect little bit more whether you have changed anything apart from the perm level?

On 15-Aug-2013, at 3:33 PM, lxnow wrote:

if you want to show a field to a role, you have to give at-least READ permission for that perm level

Yes I understand this already, but my goal is to hide the field so I shouldn't give read permission at all.

Did you checked the perm level of the fields which are not loading in PO?

I cannot tell what fields are not loading as the form looks messed up.  No real value is shown except the Doc # and the Created by and Modified by data. The rest are just blank. Item table also does not show. 

I understand I can do trial-and-error (which I'll probably get to when I find time) but I am throwing out the question here in case there's a general rule on what the "bare minimums" are for a form to load properly. 

Isn't the way it should work is if I set all fields to perm level 1, except, says, Supplier field which I retain at perm level 0, then a role with only access to read perm level 0 should *still* be able to load the Purchase Order but only see the Supplier name? (and the doc number and user creator I guess)?

On Thursday, August 15, 2013 5:41:07 PM UTC+8, Nabin Hait wrote:
If you assign a role to access only perm level 0, then the user will be able to see only fields which have perm level 0. In other word, if you want to show a field to a role, you have to give at-least READ permission for that perm level.
Did you checked the perm level of the fields which are not loading in PO?

On 15-Aug-2013, at 2:36 PM, lxnow wrote:

question




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.





You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

Fixed the listview issue, so if field is in listview, still you will be able to set higher permlevel. But definitely it should not mandatory field.

On 16-Aug-2013, at 1:34 PM, lxnow wrote:

  1. Field should not be In List View




You received this message because you are subscribed to the Google Groups “ERPNext User’s Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-user-forum+un...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.