Get V4 Repository

Hi
Can any one tell me how can i get V4 erpnext

Thanks sir…and Sorry i didn’t mention…i need full v4 bench,frappe-bench and erpnext…It means i want v4 installation…!
How can i sir…?

bench init --frappe-branch v4.x.x frappe-bench
cd frappe-bench
bench get-app erpnext https://github.com/frappe/erpnext --branch v4.x.x

Thank you for this valuable reply sir…!

Hi Sir,
I have tried the commands given by you using Manual installation but still I am getting errors…!

[stuser@stcentvm ~]$ sudo pip install -e bench-repo
Obtaining file:///home/stuser/bench-repo
Running setup.py (path:/home/stuser/bench-repo/setup.py) egg_info for package from file:///home/stuser/bench-repo

file bench.py (for module bench) not found

Requirement already satisfied (use --upgrade to upgrade): Click in /usr/lib64/py thon2.7/site-packages (from bench==0.1)
Requirement already satisfied (use --upgrade to upgrade): jinja2 in /usr/lib/pyt hon2.7/site-packages (from bench==0.1)
Requirement already satisfied (use --upgrade to upgrade): virtualenv in /usr/lib /python2.7/site-packages (from bench==0.1)
Requirement already satisfied (use --upgrade to upgrade): requests in /usr/lib/p ython2.7/site-packages (from bench==0.1)
Requirement already satisfied (use --upgrade to upgrade): honcho in /usr/lib/pyt hon2.7/site-packages (from bench==0.1)
Requirement already satisfied (use --upgrade to upgrade): semantic-version in /u sr/lib/python2.7/site-packages (from bench==0.1)
Requirement already satisfied (use --upgrade to upgrade): GitPython==0.3.2.RC1 i n /usr/lib/python2.7/site-packages (from bench==0.1)
Requirement already satisfied (use --upgrade to upgrade): markupsafe in /usr/lib /python2.7/site-packages (from jinja2->bench==0.1)
Requirement already satisfied (use --upgrade to upgrade): gitdb>=0.5.1 in /usr/l ib64/python2.7/site-packages (from GitPython==0.3.2.RC1->bench==0.1)
Requirement already satisfied (use --upgrade to upgrade): smmap>=0.8.5 in /usr/l ib/python2.7/site-packages (from gitdb>=0.5.1->GitPython==0.3.2.RC1->bench==0.1)
Installing collected packages: bench
Running setup.py develop for bench

file bench.py (for module bench) not found
Creating /usr/lib/python2.7/site-packages/bench.egg-link (link to .)
bench 0.1 is already the active version in easy-install.pth
Installing bench script to /usr/bin

Installed /home/stuser/bench-repo

Successfully installed bench
Cleaning up…

Can you please help otherwise can I go for easy way installation of Frappe Bench V4, for that please provide the setup_frappe.sh file for V4.
Thanks in advance

Now run,

bench init --frappe-branch v4.x.x frappe-bench
cd frappe-bench
bench get-app erpnext https://github.com/frappe/erpnext --branch v4.x.x

After Run this command

[stuser@stcentvm ~]$ bench init --frappe-branch v4.13.1 frappe-bench
Already using interpreter /usr/bin/python
/home/stuser/frappe-bench/env/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
/home/stuser/frappe-bench/env/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
/home/stuser/frappe-bench/env/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-QvNwjj-build
Error: None
Traceback (most recent call last):
File “/usr/bin/bench”, line 9, in
load_entry_point(‘bench==0.1’, ‘console_scripts’, ‘bench’)()
File “/home/stuser/bench-repo/bench/cli.py”, line 56, in cli
bench()
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 664, in call
return self.main(*args, **kwargs)
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 644, in main
rv = self.invoke(ctx)
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 991, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 837, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/lib64/python2.7/site-packages/click/core.py”, line 464, in invoke
return callback(*args, **kwargs)
File “/home/stuser/bench-repo/bench/cli.py”, line 161, in init
no_auto_update=no_auto_update, frappe_path=frappe_path, frappe_branch=frappe_branch)
File “/home/stuser/bench-repo/bench/utils.py”, line 56, in init
setup_env(bench=path)
File “/home/stuser/bench-repo/bench/utils.py”, line 87, in setup_env
exec_cmd(’./env/bin/pip -q install https://github.com/frappe/MySQLdb1/archive/MySQLdb-1.2.5-patched.tar.gz’, cwd=bench)
File “/home/stuser/bench-repo/bench/utils.py”, line 79, in exec_cmd
subprocess.check_call(cmd, cwd=cwd, shell=True)
File “/usr/lib64/python2.7/subprocess.py”, line 542, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘./env/bin/pip -q install https://github.com/frappe/MySQLdb1/archive/MySQLdb-1.2.5-patched.tar.gz’ returned non-zero exit status 1

Now i getting this error