Try ERPNext Buy Support Partners Foundation

FYI: New installation error from pip

I have installed frappe and erpnext in a docker container for development.

There is a new error whilst install since October 2020.

bench init --skip-redis-config-generation --frappe-branch version-13-beta frappe-bench

WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: `pip install frappe-bench`

$ /home/frappe/.local/bin/virtualenv -q env -p python3

Getting frappe
$ git clone https://github.com/frappe/frappe.git --branch version-13-beta --depth 1 --origin upstream
Cloning into 'frappe'...
remote: Enumerating objects: 2924, done.
remote: Counting objects: 100% (2924/2924), done.
remote: Compressing objects: 100% (2724/2724), done.
remote: Total 2924 (delta 388), reused 1079 (delta 131), pack-reused 0
Receiving objects: 100% (2924/2924), 11.96 MiB | 9.77 MiB/s, done.
Resolving deltas: 100% (388/388), done.

Installing frappe
$ frappe-bench/env/bin/pip install -q -U -e frappe-bench/apps/frappe 
ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

# another ERROR:
google-api-core 1.22.3 requires google-auth<2.0dev,>=1.21.1, but you'll have google-auth 1.18.0 which is incompatible.

But everything is working well! :smiley:

Also interested on how to deal with that error.