Try ERPNext Buy Support Partners Foundation

Frontmatter 3.0.5 has requirement PyYAML==3.13 on NEW Installation in UBUNTU 18.04

Trying to fresh install but on giving command in terminal
“bench init erpnext” getting error for Frontmatter 3.0.5 has requirement PyYAML–3.13, but you’ll have pyjama 5.1 which is incompatible.

can anyone suggest steps to got done and change the version of pyyaml or any other way.

thank you

1 Like

make sure all requisites are installed first and script command starts with python3 ....
to avoid aborted installation, disable IPv6 and install redis and get it run before running script

I think there is a conflict after the merge: https://github.com/frappe/frappe/pull/9303

2 Likes

For now you can install using command

bench init --frappe-branch version-12 erpnext

2 Likes

There’s a pending PR to fix this, please merge: https://github.com/jonbeebe/frontmatter/pull/8

Worked with this code. and successful running erpnext version 12 in developer mode.
Thanks.

1 Like

Thanks @dipalivaddoriya for confirmation :slight_smile: