Frappe and erpnext installation errror?

ikhlas@ikhlas:~/frappe-bench/apps/frappe$ sudo python setup.py develop
[sudo] password for ikhlas:
running develop
Checking .pth file support in /usr/local/lib/python2.7/dist-packages/
/usr/bin/python -E -c pass
TEST PASSED: /usr/local/lib/python2.7/dist-packages/ appears to support .pth files
running egg_info
writing requirements to frappe.egg-info/requires.txt
writing frappe.egg-info/PKG-INFO
writing top-level names to frappe.egg-info/top_level.txt
writing dependency_links to frappe.egg-info/dependency_links.txt
writing requirements to frappe.egg-info/requires.txt
writing frappe.egg-info/PKG-INFO
writing top-level names to frappe.egg-info/top_level.txt
writing dependency_links to frappe.egg-info/dependency_links.txt
reading manifest file ‘frappe.egg-info/SOURCES.txt’
reading manifest template ‘MANIFEST.in’
warning: no files found matching ‘.json’
warning: no files found matching '
.dat’ under directory ‘frappe’
warning: no files found matching ‘.jpg’ under directory ‘frappe’
warning: no files found matching '
.swf’ under directory ‘frappe’
warning: no files found matching ‘.ico’ under directory ‘frappe’
warning: no previously-included files matching '
.pyc’ found under directory ‘*’
writing manifest file ‘frappe.egg-info/SOURCES.txt’
running build_ext
Creating /usr/local/lib/python2.7/dist-packages/frappe.egg-link (link to .)
frappe 6.27.4 is already the active version in easy-install.pth

Installed /home/ikhlas/frappe-bench/apps/frappe
Processing dependencies for frappe==6.27.4
Searching for kombu>=3.0.34,<3.1
Reading http://pypi.python.org/simple/kombu/
Best match: kombu 3.0.35
Downloading https://pypi.python.org/packages/source/k/kombu/kombu-3.0.35.tar.gz#md5=6483ac8ba7109ec606f5cb9bd084b6ef
Processing kombu-3.0.35.tar.gz
Running kombu-3.0.35/setup.py -q bdist_egg --dist-dir /tmp/easy_install-55uqnF/kombu-3.0.35/egg-dist-tmp-lKT6_D
error: /tmp/easy_install-55uqnF/kombu-3.0.35/requirements/default.txt: No such file or directory
ikhlas@ikhlas:~/frappe-bench/apps/frappe$

Thanks
Sajid

Can you try running

python install.py --develop

Without sudo and with --develop

@vjFaLk
ikhlas@ikhlas:~$ python install.py --develop
python: can’t open file ‘install.py’: [Errno 2] No such file or directory

From your previous traceback, I’m not understanding what your setup is like. Have you installed ERPNext before? What are you trying to use to install?

Yes i already install the erp in my system but now i do the fresh installetion…

For a fresh install, I suggest formatting everything.

Already i formated my ubutnu…and did the fresh installation but same error?

Are you doing the install properly? I think you might be missing a few steps.

sunrise@sunrise:~$ wget https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup_frappe.sh
–2016-04-11 21:17:13-- https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup_frappe.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 103.245.222.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|103.245.222.133|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 14154 (14K) [text/plain]
Saving to: `setup_frappe.sh’

100%[======================================>] 14,154 --.-K/s in 0s

2016-04-11 21:17:14 (276 MB/s) - `setup_frappe.sh’ saved [14154/14154]

sunrise@sunrise:~$ sudo bash setup_frappe.sh --setup-production
Installing for Ubuntu precise x86
In case you encounter an error, you can post on https://discuss.frappe.io

Adding ubuntu mariadb repo

Installing packages for Ubuntu. This might take time…
Installing wkhtmltopdf

  • Stopping MariaDB database server mysqld [ OK ]
  • Starting MariaDB database server mysqld [ OK ]
  • Checking for corrupt, not cleanly closed and upgrade needing tables.
    Adding frappe user
    Installing frappe-bench
    Traceback (most recent call last):
    File “/usr/local/bin/bench”, line 5, in
    from pkg_resources import load_entry_point
    File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 2707, in
    working_set.require(requires)
    File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 686, in require
    needed = self.resolve(parse_requirements(requirements))
    File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 584, in resolve
    raise DistributionNotFound(req)
    pkg_resources.DistributionNotFound: honcho

above command is not create a frappe-bench folder…

Try updating pip first using sudo pip install --upgrade pip and then try running it again

sunrise@sunrise:~$ sudo pip install --upgrade pip
The directory ‘/home/sunrise/.cache/pip/http’ or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
The directory ‘/home/sunrise/.cache/pip’ or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
/usr/local/lib/python2.7/dist-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
SNIMissingWarning
/usr/local/lib/python2.7/dist-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
Requirement already up-to-date: pip in /usr/local/lib/python2.7/dist-packages
sunrise@sunrise:~$

sunrise@sunrise:~/dell/frappe-bench$ bench update
Updating 6dc236f…4223b37
error: Your local changes to the following files would be overwritten by merge:
bench/release.py
install_scripts/setup_frappe.sh
Please, commit your changes or stash them before you can merge.
Aborting
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==0.92’, ‘console_scripts’, ‘bench’)()
File “/home/sunrise/dell/bench-repo/bench/cli.py”, line 60, in cli
bench()
File “/usr/local/lib/python2.7/dist-packages/click-6.4-py2.7.egg/click/core.py”, line 716, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click-6.4-py2.7.egg/click/core.py”, line 696, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click-6.4-py2.7.egg/click/core.py”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click-6.4-py2.7.egg/click/core.py”, line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click-6.4-py2.7.egg/click/core.py”, line 534, in invoke
return callback(*args, **kwargs)
File “/home/sunrise/dell/bench-repo/bench/cli.py”, line 229, in _update
update_bench()
File “/home/sunrise/dell/bench-repo/bench/utils.py”, line 219, in update_bench
exec_cmd(“git pull”, cwd=cwd)
File “/home/sunrise/dell/bench-repo/bench/utils.py”, line 104, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git pull
sunrise@sunrise:~/dell/frappe-bench$

Hi,

You have some local changes you’ve made in the bench-repo folder, specifically the files:

bench/release.py and
install_scripts/setup_frappe.sh

You should run git stash inside the bench-repo folder and then try running update again

sunrise@sunrise:~/bench-repo$ git stash
No local changes to save
sunrise@sunrise:~/bench-repo$