Errors while setting up the account initially

Hello Team,

I just installed ERPNext app on my ubuntu 14.04 LTS 64 bit, although installation seems fine and I am able to run it on my browser using port 8000.
I am having a problem that I am not able to set up my account and getting the errors on the browser screen at the last step for setting up the account.

There were errros // message I am getting on my browser screen.
I reinstalled the bench and ERPNext app on the browser, but no luck. Also followed threads about the same issue on https://discuss.erpnext.com/

Please help me on this that how I can resolve this error.

Thanks
Virender

Share screen shots or full error trace.

Hello Team,

Please find the screenshot of error. We are only getting this when we are setting up account initially.

Also please find the logs, when we are starting bench.

09:41:48 system           | redis_socketio.1 started (pid=2328)
09:41:48 redis_socketio.1 | 2334:C 03 Oct 09:41:48.571 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
09:41:48 redis_socketio.1 | 2334:C 03 Oct 09:41:48.571 # Redis version=4.0.2, bits=64, commit=00000000, modified=0, pid=2334, just started
09:41:48 redis_socketio.1 | 2334:C 03 Oct 09:41:48.571 # Configuration loaded
09:41:48 redis_socketio.1 | 2334:M 03 Oct 09:41:48.572 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
09:41:48 redis_socketio.1 | 2334:M 03 Oct 09:41:48.572 # Server can't set maximum open files to 10032 because of OS error: Operation not permitted.
09:41:48 redis_socketio.1 | 2334:M 03 Oct 09:41:48.572 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase 'ulimit -n'.
09:41:48 redis_socketio.1 | 2334:M 03 Oct 09:41:48.573 * Running mode=standalone, port=12000.
09:41:48 redis_socketio.1 | 2334:M 03 Oct 09:41:48.574 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
09:41:48 redis_socketio.1 | 2334:M 03 Oct 09:41:48.574 # Server initialized
09:41:48 redis_socketio.1 | 2334:M 03 Oct 09:41:48.574 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
09:41:48 redis_socketio.1 | 2334:M 03 Oct 09:41:48.574 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
09:41:48 redis_socketio.1 | 2334:M 03 Oct 09:41:48.574 * Ready to accept connections
09:41:48 system           | watch.1 started (pid=2337)
09:41:48 system           | worker_long.1 started (pid=2331)
09:41:48 system           | worker_default.1 started (pid=2346)
09:41:48 system           | schedule.1 started (pid=2347)
09:41:48 system           | redis_cache.1 started (pid=2348)
09:41:48 redis_cache.1    | 2351:C 03 Oct 09:41:48.598 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
09:41:48 redis_cache.1    | 2351:C 03 Oct 09:41:48.598 # Redis version=4.0.2, bits=64, commit=00000000, modified=0, pid=2351, just started
09:41:48 redis_cache.1    | 2351:C 03 Oct 09:41:48.598 # Configuration loaded
09:41:48 redis_cache.1    | 2351:M 03 Oct 09:41:48.619 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
09:41:48 redis_cache.1    | 2351:M 03 Oct 09:41:48.619 # Server can't set maximum open files to 10032 because of OS error: Operation not permitted.
09:41:48 redis_cache.1    | 2351:M 03 Oct 09:41:48.619 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase 'ulimit -n'.
09:41:48 redis_cache.1    | 2351:M 03 Oct 09:41:48.620 * Running mode=standalone, port=13000.
09:41:48 redis_cache.1    | 2351:M 03 Oct 09:41:48.620 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
09:41:48 redis_cache.1    | 2351:M 03 Oct 09:41:48.620 # Server initialized
09:41:48 redis_cache.1    | 2351:M 03 Oct 09:41:48.620 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
09:41:48 redis_cache.1    | 2351:M 03 Oct 09:41:48.620 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
09:41:48 redis_cache.1    | 2351:M 03 Oct 09:41:48.620 * Ready to accept connections
09:41:48 system           | web.1 started (pid=2356)
09:41:48 system           | socketio.1 started (pid=2349)
09:41:48 system           | worker_short.1 started (pid=2355)
09:41:48 system           | socketio.1 started (pid=2349)
09:41:48 system           | worker_short.1 started (pid=2355)
09:41:48 system           | redis_queue.1 started (pid=2364)
09:41:48 redis_queue.1    | 2370:C 03 Oct 09:41:48.625 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
09:41:48 redis_queue.1    | 2370:C 03 Oct 09:41:48.625 # Redis version=4.0.2, bits=64, commit=00000000, modified=0, pid=2370, just started
09:41:48 redis_queue.1    | 2370:C 03 Oct 09:41:48.625 # Configuration loaded
09:41:48 redis_queue.1    | 2370:M 03 Oct 09:41:48.626 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
09:41:48 redis_queue.1    | 2370:M 03 Oct 09:41:48.626 # Server can't set maximum open files to 10032 because of OS error: Operation not permitted.
09:41:48 redis_queue.1    | 2370:M 03 Oct 09:41:48.626 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase 'ulimit -n'.
09:41:48 redis_queue.1    | 2370:M 03 Oct 09:41:48.635 * Running mode=standalone, port=11000.
09:41:48 redis_queue.1    | 2370:M 03 Oct 09:41:48.635 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
09:41:48 redis_queue.1    | 2370:M 03 Oct 09:41:48.635 # Server initialized
09:41:48 redis_queue.1    | 2370:M 03 Oct 09:41:48.635 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
09:41:48 redis_queue.1    | 2370:M 03 Oct 09:41:48.635 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
09:41:48 redis_queue.1    | 2370:M 03 Oct 09:41:48.635 * Ready to accept connections
09:41:50 socketio.1       | listening on *: 9000
09:41:52 worker_long.1    | 09:41:52 RQ worker u'rq:worker:TSPL-PC-22.2340.long' started, version 0.8.2
09:41:52 worker_long.1    | 09:41:52 Cleaning registries for queue: long
09:41:52 worker_long.1    | 09:41:52
09:41:52 worker_long.1    | 09:41:52 *** Listening on long...
09:41:52 worker_short.1   | 09:41:52 RQ worker u'rq:worker:TSPL-PC-22.2377.short' started, version 0.8.2
09:41:52 worker_default.1 | 09:41:52 RQ worker u'rq:worker:TSPL-PC-22.2353.default' started, version 0.8.2
09:41:52 worker_short.1   | 09:41:52 Cleaning registries for queue: short
09:41:52 worker_default.1 | 09:41:52 Cleaning registries for queue: default
09:41:52 worker_default.1 | 09:41:52
09:41:52 worker_default.1 | 09:41:52 *** Listening on default...
09:41:52 worker_short.1   | 09:41:52
09:41:52 worker_short.1   | 09:41:52 *** Listening on short...
09:41:53 web.1            |  * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
09:41:53 web.1            |  * Restarting with inotify reloader
09:41:53 web.1            |  * Debugger is active!
09:41:54 web.1            |  * Debugger PIN: 326-550-052
09:42:01 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:01] "^[[37mGET / HTTP/1.1^[[0m" 200 -
09:42:02 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:02] "^[[37mGET /website_theme.css HTTP/1.1^[[0m" 200 -
09:42:02 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:02] "^[[37mGET /assets/frappe/css/bootstrap.css HTTP/1.1^[[0m" 200 -
09:42:02 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:02] "^[[37mGET /assets/erpnext/css/website.css HTTP/1.1^[[0m" 200 -
09:42:02 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:02] "^[[37mGET /assets/css/frappe-web.css HTTP/1.1^[[0m" 200 -
09:42:02 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:02] "^[[37mGET /assets/js/frappe-web.min.js HTTP/1.1^[[0m" 200 -
09:42:02 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:02] "^[[37mGET /assets/css/frappe-web.css HTTP/1.1^[[0m" 200 -
09:42:02 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:02] "^[[37mGET /assets/js/frappe-web.min.js HTTP/1.1^[[0m" 200 -
09:42:02 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:02] "^[[37mGET /assets/frappe/js/lib/jquery/jquery.min.js HTTP/1.1^[[0m" 200 -
09:42:02 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:02] "^[[37mGET /assets/js/erpnext-web.min.js HTTP/1.1^[[0m" 200 -
09:42:02 web.1            | 10.10.10.14 - - [03/Oct/2017 09:42:02] "^[[37mGET /website_script.js HTTP/1.1^[[0m" 200 -
09:42:03 watch.1          | compiling avatar.less
09:42:03 watch.1          | compiling calendar.less
09:42:03 watch.1          | compiling common.less
09:42:03 watch.1          | compiling desk.less
09:42:03 watch.1          | compiling desktop.less
09:42:03 watch.1          | compiling docs.less
09:42:03 watch.1          | compiling email.less
09:42:03 watch.1          | compiling form.less
09:42:03 watch.1          | compiling form_grid.less
09:42:03 watch.1          | compiling gantt.less
09:42:03 watch.1          | compiling graphs.less
09:42:03 watch.1          | compiling indicator.less
09:42:03 watch.1          | compiling kanban.less
09:42:03 watch.1          | compiling list.less
09:42:03 watch.1          | compiling mixins.less
09:42:03 watch.1          | compiling mobile.less
09:42:03 watch.1          | compiling module.less
09:42:03 watch.1          | compiling navbar.less
09:42:03 watch.1          | compiling page.less
09:42:03 watch.1          | compiling report.less
09:42:03 watch.1          | compiling role_editor.less
09:42:03 watch.1          | compiling sidebar.less
09:42:03 watch.1          | compiling slickgrid.less
09:42:03 watch.1          | compiling tree.less
09:42:03 watch.1          | compiling website.less
09:42:03 watch.1          | compiling email.less
09:42:03 watch.1          | compiling erpnext.less
09:42:03 watch.1          | compiling pos.less
09:42:03 watch.1          | compiling website.less
09:42:03 watch.1          | file watching on *: 6787
09:42:04 watch.1          | Less files compiled
09:42:04 watch.1          | Wrote css/frappe-web.css - 65.44 KB
09:42:06 watch.1          | Wrote js/frappe-web.min.js - 133.03 KB
09:42:07 watch.1          | Wrote js/control.min.js - 62.48 KB
09:42:08 watch.1          | Wrote js/dialog.min.js - 110.14 KB
09:42:08 watch.1          | Wrote css/desk.min.css - 296.94 KB
09:42:08 watch.1          | Wrote css/frappe-rtl.css - 32.61 KB
09:42:08 watch.1          | Wrote js/libs.min.js - 843.7 KB

Thanks
Virender Rana

Hi @Ittrigma

I had a similar issue a while back and I think someone pointed out the sample data was causing this error so try and uncheck that option while running setup.

HI @mwai

How I can uncheck the sample data while running setup? Are you talking about uncheck the sample data, when we start setup by running bench start or Is there anything related to configuration?

Thanks
Virender Rana

Hi All,

Is there anybody, who can help me out with this?

Thanks
Virender Rana

Hi @Pawan

Please help me on this.