ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

Errors during install

Hello, I have installed erp-next on Ubuntu 18.04.6 with Python 3.6.9 and nodejs 14.18.3

There were some errors such as the dependencies for pyjwt, requests and unidecode were different versions.

Additionally the mixins file (I’m not sure what that is) was not found.

Should I try to resolve these issues before continuing?

>  bench get-app erpnext
Getting erpnext
$ git clone https://github.com/frappe/erpnext.git  --depth 1 --origin upstream
Cloning into 'erpnext'...
remote: Enumerating objects: 6574, done.
remote: Counting objects: 100% (6574/6574), done.
remote: Compressing objects: 100% (5291/5291), done.
remote: Total 6574 (delta 1472), reused 3307 (delta 978), pack-reused 0
Receiving objects: 100% (6574/6574), 18.03 MiB | 1.64 MiB/s, done.
Resolving deltas: 100% (1472/1472), done.
Installing erpnext
$ /home/frappe/frappe-bench/env/bin/python -m pip install --quiet --upgrade -e /home/frappe/frappe-bench/apps/erpnext 
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
frappe 12.25.0 requires PyJWT==1.7.1, but you have pyjwt 2.3.0 which is incompatible.
frappe 12.25.0 requires requests==2.22.0, but you have requests 2.27.1 which is incompatible.
frappe 12.25.0 requires Unidecode==1.1.1, but you have unidecode 1.2.0 which is incompatible.
$ yarn install
yarn install v1.22.17
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...
Done in 3.68s.
$ bench build --app erpnext
yarn run v1.22.17
$ FRAPPE_ENV=production node rollup/build.js --app erpnext
Production mode
✔ Built js/moment-bundle.min.js
✔ Built js/libs.min.js

Building erpnext assets...

Error: File to import not found or unreadable: frappe/public/scss/common/mixins.
✔ Built css/erpnext-web.css
✔ Built js/erpnext-web.min.js
✔ Built js/bank-reconciliation-tool.min.js
✔ Built js/item-dashboard.min.js
Browserslist: caniuse-lite is outdated. Please run:
npx browserslist@latest --update-db

Why you should do it regularly:
https://github.com/browserslist/browserslist#browsers-data-updating
✔ Built css/erpnext.css
✔ Built js/erpnext.min.js
✔ Built js/point-of-sale.min.js
✔ Built js/hierarchy-chart.min.js
✨  Done in 9.665s
Done in 14.08s.

Just a quick update. I did continue on with: ./env/bin/pip3 install -e apps/erpnext/

and it ended with: Successfully installed erpnext-14.0.0.dev0

but then

bench --site erp-baby2.local install-app erpnext

Installing erpnext…
Updating DocTypes for erpnext : [ ]An error occurred while installing erpnext:
Module import failed for POS Invoice (erpnext.accounts.doctype.pos_invoice.pos_invoice Error: No module named ‘frappe.query_builder’)

I am following:

thank you