ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

Error while updating erpnext inside vagrant


#1

hello everyone.
i am trying to install erpnext inside vagrant box for development by following this link. when i try to bench update i get following error.

Could not find a version that satisfies the requirement dropbox==9.1.0 (from frappe==11.1.14) (from versions: )
No matching distribution found for dropbox==9.1.0 (from frappe==11.1.14)
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/.bench/bench/cli.py”, line 40, in cli
bench_command()
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/.bench/bench/commands/update.py”, line 60, in update
_update(pull, patch, build, bench, auto, restart_supervisor, restart_systemd, requirements, no_backup, force=force, reset=reset)
File “/home/frappe/.bench/bench/commands/update.py”, line 76, in _update
update_requirements(bench_path=bench_path)
File “/home/frappe/.bench/bench/utils.py”, line 435, in update_requirements
install_app(app, bench_path=bench_path)
File “/home/frappe/.bench/bench/app.py”, line 171, in install_app
find_links=find_links))
File “/home/frappe/.bench/bench/utils.py”, line 159, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: ./env/bin/pip install -q -e ./apps/frappe

please help.

Regards
Ujjwal.


#2

It says that the python library dropbox, version 9.1.0 is missing in your vagrant box and could not be installed automatically.


#3

thanks.
but after installing python library now i get new error. it says Error: No such command "serve and Error: No such command “worker”.
following are the error…

2789:M 12 Mar 10:26:36.275 # Server started, Redis version 3.0.6
10:26:36 redis_cache.1 | 2789:M 12 Mar 10:26:36.277 * The server is now ready to accept connections on port 13000
10:26:36 system | worker_short.1 started (pid=2778)
10:26:56 socketio.1 | listening on *: 9000
10:27:35 web.1 | Usage: bench [OPTIONS] COMMAND [ARGS]…
10:27:35 web.1 |
10:27:35 web.1 | Error: No such command “serve”.
10:27:35 watch.1 | Usage: bench [OPTIONS] COMMAND [ARGS]…
10:27:35 watch.1 |
10:27:35 watch.1 | Error: No such command “watch”.
10:27:35 worker_default.1 | Usage: bench [OPTIONS] COMMAND [ARGS]…
10:27:35 worker_default.1 |
10:27:35 worker_default.1 | Error: No such command “worker”.
10:27:35 system | web.1 stopped (rc=2)
10:27:35 system | sending SIGTERM to redis_socketio.1 (pid 2748)
10:27:35 system | sending SIGTERM to worker_long.1 (pid 2759)
10:27:35 system | sending SIGTERM to watch.1 (pid 2750)
10:27:35 system | sending SIGTERM to redis_queue.1 (pid 2770)
10:27:35 system | sending SIGTERM to schedule.1 (pid 2773)
10:27:35 system | sending SIGTERM to worker_default.1 (pid 2766)
10:27:35 system | sending SIGTERM to socketio.1 (pid 2774)
10:27:35 system | sending SIGTERM to redis_cache.1 (pid 2768)
10:27:35 system | sending SIGTERM to worker_short.1 (pid 2778)
10:27:35 redis_socketio.1 | 2760:signal-handler (1552386455) Received SIGTERM scheduling shutdown…
10:27:35 redis_socketio.1 | 2760:M 12 Mar 10:27:35.504 # User requested shutdown…
10:27:35 redis_socketio.1 | 2760:M 12 Mar 10:27:35.505 # Redis is now ready to exit, bye bye…
10:27:35 system | redis_socketio.1 stopped (rc=-15)
10:27:35 redis_queue.1 | 2782:signal-handler (1552386455) Received SIGTERM scheduling shutdown…
10:27:35 redis_cache.1 | 2789:signal-handler (1552386455) Received SIGTERM scheduling shutdown…
10:27:35 system | worker_default.1 stopped (rc=-15)
10:27:35 system | schedule.1 stopped (rc=-15)
10:27:35 redis_queue.1 | 2782:M 12 Mar 10:27:35.594 # User requested shutdown…
10:27:35 redis_queue.1 | 2782:M 12 Mar 10:27:35.595 # Redis is now ready to exit, bye bye…
10:27:35 system | redis_queue.1 stopped (rc=-15)
10:27:35 system | watch.1 stopped (rc=-15)
10:27:35 redis_cache.1 | 2789:M 12 Mar 10:27:35.617 # User requested shutdown…
10:27:35 redis_cache.1 | 2789:M 12 Mar 10:27:35.617 # Redis is now ready to exit, bye bye…
10:27:35 system | redis_cache.1 stopped (rc=-15)
10:27:35 system | worker_long.1 stopped (rc=-15)
10:27:35 system | socketio.1 stopped (rc=-15)
10:27:35 system | worker_short.1 stopped (rc=-15)


#4

I don’t have a clue about this one, sorry.


#5

When this happens, rerunning ‘bench update’ again one or twice more can solve the problem.


#6

This post was flagged by the community and is temporarily hidden.