ERROR: pip change how it resolve conflicts

When installing Frappe in MacOS Mojave, I got this:

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

google-api-core 1.22.1 requires google-auth<2.0dev,>=1.19.1, but you'll have google-auth 1.18.0 which is incompatible.

I don’t know if this occur on other OS or not.
Is there anything I should do or just ignore it?
Thank you

1 Like

i have the same issue
Ubuntu 18.04 DigitalOcean Droplet

just version mismatch in frappe/requirements.txt

there was a fix in version-12-hotfix and waiting to be inside version-12-prerelease and then version-12?

you can fork version-12 or else and fix it by raising the version then specify your repo while production

example flags

–frappe-repo-url --frappe-branch version-12

i think frappe branch is hardcoded as either version-12 or develop.

if you have own repo and different branch than version-12, you need to remove frappe after installation and get-app immediately after installation using your url and your branch.

The first error message is regarding pip changing how it resolves it’s dependencies. I’ve tested setting up requirements using the new resolver and there seems to be no issues whatsoever.

The second one says that there’s a possibly incompatible dependency installed. The PR by @adamtang79 fixes the issue. However, it’s alright to just go ahead with the current setup. You wouldn’t face any issues…However, if you still want to be sure, you can just run bench pip install --force-reinstall google-auth==1.19.1 from your bench directory.