Error bench starting

bench start
13:58:40 system | worker.1 started (pid=3583)
13:58:40 system | workerbeat.1 started (pid=3582)
13:58:40 system | redis_async_broker.1 started (pid=3590)
13:58:40 redis_async_broker.1 | [3593] 28 Feb 13:58:40.424 * Increased maximum number of open files to 10032 (it was originally set to 1024).
13:58:40 system | socketio.1 started (pid=3589)
13:58:40 system | web.1 started (pid=3588)
13:58:40 redis_async_broker.1 | [3593] 28 Feb 13:58:40.426 # Warning: 32 bit instance detected but no memory limit set. Setting 3 GB maxmemory limit with ‘noeviction’ policy now.
13:58:40 system | redis_cache.1 started (pid=3592)
13:58:40 redis_async_broker.1 | .
13:58:40 redis_async_broker.1 | .-__ ''-._ 13:58:40 redis_async_broker.1 | _.- .. ‘’-._ Redis 2.8.19 (00000000/0) 32 bit
13:58:40 redis_async_broker.1 | .-.-```. ```\/ _.,_ ''-._ 13:58:40 redis_async_broker.1 | ( ' , .-` | `, ) Running in stand alone mode 13:58:40 redis_async_broker.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 12311 13:58:40 redis_async_broker.1 | |-. ._ / _.-' | PID: 3593 13:58:40 redis_async_broker.1 |-._ -._-./ .-’ .-’
13:58:40 redis_async_broker.1 | |-._-.
-.__.-' _.-'_.-'| 13:58:40 redis_async_broker.1 | |-.
-._ _.-'_.-' | http://redis.io 13:58:40 redis_async_broker.1 |-._ -._-..-’.-’ .-’
13:58:40 redis_async_broker.1 | |-._-.
-.__.-' _.-'_.-'| 13:58:40 redis_async_broker.1 | |-.
-._ _.-'_.-' | 13:58:40 redis_async_broker.1 |-._ -._-.
.-’.-’ .-’
13:58:40 redis_async_broker.1 | -._-..-’ _.-’
13:58:40 redis_async_broker.1 | -._ _.-' 13:58:40 redis_async_broker.1 |-.
.-’
13:58:40 redis_async_broker.1 |
13:58:40 redis_async_broker.1 | [3593] 28 Feb 13:58:40.433 # Server started, Redis version 2.8.19
13:58:40 redis_async_broker.1 | [3593] 28 Feb 13:58:40.433 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
13:58:40 redis_async_broker.1 | [3593] 28 Feb 13:58:40.433 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
13:58:40 redis_async_broker.1 | [3593] 28 Feb 13:58:40.434 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
13:58:40 redis_async_broker.1 | [3593] 28 Feb 13:58:40.434 * The server is now ready to accept connections on port 12311
13:58:40 redis_cache.1 | [3600] 28 Feb 13:58:40.443 * Increased maximum number of open files to 10032 (it was originally set to 1024).
13:58:40 redis_cache.1 | .
13:58:40 redis_cache.1 | .-__ ''-._ 13:58:40 redis_cache.1 | _.- .. ‘’-.
Redis 2.8.19 (00000000/0) 32 bit
13:58:40 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 13:58:40 redis_cache.1 | ( ' , .-` | `, ) Running in stand alone mode 13:58:40 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 11311 13:58:40 redis_cache.1 | |-._ ._ / _.-' | PID: 3600 13:58:40 redis_cache.1 |-._ -._-./ .-’ .-’
13:58:40 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 13:58:40 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 13:58:40 redis_cache.1 |-._ -._-..-’.-’ .-’
13:58:40 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 13:58:40 redis_cache.1 | |-.
-._ _.-'_.-' | 13:58:40 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
13:58:40 redis_cache.1 | -._-..-’ _.-’
13:58:40 redis_cache.1 | -._ _.-' 13:58:40 redis_cache.1 |-.
.-’
13:58:40 redis_cache.1 |
13:58:40 redis_cache.1 | [3600] 28 Feb 13:58:40.449 # Server started, Redis version 2.8.19
13:58:40 redis_cache.1 | [3600] 28 Feb 13:58:40.449 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
13:58:40 redis_cache.1 | [3600] 28 Feb 13:58:40.449 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
13:58:40 redis_cache.1 | [3600] 28 Feb 13:58:40.449 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
13:58:40 redis_cache.1 | [3600] 28 Feb 13:58:40.449 * The server is now ready to accept connections on port 11311
13:58:40 worker.1 | /home/administrator/frappe-bench/sites/…/env/bin/python: No module named bleach_whitelist
13:58:40 system | worker.1 stopped (rc=1)
13:58:40 system | sending SIGTERM to workerbeat.1 (pid 3582)
13:58:40 system | sending SIGTERM to web.1 (pid 3588)
13:58:40 system | sending SIGTERM to socketio.1 (pid 3589)
13:58:40 system | sending SIGTERM to redis_async_broker.1 (pid 3590)
13:58:40 system | sending SIGTERM to redis_cache.1 (pid 3592)
13:58:40 redis_async_broker.1 | [3593 | signal handler] (1456660720) Received SIGTERM scheduling shutdown…
13:58:40 redis_async_broker.1 | [3593] 28 Feb 13:58:40.706 # User requested shutdown…
13:58:40 redis_async_broker.1 | [3593] 28 Feb 13:58:40.706 # Redis is now ready to exit, bye bye…
13:58:40 system | redis_async_broker.1 stopped (rc=-15)
13:58:40 system | web.1 stopped (rc=-15)
13:58:40 redis_cache.1 | [3600 | signal handler] (1456660720) Received SIGTERM scheduling shutdown…
13:58:40 redis_cache.1 | [3600] 28 Feb 13:58:40.707 # User requested shutdown…
13:58:40 redis_cache.1 | [3600] 28 Feb 13:58:40.707 # Redis is now ready to exit, bye bye…
13:58:40 system | redis_cache.1 stopped (rc=-15)
13:58:40 system | workerbeat.1 stopped (rc=-15)
13:58:40 system | socketio.1 stopped (rc=-15)

You need to run bench update. bleach_whitelist is a new python requirement that was added in requirements.txt.

the error is came when i try to update bench.

I need to solve it quick. please help

Strange because bench update installs the requirements before pulling frappe/erpnext updates.

Anyway, you can run ./env/bin/pip install bleach bleach-whitelist

1 Like