ERPNext V5 Issue: Item Creation Error

After the latest update, I’m unable to add any new item.

http://imgur.com/P8nLyMo

Also, if it non-stockable item, it still asking for warehouse.

http://imgur.com/2rCvkk0

Hi @amruthp

The start of the naming series UCD.. and MT_RENT.. seems to be reset to 0. You will need to set it to an appropriate number.

-Anand.

@anand Tried different ways, any part I try to create it give UCD/0001 conversion error and says part already exists. I’m not sure where is this UCD/0001 ?

As Anand suggested, you have to reset the series number for “UCD/” to the latest number. Check https://erpnext.com/user-guide/setting-up/document-naming-series.

@nabinhait Thanks, but there is no UCDD naming series there ? I’m not able to find where is this UOM Conversion UCDD series. You can see the screenshot below

http://imgur.com/25qxaqd

There should “UCDD” in the series list. My local screenshot:

@nabinhait interesting, I can see UCDD in your screenshot, but I don’t have anything below TLB. Maybe your local fork is not updated to branch master ?

I did a update few hours ago with the ERPNEXT V5. Item creation error is coming, below is the attached logs

http://pastebin.com/7GEpWTNB

Unfortunately I can’t replicate this issue as well. There is ‘image’ field exists in the system. Please check whether in your instance “image” field exists or not. If it does not exists, try to reload item doctype forcefully.
bench frappe --reload_doc stock doctype item -f

@nabinhait Ureka I found the problem in the staging installation too, for you to test

http://staging5.erpnext.com/desk#Form/Item/New%20Item%201

Please create a new item there, the same error I’m have can been seen in this installation on your servers.

I did a fresh installation of the V5, just in case to see if it was not installed properly.

Even in the new one I’m not getting UCDD name series update

http://imgur.com/CPm2RtO

I even tried developer mode.

Not only UCDD, I’m also missing RTN to set item prices.

Is there any other setting I’m missing to turn on ?

@nabinhait After the latest update, Purchase order cannot be saved at all.

I check it in the staging also, same issue is coming in the staging site too

Thanks for reporting, fixed it.

In future if you get an issue, please raise the issue in https://github.com/frappe/erpnext/issues/, it will be easier to track.

@nabinhait After this update, I’m no longer able to login at all.

I’m raising it in the issues.