Try ERPNext Buy Support Partners Foundation

ERPNext runs very slow

Hi, erpnext works very slow even when only user is using the server with following configuration:
Ubuntu 16.04, 4GB Ram & 2 cores on digital ocean.

P.S: I have tested the same on 18.04, 4Gb Ram & 2cores hosted on digital ocean, nothing much changed.

1 Like

Check your mysql settings. there are some optimisations that you can do to improve performance there

Can you recommend something ?

Can you share/show your /etc/mysql/my.cnf

[client]
port		= 3306
socket		= /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket		= /var/run/mysqld/mysqld.sock
nice		= 0

[mysqld]
#
# * Basic Settings
#
user		= mysql
pid-file	= /var/run/mysqld/mysqld.pid
socket		= /var/run/mysqld/mysqld.sock
port		= 3306
basedir		= /usr
datadir		= /var/lib/mysql
tmpdir		= /tmp
lc_messages_dir	= /usr/share/mysql
lc_messages	= en_US
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address		= 127.0.0.1
#
# * Fine Tuning
#
max_connections		= 100
connect_timeout		= 5
wait_timeout		= 600
max_allowed_packet	= 16M
thread_cache_size       = 128
sort_buffer_size	= 4M
bulk_insert_buffer_size	= 16M
tmp_table_size		= 32M
max_heap_table_size	= 32M
#
# * MyISAM
#
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched. On error, make copy and try a repair.
myisam_recover_options = BACKUP
key_buffer_size		= 128M
#open-files-limit	= 2000
table_open_cache	= 400
myisam_sort_buffer_size	= 512M
concurrent_insert	= 2
read_buffer_size	= 2M
read_rnd_buffer_size	= 1M
#
# * Query Cache Configuration
#
# Cache only tiny result sets, so we can fit more in the query cache.
query_cache_limit		= 128K
query_cache_size		= 64M
# for more write intensive setups, set to DEMAND or OFF
#query_cache_type		= DEMAND
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file        = /var/log/mysql/mysql.log
#general_log             = 1
#
# Error logging goes to syslog due to /etc/mysql/conf.d/mysqld_safe_syslog.cnf.
#
# we do want to know about network errors and such
log_warnings		= 2
#
# Enable the slow query log to see queries with especially long duration
#slow_query_log[={0|1}]
slow_query_log_file	= /var/log/mysql/mariadb-slow.log
long_query_time = 10
#log_slow_rate_limit	= 1000
log_slow_verbosity	= query_plan

#log-queries-not-using-indexes
#log_slow_admin_statements
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id		= 1
#report_host		= master1
#auto_increment_increment = 2
#auto_increment_offset	= 1
log_bin			= /var/log/mysql/mariadb-bin
log_bin_index		= /var/log/mysql/mariadb-bin.index
# not fab for performance, but safer
#sync_binlog		= 1
expire_logs_days	= 10
max_binlog_size         = 100M
# slaves
#relay_log		= /var/log/mysql/relay-bin
#relay_log_index	= /var/log/mysql/relay-bin.index
#relay_log_info_file	= /var/log/mysql/relay-bin.info
#log_slave_updates
#read_only
#
# If applications support it, this stricter sql_mode prevents some
# mistakes like inserting invalid dates etc.
#sql_mode		= NO_ENGINE_SUBSTITUTION,TRADITIONAL
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
default_storage_engine	= InnoDB
# you can't just change log file size, requires special procedure
#innodb_log_file_size	= 50M
innodb_buffer_pool_size	= 256M
innodb_log_buffer_size	= 8M
innodb_file_per_table	= 1
innodb_open_files	= 400
innodb_io_capacity	= 400
innodb_flush_method	= O_DIRECT
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem

#
# * Galera-related settings
#
[galera]
# Mandatory settings
#wsrep_on=ON
#wsrep_provider=
#wsrep_cluster_address=
#binlog_format=row
#default_storage_engine=InnoDB
#innodb_autoinc_lock_mode=2
#
# Allow server to accept connections on all interfaces.
#
#bind-address=0.0.0.0
#
# Optional setting
#wsrep_slave_threads=1
#innodb_flush_log_at_trx_commit=0

[mysqldump]
quick
quote-names
max_allowed_packet	= 16M

[mysql]
#no-auto-rehash	# faster start of mysql but no tab completion

[isamchk]
key_buffer		= 16M

#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/

EDIT by @rahy : sorry to edit your post, but I help to make it more readable.

1 Like

You have this…

#innodb_log_file_size	= 50M
innodb_buffer_pool_size	= 256M
innodb_log_buffer_size	= 8M
innodb_file_per_table	= 1
innodb_open_files	= 400
innodb_io_capacity	= 400

To determine approximately decent values, run these commands in a terminal (with sudo privileges)


#The figures should be adjusted to suit YOUR system - which is guesstimated and implemented here...
physRAM=$(vmstat -s --unit M | awk '/total memory/ { print int( ($1)/1000 + 0.5) * 1024 } '); #printf "RAM:$physRAM\n";#4DBG#
innodbBufferPoolSize=$(($physRAM/2));             innodbBufferPoolSizeM=$(echo "$innodbBufferPoolSize""M");
innodbLogFileSize=$(($innodbBufferPoolSize/4));   innodbLogFileSizeM=$(echo "$innodbLogFileSize""M");
innodbLogBufferSize=$(($innodbLogFileSize/2));    innodbLogBufferSizeM=$(echo "$innodbLogBufferSize""M");
printf "$innodbBufferPoolSizeM\t$innodbLogFileSizeM\t$innodbLogBufferSizeM\n";#4DBG#

Then in the mysql config files, set them something like this

innodb_buffer_pool_size=$innodbBufferPoolSizeM
# Set the log file size to about 25% of the buffer pool size
innodb_log_file_size=$innodbLogFileSizeM
innodb_log_buffer_size=$innodbLogBufferSizeM
# the default here is 4MB, or maybe ??16MB?? in more recent versions, which sometimes allows for disconnects in the middle of transactions
max_allowed_packet=32M

Restart mysql and ERPNext

I have set the values as the RAM is 2GB at the moment.

innodb_log_file_size    = 256M
innodb_buffer_pool_size = 1028M
innodb_log_buffer_size  = 128M

> service mysql restart
> bench restart

No change observerd as of yet.

2GB is quite low for the newer versions of ERPNext - 4 is recommended

I have tested for 4GB as well, no change, with following settings:

innodb_log_file_size    = 1028M
innodb_buffer_pool_size = 2056M
innodb_log_buffer_size  = 512M

max_allowed_packet=32M

You need to check if your system is swapping to disk - this causes major performance issues (linked to insufficient RAM) - what does this show

free -mh
#or
free -mh | awk ‘/Swap/ {print $3}’;

Mem:           3.9G        1.2G        1.6G         14M        1.1G        2.4G
Swap:          1.0G          0B        1.0G

@trentmu what should be done now.

Are you basing your judgement of speed on other ERPNext experiences or is this a first impression?

Are there any ERPNext operations that seem especially slow?

If possible, a screenshot of the top or htop command may be useful

Stock balance is taking around 30 secs to load.

Are there a large number of Items in stock?

The frappe process is using 100% cpu in that shot, was the Stock balance loading when it was taken?

There are 2800 items in stock. I don’t think its a huge number to tackle with 4GB ram and CPU with 2 cores.

I assume, mysql database needs to be optimize for this number of items? any suggestion on how to do it ?

See if anything here can be helpful: https://mariadb.com/kb/en/optimization-and-tuning/ , though @trentmu may have covered some of that.

There is also mtop/mytop that may be useful.

Not sure it is a DBMS problem. What is the version of ERPNext?

The mysqld is using most of your RAM, which indicates a problem on dirty cache buffers

1 Like

Any tip for the solution ?