Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

ERPNext installation on Google Cloud platform

I tried since last 2 days.
Can anyone help to get ride over erpnext on gcp free tier?

I have registered google Cloud for 1 year free for experiment.

Thanks

Use the easy install script

Its amazing !!! Just took 30 min and done.

–Installation configuration
Google Cloud Platform (tried on 1 Year Free tier)
Ubuntu 16.04.6 LTS (GNU/Linux 4.15.0-1078-gcp x86_64)

smthakor1979@instance-2:~$ sudo su

root@instance-2:/home/smthakor1979# apt-get update

root@instance-2:/home/smthakor1979# apt-get upgrade

root@instance-2:/home/smthakor1979# wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py

root@instance-2:/home/smthakor1979# sudo python install.py --production

–Bench’s CLI needs these to be defined!
–Run the following commands in shell:

root@instance-2:/home/smthakor1979# export LC_ALL=C.UTF-8

– run again
root@instance-2:/home/smthakor1979# sudo python install.py --production

–First password for Mysql
–Second password for ERPNext Login

root@instance-2:/home/smthakor1979# sudo su - frappe

frappe@instance-2:~ cd frappe-bench/sites

frappe@instance-2:~ mv site1.local mytesterp.com

frappe@instance-2:~ nano mycompany.com/site_config.json

–Add This Line below MariaDB
“host_name”: “http://mytesterp.com”,

–save and close nano

frappe@instance-2:~/frappe-bench$ sudo bench config dns_multitenant on

frappe@instance-2:~/frappe-bench$ sudo bench setup add-domain mysite.com
Site: mysite.com

frappe@instance-2:~/frappe-bench$ sudo -H bench setup lets-encrypt mysite.com

Do you want to continue? [y/N]: y

(A)gree/©ancel: A

frappe@instance-2:~/frappe-bench$

5 Likes

unfortunately i could make it happen :roll_eyes:
File “install.py”, line 143, in install_prerequisites
‘python3’: “sudo -H python3 -m pip install --upgrade setuptools cryptography ansible==2.8.5 pip”

I tried:
sudo python install.py --production
sudo python3 install.py --production
upgraded pip

both get lead to the same error above

1 Like

Same persistent issue with me

1 Like

I done it smoothly by switching to ubuntu 18.04 with V13 as directed :

1- sudo apt -y install git vim libffi-dev python-pip python3-distutils python-dev libssl-dev wkhtmltopdf
2- export LC_ALL=C.UTF-8
3- wget https://raw.githubusercontent.com/frappe/bench/develop/install.py sudo python3 install.py --verbose --production --user USER --mariadb-version 10.5 --frappe-branch version-13 --erpnext-branch version-13

1 Like

I thought he had directed Ubuntu 16.04, it has persistently given the same error with Ubuntu 16. Did you mean that i switch to Ubuntu 18.04?

This what i have done, switch to 18.04 , it was just a new GCP instance for me.

1 Like

When I run this command, it shows as follows:
It is recommended to run this script with Python 3
Do you still wish to continue? [Y/n]: y
Logs are saved under /tmp/logs/easy-install__2021-04-13__12-43.log
Checking System Compatibility…
ubuntu 16 is compatible!
curl already installed!
wget already installed!
git already installed!
pip3 already installed!
/usr/bin/python: No module named pip
Traceback (most recent call last):
File “install.py”, line 436, in
install_prerequisites()
File “install.py”, line 143, in install_prerequisites
‘python3’: “sudo -H python -m pip install --upgrade setuptools cryptography ansible==2.8.5 pip”
File “install.py”, line 118, in run_os_command
returncode = subprocess.check_call(command, shell=True, stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python2.7/subprocess.py”, line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘sudo -H python -m pip install --upgrade setuptools cryptography ansible==2.8
.5 pip’ returned non-zero exit status 1

Python version is 2.7.12

sudo apt-get install python3-dev
sudo apt-get install python3-setuptools python3-pip
sudo -H python -m pip install --upgrade setuptools 
sudo python3 install.py --production

Try this, I’ve just installed two instances on GCP - it worked for me.

Hi there, I followed your steps on GCP, it took root and erpnext admin password.
What is the next step after ‘sudo python3 install.py --verbose --production --user USER --mariadb-version 10.5 --frappe-branch version-13 --erpnext-branch version-13’?

did it run without errors ?

if no error try to access your ipadress and login using set password

jycob, steps completed without any error. But while trying to access using my external ipaddress, it shows ‘This site can’t be reached’.

sudo systemctl restart nginx

Doesn’t help!
After running ‘sudo python3 install.py --verbose --production --user USER --mariadb-version 10.5 --frappe-branch version-13 --erpnext-branch version-13’

do I need to also run remaining steps from your post viz:
> root@instance-2:/home/smthakor1979# sudo su - frappe
> frappe@instance-2:~ cd frappe-bench/sites
> frappe@instance-2:~ mv site1.local mytesterp.com
> frappe@instance-2:~ nano mycompany.com/site_config.json
> –Add This Line below MariaDB
> “host_name”: “http://mytesterp.com ”,… ??

sudo su - frappe : this command for change user [frappe is user]
cd frappe-bench/sites : go to directory where site folder is located.
mv site1.local [site name] : site1.local is default and this command move it to your domain name.
“host_name”: “http://mytesterp.com ”, add this line in ur site config.

Hi Aditya, followed your steps given on ERPNext Installation. Got this error:

Traceback (most recent call last):
File “install.py”, line 498, in
install_bench(args)
File “install.py”, line 279, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “install.py”, line 414, in run_playbook
success = subprocess.check_call(args, cwd=playbooks_folder, stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python3.6/subprocess.py”, line 311, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_
vars.json’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2.

@Aditya_Bagarka
It worked seamlessly when I retried using ubuntu20.04 (previously i was trying with 16.04).
Thanks a lot

1 Like